Zen Cart Logo
Forums / All Other Contributions/Addons / 1064 error with Super Order 2.0 rev45 & 1.3.7

1064 error with Super Order 2.0 rev45 & 1.3.7

Locked

Views: 1,328

Results 1 to 5 of 5
This thread is locked. New replies are disabled.
5 Jan 2007, 8:11 AM
#1
explorer1979 avatar

explorer1979

Inactive

Join Date:
Jan 2007
Posts:
377
Plugin Contributions:
0

1064 error with Super Order 2.0 rev45 & 1.3.7

Dear all,

I am using the Zen Cart 1.3.7, and my hosting using

PHP 4.3.3 (Zend 1.3.0)
MySQL 4.0.27-standard

Apache/1.3.33 (Unix) mod_auth_passthrough/1.8 mod_log_bytes/1.2 mod_bwlimited/1.4 FrontPage/5.0.2.2634a mod_ssl/2.8.21 OpenSSL/0.9.7a PHP-CGI/0.1b

After downloaded the Super Order 2.0 rev45 and Unzip it and following up the order to do, uploaded all file to the server, it all okay, but while I import the sql files using Tools --> Install SQL Patchs

and added the sql file and press the "Upload"

It show me this ERROR:

1064 You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'True', 'False'), ')' at line 1
in:
[INSERT INTO configuration VALUES (NULL, 'Enable Purchase Order Module', 'MODULE_PAYMENT_PURCHASE_ORDER_STATUS', 'True', 'Do you want to accept Purchase Order payments?', 6, 1, now(), now(), NULL, 'zen_cfg_select_option(array('True', 'False'), ');]
If you were entering information, press the BACK button in your browser and re-check the information you had entered to be sure you left no blank fields.

Any one can help me? Teach me how to fix this problems?

Thank for your time.

5 Jan 2007, 1:05 PM
#2
azrahn avatar

azrahn

Zen Follower

Join Date:
Jun 2006
Location:
Koh Samui
Posts:
120
Plugin Contributions:
0

Re: 1064 error with Super Order 2.0 rev45 & 1.3.7

Hi,

Better copy and paste the contents of the sql file in to the sql window.
This worked for me.

Ronald.

6 Jan 2007, 2:06 AM
#3
explorer1979 avatar

explorer1979

Inactive

Join Date:
Jan 2007
Posts:
377
Plugin Contributions:
0

Re: 1064 error with Super Order 2.0 rev45 & 1.3.7

azrahn,

Do you mean using the "Tools" --> "MySQL Patch" the big windows, copy and paste the sql file's code on it?

Thx for your suggestion and reply

6 Jan 2007, 3:10 AM
#4
explorer1979 avatar

explorer1979

Inactive

Join Date:
Jan 2007
Posts:
377
Plugin Contributions:
0

Re: 1064 error with Super Order 2.0 rev45 & 1.3.7

azrahn,

I am using your way to install the Super Order's SQL file, but it show me this

What is wrong on the bold block text?? Or I just igorned it is okay?

6 Jan 2007, 10:28 AM
#5
azrahn avatar

azrahn

Zen Follower

Join Date:
Jun 2006
Location:
Koh Samui
Posts:
120
Plugin Contributions:
0

Re: 1064 error with Super Order 2.0 rev45 & 1.3.7

Hi

The bold text is just.... bold text:yes:
Check if you have a admin>configuration>super orders entry.
Everything should be working now.

Ronald.