Zen Cart Logo
Forums / Installing on a Linux/Unix Server / Server error! ....server is overloaded or there was an error in a CGI script.

Server error! ....server is overloaded or there was an error in a CGI script.

Locked

Views: 33,680

Results 1 to 17 of 17
This thread is locked. New replies are disabled.
12 Jan 2007, 6:19 PM
#1
steely avatar

steely

New Zenner

Join Date:
Jan 2007
Posts:
18
Plugin Contributions:
0

Server error! ....server is overloaded or there was an error in a CGI script.

Hello,

Anybody have a clue why all of a sudden, when I try to download a file which is an attribute of a product, I get the following error page?
I changed permissions every which way


Server error!

The server encountered an internal error and was unable to complete your request.ither the server is overloaded or there was an error in a CGI script.

The results page is http://www.mywebsite.com/store/pub/.smywmnzcctudlxmvzvp/123.zip

I am running on Apache/2.0.54 (Debian GNU/Linux) mod_auth_pgsql/2.0.1 mod_ssl/2.0.54 OpenSSL/0.9.7e mod_perl/1.999.21 Perl/v5.8.4
:lookaroun

I have no issues with self-importance, therefore, I do not have a signature with useless links blatantly advertising little of interest.

12 Jan 2007, 6:50 PM
#2
Kim avatar

Kim

Obaa-san

Join Date:
Jun 2003
Location:
West Coast, North America
Posts:
26,650
Plugin Contributions:
0

Re: Server error! ....server is overloaded or there was an error in a CGI script.

Have you spoken to your host?

Please do not PM for support issues: a private solution doesn't benefit the community.

Be careful with unsolicited advice via email or PM - Make sure the person you are talking to is a reliable source.

13 Jan 2007, 11:10 AM
#3
steely avatar

steely

New Zenner

Join Date:
Jan 2007
Posts:
18
Plugin Contributions:
0

Re: Server error! ....server is overloaded or there was an error in a CGI script.

Kim:

Have you spoken to your host?

yes, indeedy. and there are server issues, so i'm relieved. :happy:

hope that's all there is.

thanks for your feedback.

cheers! :D

I have no issues with self-importance, therefore, I do not have a signature with useless links blatantly advertising little of interest.

17 Jan 2007, 4:05 AM
#4
steely avatar

steely

New Zenner

Join Date:
Jan 2007
Posts:
18
Plugin Contributions:
0

Re: Server error! ....server is overloaded or there was an error in a CGI script.

steely:

yes, indeedy. and there are server issues, so i'm relieved. :happy:

hope that's all there is.

thanks for your feedback.

cheers! :D

Well, I ain't happy. The problem is caused by the .htaccess file in the /pub/ folder. It contains the directive:

Options +FollowSymLinks -Indexes

which is actually forbidden directive on my host's machines.

once I've disabled the .htaccess, the system started returning 'Forbidden' error

Any way around this directive? I've spent a lot of time working w/the Zen Cart on a test site, not realizing it wouldn't work on this host's server, for whom I am actually reselling.

:P

I have no issues with self-importance, therefore, I do not have a signature with useless links blatantly advertising little of interest.

17 Jan 2007, 4:16 AM
#5
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: Server error! ....server is overloaded or there was an error in a CGI script.

You would have to turn off the Redirect in the Configuration ... Attribute settings ... which is less secure but should work ...

Linda McGrath
If you have to think ... you haven't been zenned ...

**Did YOU buy the Zen Cart Team a cup of coffee and a donut today? Just click here to support the Zen Cart Team!!**

Are you using the latest? Perhaps you've a problem that's fixed in the latest version: [Upgrade today!]
Officially PayPal-Certified! Just click here

Try our Zen Cart Recommended Services - Hosting, Payment and more ...
Signup for our Announcements Forums to stay up to date on important changes and updates!

17 Jan 2007, 6:11 AM
#6
steely avatar

steely

New Zenner

Join Date:
Jan 2007
Posts:
18
Plugin Contributions:
0

Re: Server error! ....server is overloaded or there was an error in a CGI script.

Ajeh:

You would have to turn off the Redirect in the Configuration ... Attribute settings ... which is less secure but should work ...

Life should be that simple. But it's not, and that didn't work. Getting this error:

Server error!
The server encountered an internal error and was unable to complete your request.
Error message:
Premature end of script headers: index.php

surely there must be a fix for this, can't be that we have to find hosts that will specifically accomodate - i've seen many posts on the web w/this sort of problem from others

:(

I have no issues with self-importance, therefore, I do not have a signature with useless links blatantly advertising little of interest.

17 Jan 2007, 6:29 AM
#7
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: Server error! ....server is overloaded or there was an error in a CGI script.

Hosts that do not allow you to control your own server are diffcult to work with ...

I am not sure if this is an .htaccess issue or some other setting that your host has limited you to ...

Linda McGrath
If you have to think ... you haven't been zenned ...

**Did YOU buy the Zen Cart Team a cup of coffee and a donut today? Just click here to support the Zen Cart Team!!**

Are you using the latest? Perhaps you've a problem that's fixed in the latest version: [Upgrade today!]
Officially PayPal-Certified! Just click here

Try our Zen Cart Recommended Services - Hosting, Payment and more ...
Signup for our Announcements Forums to stay up to date on important changes and updates!

17 Jan 2007, 5:31 PM
#8
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Server error! ....server is overloaded or there was an error in a CGI script.

Have you tried turning on Download by Streaming ?
If the server has a memory-configuration limitation, this should help get around it.

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

18 Jan 2007, 1:57 PM
#9
steely avatar

steely

New Zenner

Join Date:
Jan 2007
Posts:
18
Plugin Contributions:
0

Re: Server error! ....server is overloaded or there was an error in a CGI script.

Ajeh:

Hosts that do not allow you to control your own server are diffcult to work with ...

I am not sure if this is an .htaccess issue or some other setting that your host has limited you to ...

Thanks for your reply.
I mentioned in my post that the directive
Options +FollowSymLinks -Indexes
in the htaccess file is 'forbidden' by my host. Possibly for security reasons.
how much control should I have over a remote server?

This would be an issue of price, and this hosting is fine for my humble needs.
Now, if I could get the originators of this Zen cart to give us something to work around this Apache issue without giving up on the program...:bored:

I have no issues with self-importance, therefore, I do not have a signature with useless links blatantly advertising little of interest.

18 Jan 2007, 4:25 PM
#10
website_rob avatar

website_rob

Inactive

Join Date:
Oct 2006
Location:
Alberta, Canada
Posts:
4,572
Plugin Contributions:
0

Re: Server error! ....server is overloaded or there was an error in a CGI script.

Without using the .htaccess file you described, use your Browser and go to the images dir. of your site. Do you see a blank page or a listing of sub-directories and files.

Could be, if your Hoster is smart, that they have already disabled directory indexing; which is what the -Indexes means. If so, you do not need to use it any .htaccess file and things might work properly by just using:
Options +FollowSymLinks

If you cannot use the Options directive for anything, then you could ask your Hoster why that is so. Could be they've got some Server-wide security setup in place and can suggest an alternative directive to use.

The learning is in the doing.

Potent Products

18 Jan 2007, 5:17 PM
#11
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Server error! ....server is overloaded or there was an error in a CGI script.

... or go for streaming downloads instead of redirects, which forces apache to serve the file in 2K chunks rather than via a direct file link fed to the browser.

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

18 Jan 2007, 5:20 PM
#12
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Server error! ....server is overloaded or there was an error in a CGI script.

steely:

Anybody have a clue why all of a sudden, when I try to download a file which is an attribute of a product, I get the following error page?> Now, if I could get the originators of this Zen cart to give us something to work around this Apache issue without giving up on the program...

It's worth noting that the issue you're experiencing appears to be caused by something your host did recently ... hence the "all of a sudden" comment you started this topic with ...

Perhaps "giving up on the program" is misdirected a little ...

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

27 Sep 2007, 2:11 AM
#13
all4coffee avatar

all4coffee

Zen Follower

Join Date:
Jul 2007
Posts:
154
Plugin Contributions:
0

Re: Server error! ....server is overloaded or there was an error in a CGI script.

When sending reviews I get this error:
CGI Error

The specified CGI application misbehaved by not returning a complete set of HTTP headers

The review itself does appear in admin as everything would work fine... however when I edit the reviews it shows this note:

NOTE: HTML is not translated!

Test site address:
http://www.time-co.com/zencart/index.php?main_page=

I would appreciate any help...

27 Sep 2007, 2:27 AM
#14
all4coffee avatar

all4coffee

Zen Follower

Join Date:
Jul 2007
Posts:
154
Plugin Contributions:
0

Re: Server error! ....server is overloaded or there was an error in a CGI script.

all4coffee:

When sending reviews I get this error:
CGI Error

The specified CGI application misbehaved by not returning a complete set of HTTP headers

The review itself does appear in admin as everything would work fine... however when I edit the reviews it shows this note:

NOTE: HTML is not translated!

Test site address:
http://www.time-co.com/zencart/index.php?main_page=

I would appreciate any help...

When I tried it again it seems that the problem went away...

I have another question: it seems to me that only registered customers can write a review - is there a way to enable review writing to all visitors?

27 Sep 2007, 2:33 AM
#15
all4coffee avatar

all4coffee

Zen Follower

Join Date:
Jul 2007
Posts:
154
Plugin Contributions:
0

Re: Server error! ....server is overloaded or there was an error in a CGI script.

all4coffee:

When I tried it again it seems that the problem went away...

I have another question: it seems to me that only registered customers can write a review - is there a way to enable review writing to all visitors?

The message
CGI Error

The specified CGI application misbehaved by not returning a complete set of HTTP headers

when sending the review is back again.

NOW I discovered that the error is displayed only when I change Admin settings to "Reviews Require Approval" to ON =1 setting

Please help!

28 Sep 2007, 7:28 AM
#16
website_rob avatar

website_rob

Inactive

Join Date:
Oct 2006
Location:
Alberta, Canada
Posts:
4,572
Plugin Contributions:
0

Re: Server error! ....server is overloaded or there was an error in a CGI script.

all4coffee:

When sending reviews I get this error:
CGI Error

The specified CGI application misbehaved by not returning a complete set of HTTP headers

The review itself does appear in admin as everything would work fine... however when I edit the reviews it shows this note:

NOTE: HTML is not translated!

Test site address:
http://www.time-co.com/zencart/index.php?main_page=

I would appreciate any help...

The error msg. leads me to believe you are using an add-on Module. PHP code will not return a CGI error msg. -- unless perhaps, PHP is being run as CGI module.

You can find out for sure by using: Admin > Tools > Server Info and look for Server API. If it says CGI then PHP is being run as a CGI module and might explain the error msg. but not the problem. For that one would need to know the exact PHP file name used by Zen Cart and I don't know what it would be.

If the Server is running PHP as CGI and/or you are using an add-on Module that uses a file ending with '.cgi' or '.pl', then you need to make sure this code is used near the beginning or top of the file.

print "Content-type:text/html\n\n";

The learning is in the doing.

Potent Products

29 Sep 2007, 7:14 AM
#17
all4coffee avatar

all4coffee

Zen Follower

Join Date:
Jul 2007
Posts:
154
Plugin Contributions:
0

Re: Server error! ....server is overloaded or there was an error in a CGI script.

Thank you for response. It turned out to be a setting in Admin/Email which changed - literally by itself from SMTP to something else. When I changed it back to smtp all mail works fine including reviews.

Two days ago when I went to my site
http://www.time-co.com/zencart/

I noticed that my Academe template was gone and was replaced (not me!) with Classic template. I changed it back and it seems OK except that randomly some pages are scrambled to the right half of center column - when refreshed - goes away but then randomly happens again on another or the same page (if refreshing few times in a row)

WHAT COULD IT BE? Anyone had it happen I'm sure? Drives me nuts