Zen Cart Logo
Forums / All Other Contributions/Addons / MYSQL Backup addon error

MYSQL Backup addon error

Locked

Views: 12,030

Results 41 to 57 of 57
This thread is locked. New replies are disabled.
12 Feb 2010, 12:45 AM
#41
elijah avatar

elijah

New Zenner

Join Date:
Jul 2006
Posts:
33
Plugin Contributions:
0

MYSQL Backup addon error

ZC 1.3.7

I am getting an error as well when attempting to do a backup. I get "result code: 127" on the first line and "ERROR: Could not locate the MYSQLDUMP backup utility. BACKUP FAILED." on the second line.

I read "Note that LOCAL_EXE_MYSQL and LOCAL_EXE_MYSQL_DUMP are defined in the /admin/includes/languages/backup_mysql.php file." I don't, however, have a "backup_mysql.php" file in the languages folder. Should this have been created during the install of the mod or is this something that I need to create?

Thanks for your help.

12 Feb 2010, 2:16 AM
#42
fourbit avatar

fourbit

Zen Follower

Join Date:
Sep 2004
Location:
MONTANA!!!
Posts:
97
Plugin Contributions:
0

Re: MYSQL Backup addon error

Elijah,

Looks like you don't have everything uploaded. Yes, there is a backup_mysql.php file in the admin\includes\languages\english directory.

Make sure you upload all of the directories with their files in them.

Paul

Beeee the space between the drops!
[email protected]
Hosting Duo - We're in this together!

16 Feb 2010, 7:55 AM
#43
renz avatar

renz

Zen Follower

Join Date:
Jun 2006
Posts:
439
Plugin Contributions:
0

Re: MYSQL Backup addon error

Having some problems with the MYSQL DB Backup add on,
I have had this feature and I happen to use it religiously that was up until a few days ago when we moved server. At this point the backup button disappeared from the CP, myself and my new host tech have look at this thread and have tried numerous things, he has just emailed me the following as he still cant shed any light on it.

What have we missed, (I even tried a fresh install of the add on)
Thanks in advance zen 138a
RR

These have been checked:

  • Path to backup correct - /backups

  • backups folder has write permissions

  • open base_dir disabled

  • register globals on

  • php safe mode off

Still doesn't work.

16 Feb 2010, 8:13 AM
#44
fourbit avatar

fourbit

Zen Follower

Join Date:
Sep 2004
Location:
MONTANA!!!
Posts:
97
Plugin Contributions:
0

Re: MYSQL Backup addon error

Howdy RR,

Have you checked the Safe_mode? The code checks that at the server level. So, if it's on there and turned off locally, you will still have an issue with that backup button. Check out post number 38 in this thread. http://www.zen-cart.com/forum/showpost.php?p=841924&postcount=38

I had to change the code a bit.

Hope this helps.

Paul

Beeee the space between the drops!
[email protected]
Hosting Duo - We're in this together!

16 Feb 2010, 8:25 AM
#45
renz avatar

renz

Zen Follower

Join Date:
Jun 2006
Posts:
439
Plugin Contributions:
0

Re: MYSQL Backup addon error

Hi Thanks for that

The host said last in his list - php safe mode off I am pretty sure he would be talking at server level not sure how you turn it on/off locally that has not been altered but I can check if you advise on how.

Thanks

RR

16 Feb 2010, 2:08 PM
#46
fourbit avatar

fourbit

Zen Follower

Join Date:
Sep 2004
Location:
MONTANA!!!
Posts:
97
Plugin Contributions:
0

Re: MYSQL Backup addon error

RR,

You can check for that setting in Admin Tools>Server/Version info. Lots of info on server settings there. It will say at the top. But, check a bit further down in the "Configuration - PHP Core" section. It will tell you the Master Value and Local Value for the settings.

Paul

Beeee the space between the drops!
[email protected]
Hosting Duo - We're in this together!

17 Feb 2010, 10:48 AM
#47
renz avatar

renz

Zen Follower

Join Date:
Jun 2006
Posts:
439
Plugin Contributions:
0

Re: MYSQL Backup addon error

:clap:The advice you offered on the code change did the trick for me.....Many Thanks :thumbsup: Friend
Regards
RR

17 Feb 2010, 5:35 PM
#48
elijah avatar

elijah

New Zenner

Join Date:
Jul 2006
Posts:
33
Plugin Contributions:
0

Re: MYSQL Backup addon error

fourbit:

Elijah,

Looks like you don't have everything uploaded. Yes, there is a backup_mysql.php file in the admin\includes\languages\english directory.

Make sure you upload all of the directories with their files in them.

Paul

Hey Paul, thanks for the reply. I do have the backup_mysql.php file in the \english directory, I just thought the it was looking for it in the \languages directory as well. I double checked to make sure I have all files in the correct folders and they look fine, but I am still getting the error message that MYSQLDUMP backup utility cannot be found. Any ideas? My host is myhosting.com.

Cory

16 Nov 2010, 6:01 PM
#49
torvista avatar

torvista

Totally Zenned

Join Date:
Aug 2007
Location:
Gijón, Asturias, Spain
Posts:
2,875
Plugin Contributions:
7

Re: MYSQL Backup addon error

I have been locally backing-up and remotely-restoring for some time with no problems during the development phase.

Some problems I have with remote-backup/local-restore:

  1. I note that using this to backup the db on my remote hosting server will produce a compressed file when backed up to that server irrespective of whether No Compression is selected or not.

  2. A downloaded backup is generated as pure sql correctly.

  3. On a local pc, I cannot restore the compressed file produced in 1).
    It gives me the error:
    Failure: The database was NOT restored. ERROR: FILE NOT FOUND: [D:/My Documents/..etc which points to the right place.

  4. The pure sql from the remote, copied manually to that same directory as the 3) error on the local, restores ok.

Steve
github.com/torvista: BackupMySQL, Structured Data, Multiple Copy-Move-Delete, Google reCaptcha, Image Checker, Spanish Language Pack and more...

17 Nov 2010, 10:44 AM
#50
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: MYSQL Backup addon error

Evidently your local pc isn't capable of uncompressing the file properly. If the file is gzipped then you need a way to decompress the gzipped file. Most windoze computers don't do that natively. If you have a tool for doing that, you'll need to properly configure the compression tool filenames in the language file in order for it to use them.

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

17 Nov 2010, 11:03 AM
#51
torvista avatar

torvista

Totally Zenned

Join Date:
Aug 2007
Location:
Gijón, Asturias, Spain
Posts:
2,875
Plugin Contributions:
7

Re: MYSQL Backup addon error

ok, I understand, thanks.

What about point 1) where it ignores the compression/pure sql selection?

Steve
github.com/torvista: BackupMySQL, Structured Data, Multiple Copy-Move-Delete, Google reCaptcha, Image Checker, Spanish Language Pack and more...

17 Nov 2010, 11:14 AM
#52
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: MYSQL Backup addon error

No idea. Never had it do that to me. Granted, I don't see any good reason to do that, since uncompressed SQL files are prone to download problems, and are needlessly huge.

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

18 Nov 2010, 12:57 PM
#53
devilekk avatar

devilekk

New Zenner

Join Date:
Sep 2010
Posts:
5
Plugin Contributions:
0

Re: MYSQL Backup addon error

Hello,
I have just installed this module Backup mysql plugin v. 1.4. when I turn it on it displays these errors:

ERROR: This backup script seldom works when safe_mode is enabled or open_basedir restrictions are in effect.
If you get no errors doing a backup, check to see whether the file is less than 200kb. If so, then the backup is likely unreliable.
ERROR: Your server's "exec()" command has been disabled. This script cannot run. Ask your host if they are willing to re-enable PHP exec().
Error: Backup directory does not exist. Please set this in configure.php.

Pls yould someone tell mehow can I fix it? My Zen is version: Zen Cart 1.3.9e, PHP 5.3

Thanks a lot in advance!

18 Nov 2010, 1:00 PM
#54
kuroi avatar

kuroi

Totally Zenned

Join Date:
Apr 2006
Location:
London, UK
Posts:
10,475
Plugin Contributions:
11

Re: MYSQL Backup addon error

devilekk:

Hello,
I have just installed this module Backup mysql plugin v. 1.4. when I turn it on it displays these errors:

ERROR: This backup script seldom works when safe_mode is enabled or open_basedir restrictions are in effect.
If you get no errors doing a backup, check to see whether the file is less than 200kb. If so, then the backup is likely unreliable.
ERROR: Your server's "exec()" command has been disabled. This script cannot run. Ask your host if they are willing to re-enable PHP exec().
Error: Backup directory does not exist. Please set this in configure.php.

Pls yould someone tell mehow can I fix it? My Zen is version: Zen Cart 1.3.9e, PHP 5.3

Thanks a lot in advance!Are you administering your own server?

Kuroi Web Design and Development | Twitter

(Questions answered in the forum only - so that any forum member can benefit - not by personal message)

18 Nov 2010, 7:18 PM
#55
devilekk avatar

devilekk

New Zenner

Join Date:
Sep 2010
Posts:
5
Plugin Contributions:
0

Re: MYSQL Backup addon error

No, I have my e-shop hosted. This problem can fix my admin?

18 Nov 2010, 8:16 PM
#56
kuroi avatar

kuroi

Totally Zenned

Join Date:
Apr 2006
Location:
London, UK
Posts:
10,475
Plugin Contributions:
11

Re: MYSQL Backup addon error

The problems being reported refer to restrictions in the way your server is configured.

So the only way around them is to get your host to lift the restrictions.

But since they're not normally there by default, it seem likely that your host has chosen to add them, and therefore unlikely that they will be willing to remove them.

In which case your options are to find another way to backup your database, or change hosts.

Kuroi Web Design and Development | Twitter

(Questions answered in the forum only - so that any forum member can benefit - not by personal message)

18 Nov 2010, 11:19 PM
#57
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: MYSQL Backup addon error

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.