Zen Cart Logo
Forums / Upgrading from 1.3.x to 1.3.9 / Help! - Problem with DB after upgrade to 1.3.7

Help! - Problem with DB after upgrade to 1.3.7

Locked

Views: 1,350

Results 1 to 3 of 3
This thread is locked. New replies are disabled.
2 Feb 2007, 5:47 AM
#1
peter_homann avatar

peter_homann

Zen Follower

Join Date:
Jun 2006
Location:
Melbourne, VIC
Posts:
106
Plugin Contributions:
0

Help! - Problem with DB after upgrade to 1.3.7

Hi,

2 days ago I upgraded my 1.3.5 install to 1.3.7 via Fantastico. After that it complained that my DB was still at 1.3.6 so I ran the zc_install and upgraded the DB and all was fine.

Then today I decided to install Paypal Express checkout, which I did. I then decided to test it, and to my surprise I am getting the following errors above my home page.

Warning: Variable passed to each() is not an array or object in /home/homann/public_html/store/includes/classes/db/mysql/query_factory.php on line 114

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/homann/public_html/store/includes/classes/db/mysql/query_factory.php:114) in /home/homann/public_html/store/includes/functions/sessions.php on line 108

Warning: Cannot modify header information - headers already sent by (output started at /home/homann/public_html/store/includes/classes/db/mysql/query_factory.php:114) in /home/homann/public_html/store/includes/init_includes/init_templates.php on line 78

Also on the page itself I get the following instead of my products;

1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'EXPECTED_PRODUCTS_SORT limit MAX_DISPLAY_UPCOMING_PRODUC' at line 7
in:
[select p.products_id, pd.products_name, products_date_available as date_expected from zen_products p, zen_products_description pd where p.products_id = pd.products_id and p.products_status = 1 and pd.language_id = '1' and p.products_date_available >=20070202 order by EXPECTED_PRODUCTS_FIELD EXPECTED_PRODUCTS_SORT limit MAX_DISPLAY_UPCOMING_PRODUCTS]

I then tried creating a test installation and pointing it to my main database to see if it was in the code. The same errors occur.

Also from the Admin side, everything is working fine

Can anybody shed some light on how to fix this please?

Cheers,

Peter.

2 Feb 2007, 10:30 AM
#2
louis avatar

louis

Zen Follower

Join Date:
Jul 2006
Location:
Johannesburg
Posts:
408
Plugin Contributions:
0

Re: Help! - Problem with DB after upgrade to 1.3.7

Peter,

You did make a backup before you installed th Paypal mod ?:D

Restore to this backup and see if the problem is still there. If not, the installation of the mod could have caused the errors. Make sure you have the latest version and re-install the mod. (After you made a backup.)

2 Feb 2007, 10:50 AM
#3
peter_homann avatar

peter_homann

Zen Follower

Join Date:
Jun 2006
Location:
Melbourne, VIC
Posts:
106
Plugin Contributions:
0

Re: Help! - Problem with DB after upgrade to 1.3.7

Hi Louis,

Thanks for your reply. Yes I did. I had both the express and Paypal IPN modules installed. I removed the IPN module and it it now working.

WEll, the Express Paypal doesn't as it complains that the address fields don't match. So I've removed the express and reinstalled the IPN Paypal module and it now works.

That said, all I wanted was a currency calculation bug in the PAypal modue fixed.

I guess I'll just have to live with that. :(

Cheers,

Peter.