Zen Cart Logo
Forums / Setting Up Categories, Products, Attributes / Strange Error when Uploading via Attribute Upload

Strange Error when Uploading via Attribute Upload

Locked

Views: 1,275

Results 1 to 2 of 2
This thread is locked. New replies are disabled.
13 Feb 2007, 12:13 AM
#1
webomat avatar

webomat

Zen Follower

Join Date:
Jan 2005
Location:
Minneapolis MN, USA
Posts:
128
Plugin Contributions:
0

Strange Error when Uploading via Attribute Upload

Hello,

Well here's a new one... at least to me!

I have a product that allows clients to upload their images for use in creating printed materials. Initially I had a problem with the 2 MB limit but got that all worked out with the site host. [Current upload limit according to ZenCart and PHP on host is 10MB, they set the timeout up so that that wouldn't be a problem either.]

In verifying/testing the results the hosting company reported, I got a weird response to an upload via a product attribute which was displayed on the shopping cart page after the process "completed".

Scenario: A shopping cart entry already existed, with 2 small images in it from an earlier upload test (together under 1MB total). I then went to "purchase" another product and upload a large image (6MB).

a) Totally crapped out in Opera, nothing ever happens. I assume there is some type of JS involved in this, which Opera is rather touchy about. Correct? Doesn't really matter since I use Opera but 98% of my clients will be using IE. "-)

b) Tried it in IE and while the image appeared to upload but when the process moved on to the shopping cart I got the error message below in a nice yellow error box at the top of the shopping cart. The image/product was not in the cart [nor was it on the server in images/uploads].

"Qty Adjusted - Maximum Qty Added to Cart B: - Upload Images/Files"

c) Deleted the existing product in the cart (with 2 small images - under 1MB total) and repeated the purchase product/upload process. This time it worked as expected -- no error message, image showed as uploaded attribute in product ordered. Image is in images/uploads on server.

Could not find any file that has the error message/words in it via the Developers Toolkit, so I'm here to ask if anyone has an understanding or explanation for this and a workaround or solution.

Thanks in advance,

Becky

15 Feb 2007, 9:14 PM
#2
webomat avatar

webomat

Zen Follower

Join Date:
Jan 2005
Location:
Minneapolis MN, USA
Posts:
128
Plugin Contributions:
0

Re: Strange Error when Uploading via Attribute Upload

bumping in case someone who knows the answer wasn't around a few days ago.

:-)

For now I'm telling users to stay under 10MB combined file size and to checkout in between uploads, but this is a potential problem with the CC company since they require 15 min between checkouts using the same card.

Thanks for looking!

Becky