Zen Cart Logo
Forums / General Questions / HAve you seen this error before?

HAve you seen this error before?

Locked

Views: 1,356

Results 1 to 8 of 8
This thread is locked. New replies are disabled.
26 Mar 2007, 4:25 PM
#1
austy25 avatar

austy25

Zen Follower

Join Date:
Feb 2006
Posts:
248
Plugin Contributions:
0

HAve you seen this error before?

Hi everyone!
I have been running the store just fine without any major issues lately but then last night this error came up

1226 User '*****' has exceeded the 'max_questions' resource (current value: 50000)
in:
[select value from sessions where sesskey = '81ca57d93d251474730b983fbf19dfbb' and expiry > '1174925865']

This resulted in me not being able to log in to admin or store - the rest of the site works just fine.
I do have admin set for more users to be able to upload and insert their own products could that be the problem I have searched the database quite a bit this morning but can't seem to pinpoint exactly this problem
Please excuse this thread if its in the wrong section. I was looking for an error section but didn't find one.

Thank you!!!!

26 Mar 2007, 4:25 PM
#2
austy25 avatar

austy25

Zen Follower

Join Date:
Feb 2006
Posts:
248
Plugin Contributions:
0

Re: HAve you seen this error before?

Grr double post sorry

26 Mar 2007, 6:08 PM
#3
austy25 avatar

austy25

Zen Follower

Join Date:
Feb 2006
Posts:
248
Plugin Contributions:
0

Re: HAve you seen this error before?

Sorry to have posted this question - never mind on the issue - I did a 'max_questions' resource check and found my answer. I already contacted my hosting ;)
Sorry I took up yes even more space asking a question that has been asked before ;)

26 Mar 2007, 6:11 PM
#4
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: HAve you seen this error before?

Let us know what you discover ... it is always helpful to have both question and solution on issues posted ... :smile:

26 Mar 2007, 6:54 PM
#5
austy25 avatar

austy25

Zen Follower

Join Date:
Feb 2006
Posts:
248
Plugin Contributions:
0

Re: HAve you seen this error before?

well so far I have done a search on the web on it and people recommend setting up new databases this is one article I found HTH:

This topic has been fixed. Her problem was that her service provider puts a quota on a SQL database user of 50,000 querries per hour max. Well everybody knows that Nuke with many active users can double that number so the site was shutting everything down when they hit their quota for an hour. Her service provider refused to bump the quota and actually told her to purchace a dedicated server which is BS!

I fixed this problem by creating 3 DB users and gave them all permissions to the nuke database. All 3 had the same password. Then went to config.php and made these modifications:
Code:

//$dbuname = "********1"; //Old DB UserName Access
$db_user_array[] = "********1"; //1st user name
$db_user_array[] = "********2"; //2nd user name
$db_user_array[] = "********3"; //3rd user name
$dbuname = $db_user_array[ rand( 0, ( sizeof($db_user_array) -1 ) ) ];

This allowed nuke to swap between 3 different users so that the 50,000 limit quota would be evenly distributed throught 3 users making her quota 150,000.

Like I said hope that helps someone else as well :)

26 Mar 2007, 7:44 PM
#6
austy25 avatar

austy25

Zen Follower

Join Date:
Feb 2006
Posts:
248
Plugin Contributions:
0

Re: HAve you seen this error before?

Here I found an even better one that was posted by Dr.Byte: Thanks Doc.:)

http://www.zen-cart.com/forum/showthread.php?t=24089

GL to all with this problem :)

26 Mar 2007, 7:52 PM
#7
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: HAve you seen this error before?

Thanks for the update and adding that link for others ... :smile:

26 Mar 2007, 8:36 PM
#8
austy25 avatar

austy25

Zen Follower

Join Date:
Feb 2006
Posts:
248
Plugin Contributions:
0

Re: HAve you seen this error before?

Unfortunately its not working for me .... I'll just wait for my hosting to see what they have to say ... Thanks anyways :)

1142 DELETE command denied to user 'u'@'cgihost' for table 'whos_online'
in:
[delete from whos_online where time_last_click < '1174940397']

1142 INSERT command denied to user 'u'@'cgihost' for table 'sessions'
in:
[insert into sessions values ('be87728aa9a2b520b1004aebeaad93aa', '1174942737', 'customers_host_address|s:28:"cache-ntc-ac03.proxy.aol.com";cartID|s:0:"";cart|O:12:"shoppingcart":8:{s:9:"observers";a:0:{}s:8:"contents";a:0:{}s:5:"total";i:0;s:6:"weight";i:0;s:12:"content_type";b:0;s:18:"free_shipping_item";i:0;s:20:"free_shipping_weight";i:0;s:19:"free_shipping_price";i:0;}navigation|O:17:"navigationhistory":3:{s:9:"observers";a:0:{}s:4:"path";a:1:{i:0;a:4:{s:4:"page";s:5:"index";s:4:"mode";s:6:"NONSSL";s:3:"get";s:0:"";s:4:"post";a:0:{}}}s:8:"snapshot";a:0:{}}check_valid|s:4:"true";language|s:7:"english";languages_id|s:1:"1";languages_code|s:2:"en";currency|s:3:"USD";')]

Warning: Unknown(): A session is active. You cannot change the session module's ini settings at this time. in Unknown on line 0