Zen Cart Logo
Forums / Installing on a Linux/Unix Server / Transfer to new host

Transfer to new host

Locked

Views: 2,547

Results 1 to 10 of 10
This thread is locked. New replies are disabled.
1 Apr 2007, 4:33 PM
#1
ivyrose avatar

ivyrose

New Zenner

Join Date:
Apr 2007
Posts:
5
Plugin Contributions:
0

Transfer to new host

I transfered my cart to a new host. I search the site and did everything I was told, however, there is still a reference to the old host. I was wondering how I can go and edit this so that my site is functional again? I can not log into my admin area so I'm assuming I have to go and edit the database. Where do I do that ad and how? I have a few other errors as well but this is the main error which I'm thinking is causing the root of my problem.

Here is the error if you need it:

Warning: session_save_path() [function.session-save-path]: open_basedir restriction in effect. File(/home/oldusername/public_html/shop/cache) is not within the allowed path(s): (/home/newusername:/usr/lib/php:/usr/local/lib/php:/tmp) in /home/newusername/public_html/shop/includes/functions/sessions.php on line 151

Thanks for any help,
Tracey

1 Apr 2007, 4:47 PM
#2
kobra avatar

kobra

Black Belt

Join Date:
Aug 2005
Location:
Arizona
Posts:
31,500
Plugin Contributions:
4

Re: Transfer to new host

This is in the configuration table in the DB. Do a backup first & always.

Using phpmyadmin export this table and with a plain text editor edit/find the reference to your old address and change it to the current save and with phpmyadmin import it.

1 Apr 2007, 5:14 PM
#3
merlinpa1969 avatar

merlinpa1969

Totally Zenned

Join Date:
Mar 2004
Posts:
13,031
Plugin Contributions:
4

Re: Transfer to new host

or go into admin-> configuration -> sessions and reset the path there

1 Apr 2007, 7:54 PM
#4
pixxi avatar

pixxi

Totally Zenned

Join Date:
Jan 2004
Location:
UK
Posts:
1,065
Plugin Contributions:
1

Re: Transfer to new host

(@Merlin: the OP has said she can't login to admin)

Or an easier way would be to upload the fix_cache_key.php file (available from the downloads section) to the root of your store and run it via your browser. Remember to delete it afterwards:

http://www.zen-cart.com/index.php?main_page=product_contrib_info&cPath=40_54&products_id=82

1 Apr 2007, 8:02 PM
#5
merlinpa1969 avatar

merlinpa1969

Totally Zenned

Join Date:
Mar 2004
Posts:
13,031
Plugin Contributions:
4

Re: Transfer to new host

sorry pixxi,

I thought I read through that a few times and didnt see anything about not being able to get in the admin

1 Apr 2007, 9:13 PM
#6
ivyrose avatar

ivyrose

New Zenner

Join Date:
Apr 2007
Posts:
5
Plugin Contributions:
0

Re: Transfer to new host

Actually I tried that cache key and with the error for the old database it only fixed one problem but the reference to the old host is still there which is causing some other errors.

I will see if I can get into the db and export the configuration and the import it.

Thanks for your help... I'll keep you posted,
Tracey

1 Apr 2007, 9:38 PM
#7
pixxi avatar

pixxi

Totally Zenned

Join Date:
Jan 2004
Location:
UK
Posts:
1,065
Plugin Contributions:
1

Re: Transfer to new host

You sometimes need to run the fix_cache_key program more than once, and then refresh your browser a few times before it clears the error.

You might also delete any session files you have in your /cache folder on your new host - they will start with 'zc_'.

1 Apr 2007, 11:02 PM
#8
ivyrose avatar

ivyrose

New Zenner

Join Date:
Apr 2007
Posts:
5
Plugin Contributions:
0

Re: Transfer to new host

Well it cleared most of the errors. However, I'm down to one now on the admin area and that one is:

Fatal error: Call to a member function Execute() on a non-object in /home/username/public_html/shop/includes/functions/sessions.php on line 71

I checked to see if it had any of the page breaks and that but the only thing on line 71 is:

$total = $db->Execute($qid);

I'm lost...
:lamo:

Tracey

2 Apr 2007, 12:01 AM
#9
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: Transfer to new host

What version of Zen Cart are you running?

That is a php 5.2 bug that we have a temp fix for in the current Zen Cart v1.3.7 ... with the current PayPal Patch:
http://www.zen-cart.com/forum/showthread.php?t=56216

2 Apr 2007, 12:27 AM
#10
ivyrose avatar

ivyrose

New Zenner

Join Date:
Apr 2007
Posts:
5
Plugin Contributions:
0

Re: Transfer to new host

It's actually the 1.2 because when I try to use the upgraded version and then import the database I get a ton of errors.

I wouldn't mind using the newer version if I can get the database to upgrade as well. When I tried the upgrade via the cpanel it fixes that admin part, but, on the main page there is a bunch of errors.

See the problem is the old host was the older version of zen along with the older version of mysql. The new host has the newer version along with the newer version of mysql.

Tracey