Zen Cart Logo
Forums / General Questions / Email Error: SMTP Error: Could not connect to SMTP host.

Email Error: SMTP Error: Could not connect to SMTP host.

Locked

Views: 16,033

Results 1 to 3 of 3
This thread is locked. New replies are disabled.
8 Apr 2007, 1:58 PM
#1
stack_a_brown avatar

stack_a_brown

New Zenner

Join Date:
Apr 2007
Posts:
7
Plugin Contributions:
0

Email Error: SMTP Error: Could not connect to SMTP host.

The ZenCart is installed in ifastnet.com with free acount, i dont know if this is the problem. :blink:

I tried with the diferent methods of send mail, and not work for me.

In the PHP info say : sendmail_path: /usr/bin/nosendmail

I used SMPT and SMPT Auth with diferent accounts and not working

SMTP Email Account Mailbox : [email protected]
SMTP Email Account Password: ******
SMTP Email Mail Host: smtp.mail.yahoo.com
SMTP Email Port Server: 25
NOT WORK!

SMTP Email Account Mailbox : stack_a_brown@**********.com
SMTP Email Account Password: ******
SMTP Email Mail Host: mail.marcatel.com.mx
SMTP Email Port Server: 25
NOT WORK!

What happend?

8 Apr 2007, 2:42 PM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Email Error: SMTP Error: Could not connect to SMTP host.

You may or may not be able to use email support with a free-hosting service.
You certainly don't want to run a real business on a free hosting service.

Here are some email-troubleshooting suggestions:
http://www.zen-cart.com/wiki/index.php/Troubleshoot_-_Email_Problems

15 Feb 2010, 8:53 PM
#3
notageek avatar

notageek

Zen Follower

Join Date:
Mar 2009
Posts:
418
Plugin Contributions:
0

Re: Email Error: SMTP Error: Could not connect to SMTP host.

Hi. After changing my mail server to SMTP to correct other checkout errors on my WAMP localhost test server, I received this error:

"SMTP:Email Error: SMTP Error: Could not connect to SMTP host."

I checked the above link provided by Dr. Byte which led me to install the Email Archive Manager module which led me to Admin->Configuration->Email Options->Email Archiving Active? which I set to true. (Seems like a good idea, but this module was not part of the solution below.)

I wondered what the E-mail Friendly-Errors option was, just below the Email Archiving Active? option, so I clicked on that, and in the edit screen it said:

"Do you want to display friendly errors if emails fail? Setting this to false will display PHP errors and likely cause the script to fail. Only set to false while troubleshooting, and true for a live shop."

Well, I wondered if it was a PHP error causing the "script(?)" to fail; therefore, I set it to "true."

Now, I see the full range of pages in checkout on my WAMP localhost test server.

I note that my online server, which never had this problem, uses PHP as the email transport method, and still has the E-mail Friendly-Errors set to false.

I don't know if the errors reported mean anything, but the above change made it at least look like everything is working. I am receiving confirming emails. Products are not leaving my cart as they should, but most likely that is because I am still running in test mode.

I hope this helps the next person with this problem.