Zen Cart Logo
Forums / Templates, Stylesheets, Page Layout / Error! Unable to determine the page link! Purchased template. Using an SEO Url modul

Error! Unable to determine the page link! Purchased template. Using an SEO Url modul

Locked

Views: 2,635

Results 1 to 5 of 5
This thread is locked. New replies are disabled.
20 Apr 2007, 10:21 PM
#1
olaand avatar

olaand

New Zenner

Join Date:
Apr 2007
Location:
Herefordshire, UK
Posts:
11
Plugin Contributions:
0

Error! Unable to determine the page link! Purchased template. Using an SEO Url modul

I have an zencart installed in the root.
When I type in www.diningbydesign.co.uk the page only partly loads and it loads with an error (you can visit the URL above to see what I mean)

For the page to load properly I need to type in www.diningbydesign.co.uk/index.php OR if I click on Home in the menu then it loads ok.

I would expect the domain to automatically resolve to and load .co.uk/index.php . but it doesn't seem to. Based on the error message I went looking in index.php to find out if there was a problem with the address to the tpl_main_page.php but it all got a bit compllicated and I am not sure what to look for.

This is hosted with network solutions (UNIX)

Any ideas? :dontgetit

Thanks
ola

24 Apr 2007, 4:53 PM
#2
kay6284 avatar

kay6284

New Zenner

Join Date:
Aug 2006
Posts:
37
Plugin Contributions:
0

Re: Error! Unable to determine the page link! Purchased template. Using an SEO Url modul

I am getting this same error. I also use network solutions as my host (unix). Maybe we should contact network solutions on this problem?

kay6284

24 Apr 2007, 7:06 PM
#3
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Error! Unable to determine the page link! Purchased template. Using an SEO Url modul

olaand:

I have an zencart installed in the root.
When I type in www.diningbydesign.co.uk the page only partly loads and it loads with an error (you can visit the URL above to see what I mean)

For the page to load properly I need to type in www.diningbydesign.co.uk/index.php OR if I click on Home in the menu then it loads ok.

I would expect the domain to automatically resolve to and load .co.uk/index.php . but it doesn't seem to.

This is hosted with network solutions (UNIX)

kay6284:

I am getting this same error. I also use network solutions as my host (unix). Maybe we should contact network solutions on this problem?Yes, if your site is requiring you to use the "index.php" in the URL, then your hosting account is probably not configured right.
Best to contact your hosting tech support for the right way to resolve this matter.

You might try changing to "classic" template instead of your "theme030" template. If things work properly, then you should contact whomever you purchased your template from to get them to help support their product.

25 Apr 2007, 6:48 AM
#4
olaand avatar

olaand

New Zenner

Join Date:
Apr 2007
Location:
Herefordshire, UK
Posts:
11
Plugin Contributions:
0

Re: Error! Unable to determine the page link! Purchased template. Using an SEO Url modul

Thanks for the answers guys, I had an update from Network Soutions and they confirm there is a problem. Here is their answer:

"There is currently an issue in our PHP environment with the server variable PHP_SELF. This issue is expected to be resolved on April 28, 2007. In the mean time, we have updated the file /htdocs/includes/functions/html_output.php to work around this issue. We have renamed the original html_output.php to html_output.php.orig. After 4/28/2007, you should be able to move the current html_output.php and rename html_output.php.orig to html_output.php."

Regards
Ola

25 Apr 2007, 4:01 PM
#5
kay6284 avatar

kay6284

New Zenner

Join Date:
Aug 2006
Posts:
37
Plugin Contributions:
0

Re: Error! Unable to determine the page link! Purchased template. Using an SEO Url modul

ok....the problem I was having was not because of Network Solutions. A couple weeks ago, I had installed SEO URL's and had problems. I went on vacation the next week and kinda forgot about what I had been working on. I noticed in admin I was getting an error that specified the file admin/includes/functions/general.php as having a problem. I replaced the file from the zencart installation files and the error is gone now.

I did find other articles about this error, but they are on the oscommerce forums. The articles suggest to go to your admin panel and under configuration and my store change Use Search-Engine Safe URLs to false. However, I do not see this option in the zencart admin.

kay6284