Zen Cart Logo
Forums / General Questions / Internal Server Error on checkout - driving me nuts!

Internal Server Error on checkout - driving me nuts!

Locked

Views: 3,326

Results 1 to 13 of 13
This thread is locked. New replies are disabled.
23 Apr 2007, 7:11 PM
#1
brettdixon avatar

brettdixon

New Zenner

Join Date:
Sep 2006
Posts:
11
Plugin Contributions:
0

Internal Server Error on checkout - driving me nuts!

Hi all, hope you can help me. When my customers go to the checkout page i get an internal server error. Nothing has changed on my website at all and its just radomly started happening.

Ive contacted my host who insist they havent changed a thing and all is well. Ive waiting a few days and nothing has changed, please please can someone help me i really need to get my site going again!

my site address is: www.twenty-7.co.uk

there is noting in the sites error logs, its all blank.

Error message is:

Internal Server Error

The page you requested could not be served. This could happen for a variety of reasons, including: - A CGI script failed to produce any output.

  • The server is incorrectly configured.
  • The server encountered a critical error.There may be more information about this error in the server's error logs. If you have any queries about this error, please e-mail [email protected].
23 Apr 2007, 7:57 PM
#2
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: Internal Server Error on checkout - driving me nuts!

I was able to add to cart ...

Hit checkout and create an account ...

Get to checkout_shipping ...

Get to checkout_payment ... and died after the left column started to draw ...

It looks like you are running an older version of Zen Cart or have not upgraded your files correctly ...

What happens if you switch to Classic?

23 Apr 2007, 7:59 PM
#3
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: Internal Server Error on checkout - driving me nuts!

NOTE: FireFox 2.0 you see the Categories sidebox draw then die ...

IE 6 you see just the header draw then die ...

on the checkout_shipping page ...

23 Apr 2007, 8:01 PM
#4
merlinpa1969 avatar

merlinpa1969

Totally Zenned

Join Date:
Mar 2004
Posts:
13,031
Plugin Contributions:
4

Re: Internal Server Error on checkout - driving me nuts!

running php as cgi is a pain in the butt at best,
take a look at the permissions on the file
includes/templates/YOUR template name/templates/tpl_checkout_payment_default.php and see if the permissions are duifferent that that of the checkout shipping page that should be right there ae well,

and for some reason you have the zen ID displaying on EVERY link, that uses SSL,
this is NOT a good idea

and in Internet explorer all that there is a blank page for checkout shipping

23 Apr 2007, 8:37 PM
#5
brettdixon avatar

brettdixon

New Zenner

Join Date:
Sep 2006
Posts:
11
Plugin Contributions:
0

Re: Internal Server Error on checkout - driving me nuts!

Hi all, tried the classic template and its still the same problem exactly,

Merlin - i dont have that path im using the black gloss template from the downloads section and it goes templates/blackgloss and then just have 5 folders: buttons, common, css, images, sideboxes,

one odd thing though, when i got to templates in tools rather than say the template name "black gloss" like it always said it now says CSS categories flyout menu template.

now im totally lost!???!

thanks for your prompt replies,

oh merloin, no sure what you mean zen id displaying of every link wouldnt know how and why i would do that!

23 Apr 2007, 8:38 PM
#6
brettdixon avatar

brettdixon

New Zenner

Join Date:
Sep 2006
Posts:
11
Plugin Contributions:
0

Re: Internal Server Error on checkout - driving me nuts!

oh and i havent upgraded either. Do you think if i upgrade to the latest version it will fix things? could i update with losing all my listings and customer info?

23 Apr 2007, 8:46 PM
#7
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: Internal Server Error on checkout - driving me nuts!

Upgrading will replace and fix any of the bugs that exist on your current site and unless this is a template issue only ... it will fix this issue too ...

Be sure to load all of the /classic directories so you have a clean Classic template loaded ...

23 Apr 2007, 8:48 PM
#8
brettdixon avatar

brettdixon

New Zenner

Join Date:
Sep 2006
Posts:
11
Plugin Contributions:
0

Re: Internal Server Error on checkout - driving me nuts!

thankyou i will try this at some point, is there a guide anywhere for just upgrading without losing any info?

30 Jun 2007, 3:20 AM
#9
ksteele avatar

ksteele

New Zenner

Join Date:
Jun 2007
Posts:
12
Plugin Contributions:
0

Re: Internal Server Error on checkout - driving me nuts!

:censored: hmmm, I'm having the same error also. However, my config files are edited correctly according to the help section >>> https://www.zen-cart.com/tutorials/index.php?article=14 <<< uploaded correctly and reset the permissions back to 444.

I checked the SSL script information locate on my server and the only difference seems to be that it was coded to: "www" verses just the "nutriguard.com". So I made the proper adjustments to my php scripts and still have the same error

i,e,.- (both in IE7 and Firefox) "Cannot display webpage -

Most likely causes:

  • <LI id=causeNotConnected>You are not connected to the Internet. <LI id=causeSiteProblem>The website is encountering problems.
  • There might be a typing error in the address.This happens for all instances of SSL? I also looked for any spaces in my code
    and didn't find any obvious violations. Here's a copy of code: * ...depending on your system configuration settings
    */
    define('HTTP_SERVER', 'http://www.nutriguard.com');
    define('HTTPS_SERVER', 'https://www.nutriguard.com');
    define('HTTP_CATALOG_SERVER', 'http://www.nutriguard.com');
    define('HTTPS_CATALOG_SERVER', 'https://www.nutriguard.com');
    // Use secure webserver for catalog module and/or admin areas?
    define('ENABLE_SSL_CATALOG', 'true');
    define('ENABLE_SSL_ADMIN', 'true');

The 2nd config file reads the same, and my Zen Cart = v1.3.7 think maybe it's server side???

30 Jun 2007, 4:06 AM
#10
merlinpa1969 avatar

merlinpa1969

Totally Zenned

Join Date:
Mar 2004
Posts:
13,031
Plugin Contributions:
4

Re: Internal Server Error on checkout - driving me nuts!

I do see that one issue is that you are are having is that you are trying to use SSL and there is no ssl configured on your account

1 Jul 2007, 4:44 AM
#11
ksteele avatar

ksteele

New Zenner

Join Date:
Jun 2007
Posts:
12
Plugin Contributions:
0

Re: Internal Server Error on checkout - driving me nuts!

OK, at the risk of sounding reaallllllllllly dumb here... where are you seeing this info? I paid my host (Ace-Host.Net) to set it up for me and they assured me it was done. Also, if I look at my cpanel all the SSL scripts are visible.

1 Jul 2007, 4:49 AM
#12
merlinpa1969 avatar

merlinpa1969

Totally Zenned

Join Date:
Mar 2004
Posts:
13,031
Plugin Contributions:
4

Re: Internal Server Error on checkout - driving me nuts!

https://www.nutriguard.com
use firefox it pops up an error code
unexpected error -12263

this is from dnsstuff

SSL Information for https://www.nutriguard.com
Generated by https://www.DNSstuff.com

SSL information for www.nutriguard.com:

Version Supported? Information
SSLv2 No Non-SSL: Appears to be non-SSL HTML [3c21444f43545950].
SSLv3 No Non-SSL: Appears to be non-SSL HTML [3c21444f43545950].
TLS 1.0 No Non-SSL: Appears to be non-SSL HTML [3c21444f43545950].

Certificate:
I could not detect any SSL at www.nutriguard.com:443.

1 Jul 2007, 2:36 PM
#13
ksteele avatar

ksteele

New Zenner

Join Date:
Jun 2007
Posts:
12
Plugin Contributions:
0

Re: Internal Server Error on checkout - driving me nuts!

Thank you for that information Merlinpa, I'll forward this to my host