Zen Cart Logo
Forums / General Questions / Error sending e-mail to customers

Error sending e-mail to customers

Locked

Views: 4,115

Results 1 to 14 of 14
This thread is locked. New replies are disabled.
9 May 2007, 10:19 AM
#1
scottrdj avatar

scottrdj

New Zenner

Join Date:
May 2006
Posts:
26
Plugin Contributions:
0

Error sending e-mail to customers

Hi I keep getting this error when I am trying to send an e-mail to customers
1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ':admin_id' at line 1
in:
[select 'ADMIN' as customers_firstname, admin_name as customers_lastname, admin_email as customers_email_address from admin where admin_id = $SESSION:admin_id ]
If you were entering information, press the BACK button in your browser and re-check the information you had entered to be sure you left no blank fields.

Where is this file held to check it or does anyone know what the specific problem is.

Thanks

9 May 2007, 10:54 AM
#2
chuckl avatar

chuckl

Totally Zenned

Join Date:
Nov 2006
Location:
Papworth, Cambridgeshire, UK
Posts:
717
Plugin Contributions:
0

Re: Error sending e-mail to customers

It is a table entry in the query builder table in your Zen Cart database. Under Admin Settings in Admin - Tools, do you have an email address defined?

9 May 2007, 11:04 AM
#3
scottrdj avatar

scottrdj

New Zenner

Join Date:
May 2006
Posts:
26
Plugin Contributions:
0

Re: Error sending e-mail to customers

Yes, its all defined.

9 May 2007, 11:13 AM
#4
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Error sending e-mail to customers

Your /includes/functions/audience.php is out of date -- probably didn't get upgraded in your last update.

9 May 2007, 11:18 AM
#5
scottrdj avatar

scottrdj

New Zenner

Join Date:
May 2006
Posts:
26
Plugin Contributions:
0

Re: Error sending e-mail to customers

Thanks, thats it all fixed.

28 May 2007, 1:55 PM
#6
karthi_00703 avatar

karthi_00703

New Zenner

Join Date:
Mar 2007
Posts:
10
Plugin Contributions:
0

Re: Error sending e-mail to customers

Hi,

I sent Newsletter to Admin and other users. But this Newsletter is not sending. It gives error message, that is,

Email Error: Could not instantiate mail function.

I have tried to solve this issue. But i couldn't find it.

So, please help me to solve this issue.

With regards,
Karthi

28 May 2007, 2:25 PM
#7
chuckl avatar

chuckl

Totally Zenned

Join Date:
Nov 2006
Location:
Papworth, Cambridgeshire, UK
Posts:
717
Plugin Contributions:
0

Re: Error sending e-mail to customers

It means that you are trying to use an email transport that is not enabled on your system. Logically, it means that you cannot send any email. Check your setting of email transport in Admin-Configuration-Email Options against what your hosting service recommends.

29 May 2007, 3:43 AM
#8
karthi_00703 avatar

karthi_00703

New Zenner

Join Date:
Mar 2007
Posts:
10
Plugin Contributions:
0

Re: Error sending e-mail to customers

Chuckl:

It means that you are trying to use an email transport that is not enabled on your system. Logically, it means that you cannot send any email. Check your setting of email transport in Admin-Configuration-Email Options against what your hosting service recommends.

Hi,

In Admin, E-Mail Transport Method is PHP.

Sometime Admin received Newsletter. Sometimes it gives the following error.

Email Error: Could not instantiate mail function.

And If i send the Newsletter to Customers then it gives the above error always.

I couldn't find it. Please help me.

With best regards,
Karthi

29 May 2007, 8:51 AM
#9
chuckl avatar

chuckl

Totally Zenned

Join Date:
Nov 2006
Location:
Papworth, Cambridgeshire, UK
Posts:
717
Plugin Contributions:
0

Re: Error sending e-mail to customers

That is exactly your problem:

In Admin, E-Mail Transport Method is PHP.

The error message is telling you that you cannot use that email transport. Change to another one that is appropriate for your server.

8 Jun 2007, 6:03 PM
#10
andyii avatar

andyii

Zen Follower

Join Date:
Mar 2007
Posts:
153
Plugin Contributions:
0

Re: Error sending e-mail to customers

Chuckl:

That is exactly your problem:

In Admin, E-Mail Transport Method is PHP.

The error message is telling you that you cannot use that email transport. Change to another one that is appropriate for your server.

Not always true, I Own the servers and use php mail function all the time so I know Im allowed :)
Im thinking its something to do with the amount of emails being sent, I have used it before and never problem till now, Im getting same error only diff is the amount of subscribers

8 Jun 2007, 6:14 PM
#11
andyii avatar

andyii

Zen Follower

Join Date:
Mar 2007
Posts:
153
Plugin Contributions:
0

Re: Error sending e-mail to customers

AndyII:

Not always true, I Own the servers and use php mail function all the time so I know Im allowed :)
Im thinking its something to do with the amount of emails being sent, I have used it before and never problem till now, Im getting same error only diff is the amount of subscribers

adding that it Does send some mail as I get the newsletter, not sure where it stopped

8 Jun 2007, 7:15 PM
#12
chuckl avatar

chuckl

Totally Zenned

Join Date:
Nov 2006
Location:
Papworth, Cambridgeshire, UK
Posts:
717
Plugin Contributions:
0

Re: Error sending e-mail to customers

You are of course correct AndyII, what I should have said is that I have only ever seen it when the transport is disabled.
More correctly it means that the call to the mail function returned an error. From what you describe, I'd check how much memory PHP has, and possibly up it a bit? Could be a memory leak or incremental memory use on the repeated calls is using up all the available mem, at which point it can't instantiate the next piece of mail?
I have also heard of it with badly formed email addresses, which would only make sense it it happened at the same or similar place every time, but that could also be a mem problem.
and finally, if the mail server (even your own), has a mails per hour limit set, it could be refusing the mail?

Rgds,

8 Jun 2007, 11:42 PM
#13
andyii avatar

andyii

Zen Follower

Join Date:
Mar 2007
Posts:
153
Plugin Contributions:
0

Re: Error sending e-mail to customers

of course your right Chuckl, thing is I also run a different newsletter script and send out couple thousand emails using the php mail function, that doesnt have any problems so I wondering if its a zen thing, this is the difference between my 1st mailing and the one that failed, 200 more subscribers and the weight of the letter was 2kb more. going to check some logs and see if I find any answers :)

15 Sep 2007, 9:25 AM
#14
vandiermen avatar

vandiermen

Totally Zenned

Join Date:
Feb 2007
Posts:
518
Plugin Contributions:
1

Re: Error sending e-mail to customers

karthi_00703:

Hi,

I sent Newsletter to Admin and other users. But this Newsletter is not sending. It gives error message, that is,

Email Error: Could not instantiate mail function.

I got this message when I had forgot to setup the email account I was using in the shop

All I had to do was set up email forwarding or an inbox for the email account I specified in the set up and I no longer got this message