Zen Cart Logo
Forums / General Questions / Fatal Error Message After Host Problems?

Fatal Error Message After Host Problems?

Locked

Views: 2,038

Results 1 to 19 of 19
This thread is locked. New replies are disabled.
18 May 2007, 11:17 PM
#1
jolaedana avatar

jolaedana

New Zenner

Join Date:
Feb 2007
Posts:
34
Plugin Contributions:
0

Fatal Error Message After Host Problems?

I'm REALLY hoping this isn't going to be a huge fix.

I've got a client's store that is coming up with the following error message:

Fatal error: main() [function.require]: Failed opening required '' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/samsarah/public_html/shop/includes/templates/template_default/templates/tpl_index_default.php on line 39

You can see the way the page begins to load here: http://www.shopsamsara.com

I'm having issues with my test store on my own web space here: http://shop.audreyportfolio.com/

Recently, the server that our sites was on had issues and was down for about four hours. My host said the following:

The following server was had tested for a bad drive segment even though this is very rare, we decided to migrate all the user on your server to a new faster server that is quad core. In doing so the first initial transfer that would have been not noticed has a small period gap in time. We are quickly rebuilding the accounts and will have all back up with 4-5 hours.

I'm hoping it wasn't caused by that!!

To be sure, I checked to see if the file giving the error code was on the server and in the correct spot. It's there and looks okay- no blank returns at the end of the file etc.

I also checked all my permissions, thinking maybe it just couldn't access what it needed. They're all fine.

I will admit to being an incredible ZenCart Newbie :no: ... can anyone clarify for me what that error means exactly, and if I should be contacting my hosting provider?

Thanks!

18 May 2007, 11:22 PM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Fatal Error Message After Host Problems?

The tpl_index page typically attempts to load the define_main_page.php file from the /includes/languages/english/html_includes/YOURTEMPLATE/ folder. If that file doesn't exist or its permissions are set such that it's getting blocked, you'll get the error message shown.

Or, you may have templates installed that reference old code and thus cannot properly display the expected content. There are a number of forum posts discussing this typical post-upgrade problem (esp when moving from v1.2.x to v1.3.x)

18 May 2007, 11:31 PM
#3
jolaedana avatar

jolaedana

New Zenner

Join Date:
Feb 2007
Posts:
34
Plugin Contributions:
0

Re: Fatal Error Message After Host Problems?

Hi Dr. Byte-

Thanks so much for the quick response!

I don't have a "define_main_page" file in my /includes/languages/english/html_includes/YOURTEMPLATE/ folder (for the record, I created my own template).

There is one, however in /includes/languages/english/html_includes/ -

What should permissions be on that file and the folders that contain them?

Right now, permissions on the PHP files are set to 644, and permissions on the folders are set to 755.

I have not changed my template or updated Zen Cart since the site was tested and working just over two weeks ago - the only thing I can think of that has changed is the server problem.

19 May 2007, 12:01 AM
#4
jolaedana avatar

jolaedana

New Zenner

Join Date:
Feb 2007
Posts:
34
Plugin Contributions:
0

Re: Fatal Error Message After Host Problems?

I should add that I am using the most up to date version of Zen Cart (and have been for this entire install.)

Also, the admin panel is working okay, so that part seems to be just fine.

19 May 2007, 12:30 AM
#5
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Fatal Error Message After Host Problems?

Try copying the one from html_includes into html_includes/MY_TEMPLATE (whatever it's called).

Technically, 644 should be sufficient on the files,but you will require 777 in order to edit via the Admin (Define Pages Editor).

19 May 2007, 12:56 AM
#6
jolaedana avatar

jolaedana

New Zenner

Join Date:
Feb 2007
Posts:
34
Plugin Contributions:
0

Re: Fatal Error Message After Host Problems?

Hi there-

I've copied the file to /includes/languages/english/html_includes/samsaratemplate/ (my template).

I've also double checked the permissions.

No luck.

I've also noticed that in the admin panel, it's no longer recognizing the "classic" theme, even though all the files are there. I can however "preview" the classic template.

Interestingly enough, when I try to "preview" my template, samsaratemplate, I get the following:

Forbidden

You don't have permission to access /includes/templates/samsaratemplate/images/ on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

I've checked the permissions on all the folders in that access string, and they're all 755.

19 May 2007, 4:42 AM
#7
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Fatal Error Message After Host Problems?

Sounds like you need your hosting company involved to reset permissions and apache configuration settings.

You may also need to rework folder paths in your two configure.php files to suit the new server they moved you to.

FAQ's that might help:
http://www.zen-cart.com/wiki/index.php/Server_Admin_-_Switch_Servers
http://www.zen-cart.com/wiki/index.php/Server_Admin_-_Change_Folders

19 May 2007, 5:05 PM
#8
jolaedana avatar

jolaedana

New Zenner

Join Date:
Feb 2007
Posts:
34
Plugin Contributions:
0

Re: Fatal Error Message After Host Problems?

Erg. That wasn't what I wanted to hear, but thanks Dr. Byte. I'll look into things.

21 May 2007, 12:47 AM
#9
jolaedana avatar

jolaedana

New Zenner

Join Date:
Feb 2007
Posts:
34
Plugin Contributions:
0

Re: Fatal Error Message After Host Problems?

Well, I've had an unhappy last 24 hours.

My host claims that due to a CPanel/Fantastico bug, when he moved us to another server and uploaded our backup, the bug caused a corruption issue of some kind on ZenCart installations.

He said he would try reuploading our backup, which apparently hasn't worked.

He claims the only alternative I have at this point is to do a clean install of ZenCart and restore my old template and start over.

Sadly, I had not yet backed up the database as we weren't quite done configuring everything. I have a copy of the current database- would it be a bad idea to try restoring that database, or is that what was corrupt? I have all my custom template files at least, so that's not gone- but reconfiguring everything will take a lot of time!

I can't get any straight answers out of the host- it sounds like he's handling a lot of issues at the moment and doesn't want to take time with me, his five dollar a month client. (lovely, I know.)

Does anyone have advice as to what I should do next?

Thanks again for all the help so far on this issue. :(

21 May 2007, 5:02 PM
#10
jolaedana avatar

jolaedana

New Zenner

Join Date:
Feb 2007
Posts:
34
Plugin Contributions:
0

Re: Fatal Error Message After Host Problems?

Best weekend ever. /sarcasam.

Just a quick update- a complete clean reinstall did NOT work. My hosting provider was incorrect- my files and database were likely just fine, it seems. Looks like it is definitely a server issue as Dr. Byte first suspected.

At this point, I'm going to need to completely reconfigure the store no matter what I do, thanks to his advice.

Just wanted to let folks know that so far, that is NOT the solution. I will post back with what the final problem ended up being.

Thanks again. :)

21 May 2007, 5:21 PM
#11
jolaedana avatar

jolaedana

New Zenner

Join Date:
Feb 2007
Posts:
34
Plugin Contributions:
0

Re: Fatal Error Message After Host Problems?

I've heard back from my server, and they say the following:

Ask the ZenCart people if they have issues with suhosin and or mod security.

Put this in your .htaccess files

SecFilterEngine Off
SecFilterScanPOST Off

I'm going to go ahead and modify the .htacess file- anyone have an answer to the other question?

Thanks again!

22 May 2007, 6:03 AM
#13
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Fatal Error Message After Host Problems?

I hope you never run into any other hosting problems once you go live, or you'll be missing sales. I think I'd consider another host.

As far as I know, Zen Cart has no so-called "issues" ... "with suhosin and or mod security" -- from a store-front perspective.

If mod_security is active, you may have some challenges completing new installations because a number of otherwise-forbidden URL parameters are used. The installer typically overrides the mod_security limitation in these cases.

However, your admin area may also come under some scrutiny by mod_security if you are attempting to run certain commands/actions that your hosting company has deemed to be "dangerous". They mean well and usually only intend to help prevent malicious intrusions. But if you're running into certain ADMIN pages being blocked, you may have to override mod_security by adding the 2 lines he mentioned into your /admin/.htaccess file. If you don't have one, just create it and upload it.

I suppose having these issues suddenly happen as a result of switching servers is also a result of the new server running additional security rules that the older server did not.
You might ask your host to outline what other differences between servers might crop up to bite you in the leg ...

22 May 2007, 3:03 PM
#14
jolaedana avatar

jolaedana

New Zenner

Join Date:
Feb 2007
Posts:
34
Plugin Contributions:
0

Re: Fatal Error Message After Host Problems?

Thanks again, Dr. Byte. I'll pass this along and see what they say.

As for switching hosts, I agree with you- but ultimately it's up to my client.

22 May 2007, 3:08 PM
#15
jolaedana avatar

jolaedana

New Zenner

Join Date:
Feb 2007
Posts:
34
Plugin Contributions:
0

Re: Fatal Error Message After Host Problems?

Quick question- I'm doing some reading- WHICH .htaccess file should I be modifying? In other words, which directory should it be located in?

22 May 2007, 3:44 PM
#16
jolaedana avatar

jolaedana

New Zenner

Join Date:
Feb 2007
Posts:
34
Plugin Contributions:
0

Re: Fatal Error Message After Host Problems?

Nevermind- Just re read and saw it in the answer above. Sorry, this has been a long week.

23 May 2007, 4:05 PM
#17
jolaedana avatar

jolaedana

New Zenner

Join Date:
Feb 2007
Posts:
34
Plugin Contributions:
0

Re: Fatal Error Message After Host Problems?

Well, I think the original problem I started this thread for is solved, after a wonderful and merry chase through futile land with my host (soon to be Ex Host, I'm looking. Any reccomendations would be welcome.)

Basically, they completely wiped and reset the account. Told me there were too many variables to diagnose the issue, they don't even offer ZenCart support, and I was out of luck. (He was apparently doing me a favor talking to me with the word ZenCart in my email at all. I rather feel it was less a favor and more a mistake.)

Told me to just resign myself that I was going to have to restore her website, reinstall ZenCart, and start over.

Since they left me little choice, i went ahead and let them do it. I now have a fresh install of Zen Cart, completely NON Fantastico related.

I am still having problems- my CSS stylesheet isn't loading. I know the FAQ says that I should rename my .htaccess file to see if it's the issue, but I can't see my .htaccess files (I know they're there- if I make my own, I can overwrite it, and when I upload, I see it in the upload logs, but I can't physically click on it to rename it.) It also says I can check logs- but I'm not sure where or how to do that.

THEN it says if it is the problem, I may need to alter my .htaccess file to suit my server's settings- does anyone have any idea HOW I should modify it? Or how I can find out how to modify it when my server refuses to answer any server related questions??

(Should I just give up and jump off the nearest virtual bridge? (and then, of course, find a new host?))

Thanks in advance to anyone reading.

27 May 2007, 3:18 AM
#18
mr_b avatar

mr_b

New Zenner

Join Date:
Mar 2007
Posts:
54
Plugin Contributions:
0

Re: Fatal Error Message After Host Problems?

Me I'd find a new Host, one that works with Zen Cart.

Just my 2 cents.

Bob

GAB-Enterprises

27 May 2007, 4:14 AM
#19
jolaedana avatar

jolaedana

New Zenner

Join Date:
Feb 2007
Posts:
34
Plugin Contributions:
0

Re: Fatal Error Message After Host Problems?

I am in fact doing just that, thanks. :)

I had NO idea how incredibly important it was to have a host that actually understood what was going on with ZenCart- now I know.

We'll be moving to one of the certified hosts this week.