Sorry for the late response. My internet connection was lost again yesterday night.
In the standard ZC, just "disabling" the customer by making the green switch red doesn't do anything.. supposedly there may be future implementation for it but nothing right now. From what it sounds like, this brings that future implementation today.
Sorry, I don't quite understand what you mean by that. The red and green switch works perfectly fine. When enabling (green) the banning feature, the customer gets notified. When the red button is checked, it means that the customer is not banned but, to make sure that other admins to not report this customer twice, the master admin(s) already are aware of their customer's situation. Which is why, reasons are an obligation to be stated when a regular admin wishes to report customers regarding issues they might of had noticed.
irstly, I am using MySQL 3.23.58 and the SQL patch hangs on 'ENGINE = MYISAM'. I removed that entry from both table definitions and it installed the two tables o.k. MyISAM is a default table type anyway and I expect this may not be a prob in later versions of MySQL.
Yes, that is correct. I will update my installation guide for this. I forgot to state that my contributions are tested under mySQL v4.1+ (and not under mySQL v3+ nor mySQL v5+). Regarding the myISAM engine, that is also correct. I do not have any modulations handling for InnoDB engines yet. This has already been planned to be implemented in one of the future releases.
ENTRY_CUSTOMERS_BANNED_STATUS_EDIT_ALT
ahHA ! 'three bugs' in one block. Very well, I will make the corrections immediately and notify on this topic when the updated version will be posted. Thanks for the catch. :smile:
but unfortunately, I can still log in as the banned customer. Also, my homepage heading, log-off page heading and some others now reads 'Account Status'.
Also, I am using UK date formats in the cart and admin so I don't know if that would affect anything.
This is also an instruction I forgot to state since it was also late from my end. The reason why you can still log is because, even when using the zen_session_destroy() function, the customer's cookies must first be cleared out from the site (even cleared out entirely when the browser is closed period). The good news is, you can ajust your expiration session time to a shorter time in case there would be banned users involved. Right now, the unfortunite thing is that this has to be handled globally for everyone. However, I do plan, in one of the future releases, to reduce the expiration time for banned users.
As for the UK date, as long as your server date corresponds well with your central date, I don't think there should be any problems. Besides, this would be up to your related web hosting party to assure this particular functionnality. :wink2:
Email Error: Could not instantiate mail function.
Check your mail error logs to see what might be the cause precisely.