Zen Cart Logo
Forums / Upgrading from 1.3.x to 1.3.9 / urgent ugrade help

urgent ugrade help

Locked

Views: 1,477

Results 1 to 9 of 9
This thread is locked. New replies are disabled.
4 Jun 2007, 9:24 AM
#1
tonkali avatar

tonkali

New Zenner

Join Date:
Sep 2006
Location:
NYC
Posts:
76
Plugin Contributions:
0

urgent ugrade help

Hi All,

:shocking: I urgently need someone to help me. Just finished an upgrade from 1.3.5 > 1.3.7 and all appears well except for the home page, I get this:

Warning: main(includes/languages/english/html_includes/define_main_page.php) [function.main]: failed to open stream: No such file or directory in /home/name/public_html/catalog/includes/templates/template_default/templates/tpl_index_default.php on line 39

Fatal error: main() [function.require]: Failed opening required 'includes/languages/english/html_includes/define_main_page.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/name/public_html/catalog/includes/templates/template_default/templates/tpl_index_default.php on line 39

please help

4 Jun 2007, 9:45 AM
#2
tonkali avatar

tonkali

New Zenner

Join Date:
Sep 2006
Location:
NYC
Posts:
76
Plugin Contributions:
0

Re: urgent ugrade help

couldn't find the edit button. this is what happens when panic stricken.

problem solved, files wasn't there (as stated) but needed a moment.

thanks 4 being here :)

4 Jun 2007, 9:47 AM
#3
chuckl avatar

chuckl

Totally Zenned

Join Date:
Nov 2006
Location:
Papworth, Cambridgeshire, UK
Posts:
717
Plugin Contributions:
0

Re: urgent ugrade help

Have you set the permissions on folder /includes/languages/english/html_includes to 777?

4 Jun 2007, 10:39 AM
#4
tonkali avatar

tonkali

New Zenner

Join Date:
Sep 2006
Location:
NYC
Posts:
76
Plugin Contributions:
0

Re: urgent ugrade help

eGad!!! :shocking:

thanks I hadn't done that but just changed permission. Now I get on the page:

Warning: main(includes/languages/english/html_includes/define_page_2.php) [function.main]: failed to open stream: No such file or directory in /home/blahhh/public_html/blah/includes/templates/opium_custom/templates/tpl_page_2_default.php on line 21

and in the admin:

Define Pages Editor for: english
Warning: is_dir() [function.is-dir]: Stat failed for /home/blah/public_html/blah/includes/languages/english/html_includes/classic (errno=13 - Permission denied) in /home/blah/public_html/blah/admin/define_pages_editor.php on line 22

4 Jun 2007, 10:59 AM
#5
chuckl avatar

chuckl

Totally Zenned

Join Date:
Nov 2006
Location:
Papworth, Cambridgeshire, UK
Posts:
717
Plugin Contributions:
0

Re: urgent ugrade help

I might be wrong, but I suspect all of the files in the folder need 777 permissions as well, if you want to edit or change them.
In your case however, it's complaining about the classic folder inside the html_includes folder. Needs to be 777 as well.

4 Jun 2007, 11:05 AM
#6
tonkali avatar

tonkali

New Zenner

Join Date:
Sep 2006
Location:
NYC
Posts:
76
Plugin Contributions:
0

Re: urgent ugrade help

yeah i chmod'ed all but still no go any other ideas?

in the admin, it's actually telling me:
Define Pages Editor for: english

for all the pages in that folder

4 Jun 2007, 11:14 AM
#7
tonkali avatar

tonkali

New Zenner

Join Date:
Sep 2006
Location:
NYC
Posts:
76
Plugin Contributions:
0

Re: urgent ugrade help

ok Chuckl, thank you so much for helping me :)

ws_ftp wasn't letting me chmod so I went to cpanel and waaaala!!!!

All is well (at least it looks it on the surface).

cricky, no sleep boy will I be worthless at the other job ;).

Again, thanks for responding surely appreciate it.

5 Jun 2007, 1:41 PM
#8
lib99 avatar

lib99

Totally Zenned

Join Date:
Dec 2004
Location:
New York, USA
Posts:
965
Plugin Contributions:
0

Re: urgent ugrade help

Be very careful making files and directories have permissions of 777!! :shocking: With all due respect (not sure how well you understand the permission structure), the first digit are permissions allowed to the file (or directory) owner. Second digit assigns group permissions. Third digit are the permissions allowed to everyone else...ie the public.

So when you assign 777, you are allowing the file (or directory) owner, group AND public full read/write/execute permissions. This is very dangerous!!

Although your problem "appears" resolved because the site is working, you still need to track down why such permissive requirements were necessary. Perhaps the owner and group settings (chown, chgrp) for your files and directories are not set correctly?

Included with the downloaded Zen Cart files is a docs directory. Read up on securing your site. You might also seek some guidance from your server host admin.

6 Jun 2007, 7:20 AM
#9
tonkali avatar

tonkali

New Zenner

Join Date:
Sep 2006
Location:
NYC
Posts:
76
Plugin Contributions:
0

Re: urgent ugrade help

Thanks for the lookout lib99! Read the security documentation included with the upgrade and all files are set accordingly!

each one teach one :smile: