Zen Cart Logo
Forums / Installing on a Linux/Unix Server / Internal server error on downloadable products

Internal server error on downloadable products

Locked

Views: 2,240

Results 1 to 9 of 9
This thread is locked. New replies are disabled.
6 Jun 2007, 9:21 AM
#1
loncika avatar

loncika

New Zenner

Join Date:
Nov 2006
Location:
Hungary
Posts:
11
Plugin Contributions:
0

Internal server error on downloadable products

Hi, May I ask some help?

I am testing my store, created a downloadable free product and after checking out when I woud like to download the zip file, there is 500 internal server error message.
I see that the path is wrong to the zip file.
I uploaded the file into " .../mystore/download " folder but the dl button points to the ".../mystore/pub/.cexpdtxlxfunplzji/..filename.zip

Where and how can I repair it?
Thank you in advance
Ilona

6 Jun 2007, 4:57 PM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Internal server error on downloadable products

The default download method is to serve from the /pub folder ... that's so that users can't easily steal downloads just by knowing the filename and folder.

If you're getting 500 errors, then your server probably doesn't like something in the /pub/.htaccess file that's used to enforce security in the /pub folder.
Try renaming it. If that stops the error, talk to your hosting company about the right settings to use to prevent people from snooping in there.

Alternatively, you might try using different download methods which provide less security. Some of that is discussed in this FAQ:
https://www.zen-cart.com/tutorials/index.php?article=121

6 Jun 2007, 9:00 PM
#3
loncika avatar

loncika

New Zenner

Join Date:
Nov 2006
Location:
Hungary
Posts:
11
Plugin Contributions:
0

Re: Internal server error on downloadable products

Somehow I do not see any .htaccess file on the server.... I know, uploaded all files and folders as it was in the zip file. Just copied back all store datas and there is not these files. In the pub folder there is only a small html file.

Thank you for the URL, it seems to be good, but as I am not expert do not know how to rewrite what need for it...
at first I thought that would be fine if the store admin works on the one, the dl will be on the other site, also have got help to create this, but not worked at all...

6 Jun 2007, 9:53 PM
#4
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Internal server error on downloadable products

Check your FTP program to see if it's configured to "hide" files that start with a "." such as .htaccess.

6 Jun 2007, 9:53 PM
#5
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Internal server error on downloadable products

You should also check your server's "errorlog" for recent errors -- it should explain the cause of the 500 errors.
Your hosting company should be able to explain them as well.

7 Jun 2007, 6:21 AM
#6
loncika avatar

loncika

New Zenner

Join Date:
Nov 2006
Location:
Hungary
Posts:
11
Plugin Contributions:
0

Re: Internal server error on downloadable products

I use Total Commander for FTP, I see the hidden files, but do not dl them from the server... Via my host's Control Panel I can find them, they are there where'd be ...
I asked help from my host and will back to inform you...
Thank you for help.
:hug:
Ilona

7 Jun 2007, 9:02 PM
#7
loncika avatar

loncika

New Zenner

Join Date:
Nov 2006
Location:
Hungary
Posts:
11
Plugin Contributions:
0

Re: Internal server error on downloadable products

Hi,
I am here again, just in crying mood because of helplessness...

I renamed the .htaccess file to .htaccess.bak --- result is 403 forbidden you don't have permition to acces .... files... on this server instead of 500 error.

After changing some post with my host for help the end result is:
"... I have checked if you have enabled Access & Error logs for your account and there seemed that there are no such features activated for your hosts. Unfortunately we are not able to assist you as the problem that you experience is not in our competence. Our company does not offer support for third party scripts as the one you use. "

Is this problem insolvable?

7 Jun 2007, 10:14 PM
#8
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Internal server error on downloadable products

The FAQ link I provided earlier suggested some alternate approaches.

Try this one:

Admin->Configuration->Attribute Settings->Download by Redirect ----> Set to False.

This way ALL your downloads will be served directly from the "download" folder.
People will be able to download anything they want, but at least your server shouldn't encounter the 500-errors.

9 Jun 2007, 11:24 AM
#9
loncika avatar

loncika

New Zenner

Join Date:
Nov 2006
Location:
Hungary
Posts:
11
Plugin Contributions:
0

Re: Internal server error on downloadable products

DrByte:

The FAQ link I provided earlier suggested some alternate approaches....

Thank you for the tutorial link. That is very good idea to place the dl folder outside the shop folder - as in 2nd options is written - , but I am afraid do not know how to resolve it.

So I used your other suggestion, set 'Redirect' to 'False', and the dl works now.

Thank you for help :hug: