Zen Cart Logo
Forums / General Questions / Customers can't 'contact us' or checkout. smtp error - Yahoo hosting

Customers can't 'contact us' or checkout. smtp error - Yahoo hosting

Locked

Views: 4,917

Results 1 to 8 of 8
This thread is locked. New replies are disabled.
27 Jun 2007, 6:52 PM
#1
jcun45 avatar

jcun45

New Zenner

Join Date:
Feb 2006
Location:
Amsterdam
Posts:
73
Plugin Contributions:
0

Customers can't 'contact us' or checkout. smtp error - Yahoo hosting

Hi, my customers are unable to to use 'contact us' or checkout (using the paypal module) without the error message "can not connect to the smtp host".

I use Yahoo small business servers and the checkout used to work fine (at that point I never used the "contact us" button. It all changed when I secured the site by copying all of the zencart files into an ssl folder in the yahoo server (which works great...other than this problem). I have checked my settings in the ADMIN and they seem correct but my customers keep getting the smtp error. My settings are as follows:

E-Mail Transport Method smtpauth
E-Mail Linefeeds LF
Use MIME HTML When Sending Emails false
Send E-Mails true
Verify E-Mail Addresses Through DNS false
Email Archiving Active? false
E-Mail Friendly-Errors false
Email Address (Displayed to Contact you) [email protected]
Email Address (sent FROM) [email protected]
Emails must send from known domain? No
Email Admin Format? HTML
Send Copy of Order Confirmation Emails To [email protected]
Send Copy of Create Account Emails To - Status 1
Send Copy of Create Account Emails To [email protected]
Send Copy of Tell a Friend Emails To - Status 0
Send Copy of Tell a Friend Emails To [email protected]
Send Copy of Customer GV Send Emails To - Status 0
Send Copy of Customer GV Send Emails To [email protected]
Send Copy of Admin GV Mail Emails To - Status 0
Send Copy of Customer Admin GV Mail Emails To [email protected]
Send Copy of Admin Discount Coupon Mail Emails To - Status 0
Send Copy of Customer Admin Discount Coupon Mail Emails To [email protected]
Send Copy of Admin Orders Status Emails To - Status 0
Send Copy of Admin Orders Status Emails To [email protected]
Send Notice of Pending Reviews Emails To - Status 0
Send Notice of Pending Reviews Emails To [email protected]
Set "Contact Us" Email Dropdown List Jeff <[email protected]@address1>, Andy <[email protected]@address2>
Allow Guest To Tell A Friend true
Contact Us - Show Store Name and Address 1
Send Low Stock Emails 0
Send Low Stock Emails To [email protected]
Display "Newsletter Unsubscribe" Link? true
Audience-Select Count Display true
SMTP Email Account Mailbox [email protected]
SMTP Email Account Password *********
SMTP Email Mail Host smtp.bizmail.yahoo.com
SMTP Email Mail Server Port 25
Convert currencies for Text emails £,£:€,€
Emails must send from known domain?

Does your mailserver require that all outgoing emails have their "from" address match a known domain that exists on your webserver?

This is often set in order to prevent spoofing and spam broadcasts. If set to Yes, this will cause the email address (sent FROM) to be used as the "from" address on all outgoing mail.

Date Added:
Last Modified: 06/27/2007


My Yahoo settings are as follows:

Your POP/SMTP Settings
Incoming mail server (POP3): pop.bizmail.yahoo.com
Outgoing mail server (SMTP): smtp.bizmail.yahoo.com
Account name/username: [email protected]
Email address: [email protected]
Password: Your Business Email password

Is there something I'm overlooking? I have been pulling my hair out for more than a week and can't seem to find an answer.

Cheers,

Jeff

Cracked Kettle Amsterdam: Supporting the Independent Brewer, Wine Producer and Distiller.

27 Jun 2007, 8:53 PM
#2
jcun45 avatar

jcun45

New Zenner

Join Date:
Feb 2006
Location:
Amsterdam
Posts:
73
Plugin Contributions:
0

Re: Customers can't 'contact us' or checkout. smtp error - Yahoo hosting

I have also used the instructions for both PHP mail and SMTP for Yahoo from "http://www.zen-cart.com/wiki/index.php/Troubleshoot_-_Email_Problems"

For PHP, I can get the message to send properly but get an error message in the tmp folder "From address not in member domain. Message not sent". For this, e-mails must send from known domain must be 'yes'. However, smtp does not work with any settings.

Does anyone out there know how to set yahoo up for the contact us page? I am thinking there are differences between my root folder and my ssl folder files. DO you know which files these might be? Any other thoughts?

Cheers,

Jeff

Cracked Kettle Amsterdam: Supporting the Independent Brewer, Wine Producer and Distiller.

29 Jun 2007, 10:34 PM
#3
jcun45 avatar

jcun45

New Zenner

Join Date:
Feb 2006
Location:
Amsterdam
Posts:
73
Plugin Contributions:
0

Re: Customers can't 'contact us' or checkout. smtp error - Yahoo hosting

Well, for those of you who are interested, , i am still fighting but have found a work around with Yahoo small business servers. I stuck with the PHP setting as every combination of settings I could think of with the SMTP and SMTPAUTH would not work. With my current settings (see below) I am now able to receive messages from customers using the 'contact us' button.

However, when I receive the e-mail, I get the subject heading: "Mail Delivery Subsystem Returned mail: see transcript for details".

When I open the e-mail I see the error " The original message was received at Thu, 28 Jun 2007 08:46:15 -0700
(PDT)
from root@localhost

----- The following addresses had permanent fatal errors -----
[email protected]@address1

----- Transcript of session follows -----
553 5.1.3 [email protected]@address1... Invalid route address

and below that:Reporting-MTA: dns; p1db2.geo.scd.yahoo.com
Arrival-Date: Thu, 28 Jun 2007 08:46:15 -0700 (PDT)

Final-Recipient: RFC822; [email protected]@address1
X-Actual-Recipient: rfc822; "553 Invalid route
address"@p1db2.geo.scd.yahoo.com
Action: failed
Status: 5.1.3
Last-Attempt-Date: Thu, 28 Jun 2007 08:46:15 -0700 (PDT)

So, it is a work around, however, if someone has a suggestion on how to fix this I would greatly appriciate it. It seem as though the @address1 is screwing things up but if I remove that I do not receive the message... Inaddition, if I say 'NO' to "Emails must send from known domain" I get the smtp error as stated in previous posts.

I have provided my settings from the ADMIN here:

E-Mail Transport Method PHP
E-Mail Linefeeds LF
Use MIME HTML When Sending Emails false
Send E-Mails true
Verify E-Mail Addresses Through DNS false
Email Archiving Active? true
E-Mail Friendly-Errors false
Email Address (Displayed to Contact you) [email protected]
Email Address (sent FROM) [email protected]
Emails must send from known domain? Yes
Email Admin Format? TEXT
Send Copy of Order Confirmation Emails To [email protected]
Send Copy of Create Account Emails To - Status 1
Send Copy of Create Account Emails To [email protected]
Send Copy of Tell a Friend Emails To - Status 1
Send Copy of Tell a Friend Emails To [email protected]
Send Copy of Customer GV Send Emails To - Status 0
Send Copy of Customer GV Send Emails To [email protected]
Send Copy of Admin GV Mail Emails To - Status 0
Send Copy of Customer Admin GV Mail Emails To [email protected]
Send Copy of Admin Discount Coupon Mail Emails To - Status 0
Send Copy of Customer Admin Discount Coupon Mail Emails To [email protected]
Send Copy of Admin Orders Status Emails To - Status 0
Send Copy of Admin Orders Status Emails To [email protected]
Send Notice of Pending Reviews Emails To - Status 0
Send Notice of Pending Reviews Emails To [email protected]
Set "Contact Us" Email Dropdown List Cracked Kettle <[email protected]@address1>
Allow Guest To Tell A Friend true
Contact Us - Show Store Name and Address 1
Send Low Stock Emails 0
Send Low Stock Emails To [email protected]
Display "Newsletter Unsubscribe" Link? true
Audience-Select Count Display true
SMTP Email Account Mailbox [email protected]
SMTP Email Account Password ******
SMTP Email Mail Host smtp.bizmail.yahoo.com
SMTP Email Mail Server Port 25
Convert currencies for Text emails £,£:€,€
Cheers,

Jeff

Cracked Kettle Amsterdam: Supporting the Independent Brewer, Wine Producer and Distiller.

3 Jul 2007, 12:56 PM
#4
jcun45 avatar

jcun45

New Zenner

Join Date:
Feb 2006
Location:
Amsterdam
Posts:
73
Plugin Contributions:
0

Re: Customers can't 'contact us' or checkout. smtp error - Yahoo hosting

Is there anyone out there who uses Yahoo Business Servers for their e-shop?? Should I switch to a different server? Any suggestions?

Cracked Kettle Amsterdam: Supporting the Independent Brewer, Wine Producer and Distiller.

3 Jul 2007, 5:44 PM
#5
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Customers can't 'contact us' or checkout. smtp error - Yahoo hosting

jcun45:

SMTP Email Mail Host smtp.bizmail.yahoo.com
SMTP Email Mail Server Port 25
jcun45:

"can not connect to the smtp host"
This error message means that the address of the smtp host cannot be reached by the webserver. Perhaps contacting your Yahoo Customer Service department might reveal that your account requires different settings to access their SMTP mailserver, esp if their SSL services actually operate from a different server somehow.

jcun45:

I use Yahoo small business servers and the checkout used to work fine (at that point I never used the "contact us" button. It all changed when I secured the site by copying all of the zencart files into an ssl folder in the yahoo server

If you put it back and do NOT run it from their SSL folder, do things work differently?
Perhaps their SSL systems cannot find the SMTP server properly, thus causing the problems?

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

3 Jul 2007, 5:47 PM
#6
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Customers can't 'contact us' or checkout. smtp error - Yahoo hosting

jcun45:

Set "Contact Us" Email Dropdown List Jeff <[email protected]@address1>, Andy <[email protected]@address2>
The "@address1" bit is certainly going to cause you problems, because having 2 @ symbols makes an email address invalid.

jcun45:

I stuck with the PHP setting.

I am now able to receive messages from customers using the 'contact us' button.

However, when I receive the e-mail, I get the subject heading: "Mail Delivery Subsystem Returned mail: see transcript for details".

....

----- The following addresses had permanent fatal errors -----
[email protected]@address1

----- Transcript of session follows -----
553 5.1.3 [email protected]@address1... Invalid route address

jcun45:

E-Mail Transport Method PHP

Set "Contact Us" Email Dropdown List Cracked Kettle <[email protected]@address1>

So ... if you keep the "PHP" setting, but get rid of the invalid @address1 part, what happens ?

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

3 Jul 2007, 10:10 PM
#7
jcun45 avatar

jcun45

New Zenner

Join Date:
Feb 2006
Location:
Amsterdam
Posts:
73
Plugin Contributions:
0

Re: Customers can't 'contact us' or checkout. smtp error - Yahoo hosting

Hi Drbyte,

Thanks for responding. To answer your question. If I remove the extra @address1 the next page says it was sent successfully but I never receive anything in my mail box (or the spam box). So I assume it is a problem with Yahoo. I have tried to contact them via e-mail but have not received a response (they usually do a good job responding, not sure what their problem is now). They do offer PHP mail and I am using the address I set up on their server...but still no joy. I also have an tmp folder that shows e-mail errors but there doesn't seem to be anbything there. So for now I will just keep getting my 'undeliverable' messages for my customers and wait for yahoo's response. Once I get it working I will post the solution (unless you have another suggestion)..

I agree with you about the smtp settings. The ssl must be screwing it up somehow. I'll figure it out eventually. I will wait to hear back from Yahoo though before I remove everything from the ssl folder...

Cheers,

Jeff

Cracked Kettle Amsterdam: Supporting the Independent Brewer, Wine Producer and Distiller.

4 Jul 2007, 3:23 AM
#8
tinypack avatar

tinypack

New Zenner

Join Date:
Apr 2007
Location:
Spudville
Posts:
60
Plugin Contributions:
0

Re: Customers can't 'contact us' or checkout. smtp error - Yahoo hosting

Is there anyone out there who uses Yahoo Business Servers for their e-shop?? Should I switch to a different server? Any suggestions?

I had too many problems with Yahoo. Now I have no problems after switching to a certified host and I am much happier. :yes:

www.PrairieRoses.com
A Country Sensibility