Zen Cart Logo
Forums / General Questions / Backup MYSQL Plugin - Installed but failing - using GoDaddy

Backup MYSQL Plugin - Installed but failing - using GoDaddy

Locked

Views: 2,420

Results 1 to 5 of 5
This thread is locked. New replies are disabled.
12 Jul 2007, 8:18 PM
#1
pastgentoys avatar

pastgentoys

Zen Follower

Join Date:
Jun 2007
Posts:
169
Plugin Contributions:
0

Backup MYSQL Plugin - Installed but failing - using GoDaddy

Is there somthing I can do to fix this?

I get the following:

Result code: 2 0 => /usr/bin/mysqldump: File '/usr/share/mysql/charsets/?.conf' not found (Errcode: 2)
1 => /usr/bin/mysqldump: Character set '#33' is not a compiled character set and is not specified in the '/usr/share/mysql/charsets/Index' file
2 => /usr/bin/mysqldump: Got error: 1251: Client does not support authentication protocol requested by server; consider upgrading MySQL client when trying to connect
Failure: The database has NOT been saved.

and this...

[IMG]http://www.pastgenerationtoys.com/admin/images/icons/file_download.gif[/IMG] db_xxxxxx-20070712131148.sql.gz07/12/2007 13:11:4851 bytes

13 Jul 2007, 3:01 PM
#2
pastgentoys avatar

pastgentoys

Zen Follower

Join Date:
Jun 2007
Posts:
169
Plugin Contributions:
0

Re: Backup MYSQL Plugin - Installed but failing - using GoDaddy

I am using GoDaddy which seems to be the problem... backed it up via the host. All is good.

26 Jul 2007, 5:10 AM
#3
gonewild avatar

gonewild

Zen Follower

Join Date:
Apr 2005
Posts:
145
Plugin Contributions:
0

Re: Backup MYSQL Plugin - Installed but failing - using GoDaddy

I am having the same error problem on two different ZC v1.3.7 installations.
Both are hosted on godaddy. But I have another ZC v1.3.6 hosted on godaddy and the backup works fine. So it seems the problem could be in the v1.3.7 code? and not with godaddy?

Could someone please comment about this error?

26 Jul 2007, 5:14 AM
#4
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Backup MYSQL Plugin - Installed but failing - using GoDaddy

gonewild:

But I have another ZC v1.3.6 hosted on godaddy and the backup works fine.You're VERY lucky then.

There's nothing different between v1.3.7 and v1.3.6 in terms of the backup code. It's an external plugin, and not part of either v1.3.7 or v1.3.6.

If you have it working on one, you'll have to figure out what magic you did to make it work, and then replicate it on the other.

It's likely that your "working" site has luckily got some supported MySQL client code on it that the others don't. That's an issue you'd have to take up with GoDaddy support. Good luck there.

I don't mean to be cheeky ... but ... good luck.

26 Jul 2007, 7:04 AM
#5
gonewild avatar

gonewild

Zen Follower

Join Date:
Apr 2005
Posts:
145
Plugin Contributions:
0

Re: Backup MYSQL Plugin - Installed but failing - using GoDaddy

OK, thanks I'll try to figure it out.