Forums / Customization from the Admin / Fatal Error? Cant access my admin area at all.

Fatal Error? Cant access my admin area at all.

Locked

Views: 2,947

Results 1 to 10 of 10
This thread is locked. New replies are disabled.
18 Jul 2007, 8:29 PM
#1
hybridwookie avatar

hybridwookie

New Zenner

Join Date:
Jul 2007
Posts:
5
Plugin Contributions:
0

Fatal Error? Cant access my admin area at all.

Greetings and thanks in advance for the help!

I get this error message when i go to the admin area on my site.

Warning: require(includes/languages/english/email_extras.php) [function.require]: failed to open stream: No such file or directory in /home/thedon/public_html/1ZenCart1/admin/includes/languages/english.php on line 669

Fatal error: require() [function.require]: Failed opening required 'includes/languages/english/email_extras.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/thedon/public_html/1ZenCart1/admin/includes/languages/english.php on line 669

I have no idea anymore how to solve this problem. I checked for those files and they existed on the server. What am i doing wrong?

18 Jul 2007, 8:38 PM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Fatal Error? Cant access my admin area at all.

Three possibilities:

  1. Did you recently edit the /admin/includes/configure.php ?

  2. Did you recently edit the /admin/includes/languages/english.php file? or copy it from somewhere else ?

  3. Either or both of these files may be missing (check via FTP):
    /includes/languages/english/email_extras.php
    /admin/includes/languages/english/email_extras.php

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

19 Jul 2007, 2:05 PM
#3
hybridwookie avatar

hybridwookie

New Zenner

Join Date:
Jul 2007
Posts:
5
Plugin Contributions:
0

Re: Fatal Error? Cant access my admin area at all.

  1. I only changed the permissions to 644
  2. changed permissions to 644
  3. both files are there.

I just installed zen cart and was going to start adding products and changing settings. This is the first time I tried to access my admin. Im positive that im using the correct path for my admin.

19 Jul 2007, 7:37 PM
#4
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Fatal Error? Cant access my admin area at all.

Can you post the contents of your /admin/includes/configure.php file, without the database password?

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

20 Jul 2007, 1:43 PM
#5
hybridwookie avatar

hybridwookie

New Zenner

Join Date:
Jul 2007
Posts:
5
Plugin Contributions:
0

Re: Fatal Error? Cant access my admin area at all.

<?php // /** * * @package Configuration Settings * @copyright Copyright 2003-2006 Zen Cart Development Team * @copyright Portions Copyright 2003 osCommerce * @license <http://www.zen-cart.com/license/2_0.txt> GNU Public License V2.0 */ /*************** NOTE: This file is similar, but DIFFERENT from the "store" version of configure.php. ***********/ /*************** The 2 files should be kept separate and not used to overwrite each other. ***********/ // Define the webserver and path parameters // Main webserver: eg, <http://localhost> - should not be empty for productive servers // HTTP_SERVER is your Main webserver: eg, <http://www.yourdomain.com> // HTTPS_SERVER is your Secure webserver: eg, <https://www.yourdomain.com> // HTTP_CATALOG_SERVER is your Main webserver: eg, <http://www.yourdomain.com> // HTTPS_CATALOG_SERVER is your Secure webserver: eg, <https://www.yourdomain.com> /* * URLs for your site will be built via: * HTTP_SERVER plus DIR_WS_ADMIN or * HTTPS_SERVER plus DIR_WS_HTTPS_ADMIN or * HTTP_SERVER plus DIR_WS_CATALOG or * HTTPS_SERVER plus DIR_WS_HTTPS_CATALOG * ...depending on your system configuration settings */ define('HTTP_SERVER', 'http://www.ministryofboost.com'); define('HTTPS_SERVER', 'https://www.ministryofboost.com'); define('HTTP_CATALOG_SERVER', 'http://www.ministryofboost.com'); define('HTTPS_CATALOG_SERVER', 'https://www.ministryofboost.com'); // Use secure webserver for catalog module and/or admin areas? define('ENABLE_SSL_CATALOG', 'false'); define('ENABLE_SSL_ADMIN', 'false'); // NOTE: be sure to leave the trailing '/' at the end of these lines if you make changes! // * DIR_WS_* = Webserver directories (virtual/URL) // these paths are relative to top of your webspace ... (ie: under the public_html or httpdocs folder) define('DIR_WS_ADMIN', '/1ZenCart1/admin/'); define('DIR_WS_CATALOG', '/1ZenCart1/'); define('DIR_WS_HTTPS_ADMIN', '/1ZenCart1/admin/'); define('DIR_WS_HTTPS_CATALOG', '/1ZenCart1/'); define('DIR_WS_IMAGES', 'images/'); define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/'); define('DIR_WS_CATALOG_IMAGES', HTTP_CATALOG_SERVER . DIR_WS_CATALOG . 'images/'); define('DIR_WS_CATALOG_TEMPLATE', HTTP_CATALOG_SERVER . DIR_WS_CATALOG . 'includes/templates/'); define('DIR_WS_INCLUDES', 'includes/'); define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/'); define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/'); define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/'); define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/'); define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/'); define('DIR_WS_CATALOG_LANGUAGES', HTTP_CATALOG_SERVER . DIR_WS_CATALOG . 'includes/languages/'); // * DIR_FS_* = Filesystem directories (local/physical) //the following path is a COMPLETE path to your Zen Cart files. eg: /var/www/vhost/accountname/public_html/store/ define('DIR_FS_ADMIN', '/home/thedon/public_html/1ZenCart1/admin/'); define('DIR_FS_CATALOG', '/home/thedon/public_html/1ZenCart1/'); define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/'); define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/'); define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/'); define('DIR_FS_CATALOG_TEMPLATES', DIR_FS_CATALOG . 'includes/templates/'); define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/'); define('DIR_FS_EMAIL_TEMPLATES', DIR_FS_CATALOG . 'email/'); define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/'); // define our database connection define('DB_TYPE', 'mysql'); define('DB_PREFIX', ''); define('DB_SERVER', 'localhost'); define('DB_SERVER_USERNAME', 'thedon_XXXXXX'); define('DB_SERVER_PASSWORD', 'XXXXXXXXXt'); define('DB_DATABASE', 'thedon_mobturbodb'); define('USE_PCONNECT', 'false'); // use persistent connections? define('STORE_SESSIONS', 'db'); // use 'db' for best support, or '' for file-based storage // The next 2 "defines" are for SQL cache support. // For SQL_CACHE_METHOD, you can select from: none, database, or file // If you choose "file", then you need to set the DIR_FS_SQL_CACHE to a directory where your apache // or webserver user has write privileges (chmod 666 or 777). We recommend using the "cache" folder inside the Zen Cart folder // ie: /path/to/your/webspace/public_html/zen/cache -- leave no trailing slash define('SQL_CACHE_METHOD', 'none'); define('DIR_FS_SQL_CACHE', '/home/thedon/public_html/1ZenCart1/cache'); ?>
21 Jul 2007, 9:59 AM
#6
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Fatal Error? Cant access my admin area at all.

That appears to be fine.

Can you delete and re-upload the 1ZenCart1/admin/includes/languages/english folder, with all its files, including the email_extras.php ?

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

24 Jul 2007, 6:40 PM
#7
hybridwookie avatar

hybridwookie

New Zenner

Join Date:
Jul 2007
Posts:
5
Plugin Contributions:
0

Re: Fatal Error? Cant access my admin area at all.

That worked! THANKS! :clap:

10 Sep 2007, 8:19 PM
#8
scrat avatar

scrat

Zen Follower

Join Date:
Dec 2005
Posts:
451
Plugin Contributions:
0

Re: Fatal Error? Cant access my admin area at all.

I have a similar problem I get this error:

Warning: require_once(/public_html/includes/extra_configures/bmz_image_handler_conf.php) [function.require-once]: failed to open stream: No such file or directory in /public_html/admin/includes/extra_configures/bmz_image_handler_conf.php on line 12

Fatal error: require_once() [function.require]: Failed opening required '/public_html/includes/extra_configures/bmz_image_handler_conf.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /public_html/admin/includes/extra_configures/bmz_image_handler_conf.php on line 12

I have just migrated my website to another host and the new host have uploaded my files for me, I have removed the Image Handler files, and it then gave me errors from Zen Core files. I have reinstalled the image Handler files and still same error. Has a file got corrupted in the migration ?

10 Sep 2007, 8:58 PM
#9
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Fatal Error? Cant access my admin area at all.

Scrat:

/public_html/includes/extra_configures/bmz_image_handler_conf.php) [function.require-once]: failed to open stream: No such file or directory
It's telling you that the file doesn't exist on the server.

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

10 Sep 2007, 9:27 PM
#10
scrat avatar

scrat

Zen Follower

Join Date:
Dec 2005
Posts:
451
Plugin Contributions:
0

Re: Fatal Error? Cant access my admin area at all.

Thanks for your reply, found the problem...

there was a missing '/' from /home in the admin config file