Zen Cart Logo
Forums / General Questions / Sudden error - Failed opening required '' in tpl_index_default.php

Sudden error - Failed opening required '' in tpl_index_default.php

Locked

Views: 1,283

Results 1 to 5 of 5
This thread is locked. New replies are disabled.
18 Jul 2007, 9:52 PM
#1
damalo avatar

damalo

New Zenner

Join Date:
Mar 2005
Posts:
2
Plugin Contributions:
0

Sudden error - Failed opening required '' in tpl_index_default.php

Hello,

I'm getting this error:

Fatal error: main() [function.require]: Failed opening required '' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/shootiel/public_html/includes/templates/template_default/templates/tpl_index_default.php on line 39

on https://www.shoot.ie

I'm using SSL. This issue happened all of a sudden and no changes were made to the website. I have tried to turn on and off SSL in the /includes/configure.php file but this has not made any change.

There doesnt seem to be any concrete answer to this problem online

Any advice?

18 Jul 2007, 10:10 PM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Sudden error - Failed opening required '' in tpl_index_default.php

A few things to check:

  1. /includes/modules/pages/index/header_php.php
    around line 43 you should have a line that says this:```
    [B]$define_page[/B] = zen_get_file_directory(DIR_WS_LANGUAGES . $_SESSION['language'] . '/html_includes/', FILENAME_DEFINE_MAIN_PAGE, 'false');

2. /includes/templates/YOUR_TEMPLATE/templates/tpl_index_default.php
*('YOUR_TEMPLATE' could be your customized template if you altered the original tpl_index_default in any way. Or, if you didn't, then it would be picking up the template_default version)*
line 39:
<div id="indexDefaultMainContent" class="content"><?php require([B]$define_page[/B]); ?></div> ```
  1. Do either of these files exist?
    /includes/languages/english/html_includes/define_main_page.php
    or
    /includes/languages/english/html_includes/YOUR_TEMPLATE/define_main_page.php

What permission-levels are set on the files on the server (check via FTP)?

18 Jul 2007, 10:23 PM
#3
damalo avatar

damalo

New Zenner

Join Date:
Mar 2005
Posts:
2
Plugin Contributions:
0

Re: Sudden error - Failed opening required '' in tpl_index_default.php

Check 1, 2 and 3 were all fine.

/includes/languages/english/html_includes/define_main_page.php has permissions:
-rw-rw-rw- 1 shootiel shootiel 1427 May 24 12:36 define_main_page.php

Are there any folders/files you need permissions of?

(Again the strange thing is that this was working fine up to a few hours ago and then bang - it stopped)

18 Jul 2007, 10:52 PM
#4
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Sudden error - Failed opening required '' in tpl_index_default.php

damalo:

/includes/languages/english/html_includes/define_main_page.php has permissions:
-rw-rw-rw- 1 shootiel shootiel 1427 May 24 12:36 define_main_page.php

What happens if you set the file to rwx (777) ?

18 Jul 2007, 10:53 PM
#5
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Sudden error - Failed opening required '' in tpl_index_default.php

damalo:

(Again the strange thing is that this was working fine up to a few hours ago and then bang - it stopped)

I suspect it's likely a global permissions change implemented by your host in a security blitz or something.