Zen Cart Logo
Forums / General Questions / Admin Login Problem Solution (after hosting upgrade to PHP 5)

Admin Login Problem Solution (after hosting upgrade to PHP 5)

Locked

Views: 1,269

Results 1 to 3 of 3
This thread is locked. New replies are disabled.
26 Jul 2007, 7:17 AM
#1
blervin avatar

blervin

New Zenner

Join Date:
Jul 2007
Posts:
2
Plugin Contributions:
0

Admin Login Problem Solution (after hosting upgrade to PHP 5)

So, I see there are countless threads regarding problems logging in to the admin side of things. I just encountered this issue myself and was able to solve it, so now I'm sharing the solution with you all.

First of all, I'm running Zen Cart 1.3.5, MySQL 4.1.22, and PHP version...well, let's get to that in a moment.

My problem was this. When trying to log into the admin side, or even trying to log into a customer account, if a correct user/pass was entered, the login screen just refreshed with no error. No 500 errors in the logs, nothing obvious at all. If an incorrect user/pass combo was entered, the normal "Error: Sorry, there is no match for that email address and/or password." error was shown, as it usually does.

After checking in with my server guy he did just make a pretty significant change: upgrading from PHP4 to PHP5 (5.2.3 to be exact). You see, PHP4 has been EOL'd (see http://www.php.net/archive/2007.php) as announced on July 13. Hence, the upgrade to PHP5 may be widespread and contributing to this trend in login errors.

Now, there is a known bug in PHP 5.2.0 that was previously outlined here: http://www.zen-cart.com/forum/showpost.php?p=287587&postcount=26

Apparently this bug is still present in PHP 5.2.3 but the workaround detailed in that thread solved the problem for me.

I hope this helps a few others, as it certainly stopped me from pulling all of my hair out.

26 Jul 2007, 7:37 AM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Admin Login Problem Solution (after hosting upgrade to PHP 5)

blervin:

Apparently this bug is still present in PHP 5.2.3 but the workaround detailed in that thread solved the problem for me.

FYI - Using or upgrading to v1.3.7 or v1.3.7.1 also resolves that problem.

30 Jul 2007, 10:17 AM
#3
hitch avatar

hitch

New Zenner

Join Date:
Sep 2006
Posts:
75
Plugin Contributions:
0

Re: Admin Login Problem Solution (after hosting upgrade to PHP 5)

hi i am having intermitent problems being kicked off the admin side at random times with no partern really. I can the log back in and it's fine. have searched here and deleted sessions, etc on database with no result and always made sure to clear my computor cache/cookies etc.

any ideas on what i've missed?