Zen Cart Logo
Forums / All Other Contributions/Addons / Auction Lister Pro (ALP) Support

Auction Lister Pro (ALP) Support

Views: 95,811

Results 21 to 40 of 374
30 Jul 2007, 8:25 PM
#21
maxrisc avatar

maxrisc

Zen Follower

Join Date:
Mar 2007
Location:
Houston
Posts:
246
Plugin Contributions:
1

Auction Lister Pro (ALP) Support

ALP-0.5.3 has been released

** Download is available here:**
http://www.zen-cart.com/index.php?main_page=product_contrib_info&cPath=40_47&products_id=673

There is no upgrade. If you have a previous installation you will need to upload everything except for /alp/includes/EbatNs and run the installer.
(http://www.example.com/alp/install)

Brief Change Log

  • eBay API 515 Compatibility
  • Removed Register Globals
  • Changed instance of name "Chinese" to "Regular Auction" to lessen user confusion
  • Now storing UUID in Database after auction creation
  • Added Notification Flag to Auction_List_Sold to avoid multiple emails to winners even if paid (Only one email goes out now. Do not use until email checkout is working)
  • Added CRON job file to check for winners automatically. Hard coded 30 minute interval checks to remain eBay Compatible. (Do not use until email checkout is working on Zen)

NOTE: Other than minor code changes to this release I will not be making any more major changes. I need to focus on getting the email checkout working.

30 Jul 2007, 8:50 PM
#22
charmedbytina2 avatar

charmedbytina2

Totally Zenned

Join Date:
Mar 2007
Location:
AZ
Posts:
1,890
Plugin Contributions:
0

Re: Auction Lister Pro (ALP) Support

**> **ALP-0.5.3 has been released

Download is available here:**
**http://www.zen-cart.com/index.php?ma...roducts_id=673**

It's in the downloads section now. I've got and am going to try it.

Thanks!

Now get some sleep! :blink:**

30 Jul 2007, 9:02 PM
#23
maxrisc avatar

maxrisc

Zen Follower

Join Date:
Mar 2007
Location:
Houston
Posts:
246
Plugin Contributions:
1

Re: Auction Lister Pro (ALP) Support

Sleep is for the weak :smile:

Let me know if you have any problems and I will get them sorted for you.

I need to learn about this template system here. I would like to have my phpBB forum match the store I am installing. So I will go do that for a bit.

30 Jul 2007, 9:16 PM
#24
charmedbytina2 avatar

charmedbytina2

Totally Zenned

Join Date:
Mar 2007
Location:
AZ
Posts:
1,890
Plugin Contributions:
0

Re: Auction Lister Pro (ALP) Support

Let me know if you have any problems and I will get them sorted for you.

Fresh install 0.5.3 I am getting the Internal Server Error.

I removed the .htaccess file and get the register globals is disabled in php.ini error, please enable it.

Am now on the phone with my hosting company!

30 Jul 2007, 9:18 PM
#25
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: Auction Lister Pro (ALP) Support

NOTE: Register Globals OFF is more secure ...

Might recommend only add-ons that are written properly to work with Register Globals ON or OFF ... just as Zen Cart is ... :cool:

EDIT: Oops, I missed maxrisc's earlier post about the mod being updated for RG Off.
So, yes, your hosting company may need to help, or you might need to be sure you uploaded all the fixes from the latest mod update.

... or else the mod still has some Register Globals dependencies :eek:

30 Jul 2007, 9:44 PM
#26
charmedbytina2 avatar

charmedbytina2

Totally Zenned

Join Date:
Mar 2007
Location:
AZ
Posts:
1,890
Plugin Contributions:
0

Re: Auction Lister Pro (ALP) Support

So, yes, your hosting company may need to help, or you might need to be sure you uploaded all the fixes from the latest mod update.
... or else the mod still has some Register Globals dependencies :eek:

Just spoke to my hosting co and was told I need to change my index.php files to index.php.ini which makes no sense to me. They are sending me some documentation on how to get that done.

We'll just have to see if that works! lol

30 Jul 2007, 9:49 PM
#27
maxrisc avatar

maxrisc

Zen Follower

Join Date:
Mar 2007
Location:
Houston
Posts:
246
Plugin Contributions:
1

Re: Auction Lister Pro (ALP) Support

Ajeh:

... or else the mod still has some Register Globals dependencies :eek:

Doh! That could be. I did a lot of changes in the few hours I was working on it.

I did an .htaccess "php_value register_globals 0" to test with.

When I get back to my workstation I will have another look at it. I vaguely recall, during that gray area about 310am, that I might have missed a couple of HTTP_SERVER_VARS.

However this needs to be in its own folder. It should not be installed inside of ZC.

I will have a look shortly and if there are changes I will repost as same revision.

30 Jul 2007, 9:51 PM
#28
maxrisc avatar

maxrisc

Zen Follower

Join Date:
Mar 2007
Location:
Houston
Posts:
246
Plugin Contributions:
1

Re: Auction Lister Pro (ALP) Support

charmedbytina2:

Just spoke to my hosting co and was told I need to change my index.php files to index.php.ini which makes no sense to me. They are sending me some documentation on how to get that done.

We'll just have to see if that works! lol

What?! I've never heard of such a thing. If you do that then all references to index.php will be broked. :blink:

I would love to see this documentation...

30 Jul 2007, 10:23 PM
#29
charmedbytina2 avatar

charmedbytina2

Totally Zenned

Join Date:
Mar 2007
Location:
AZ
Posts:
1,890
Plugin Contributions:
0

Re: Auction Lister Pro (ALP) Support

What?! I've never heard of such a thing. If you do that then all references to index.php will be broked. :blink:

I would love to see this documentation...

I'm still waiting for it to be sent! May have to call again!

30 Jul 2007, 10:51 PM
#30
maxrisc avatar

maxrisc

Zen Follower

Join Date:
Mar 2007
Location:
Houston
Posts:
246
Plugin Contributions:
1

Re: Auction Lister Pro (ALP) Support

Sounds good. I am waiting to hear back before I make any sudden moves. I think what they might be referring to is that your .htaccess might have to be renamed to htaccess.ini or something like that.

I have seen that done before.

The solution above wouldn't work because your cart would be broken using the same logic.

31 Jul 2007, 4:19 AM
#31
maxrisc avatar

maxrisc

Zen Follower

Join Date:
Mar 2007
Location:
Houston
Posts:
246
Plugin Contributions:
1

Re: Auction Lister Pro (ALP) Support

After thinking about this some more...

It is impossible to be getting an error message from ALP that your globals are turned off if you "deleted" the directory and reinstalled it. I know this because I personally removed all of those warning messages from the code in 0.5.3.

So..delete your /alp folder and upload the files from a fresh copy and let me know how that works for you.:smile:

1 Aug 2007, 10:24 PM
#32
wtashby avatar

wtashby

Totally Zenned

Join Date:
Feb 2006
Posts:
594
Plugin Contributions:
0

Re: Auction Lister Pro (ALP) Support

David,

After installing, and getting the Configuration Successfull message, I clicked on the Administration Tool Button and got this:

Warning: main(includes/languages/.php) [function.main]: failed to open stream: No such file or directory in /home/theatcom/public_html/ashbysontheweb/alp/includes/application_top.php on line 142

Warning: main(includes/languages/.php) [function.main]: failed to open stream: No such file or directory in /home/theatcom/public_html/ashbysontheweb/alp/includes/application_top.php on line 142

Fatal error: main() [function.require]: Failed opening required 'includes/languages/.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/theatcom/public_html/ashbysontheweb/alp/includes/application_top.php on line 142

Any thoughts?

1 Aug 2007, 10:31 PM
#33
wtashby avatar

wtashby

Totally Zenned

Join Date:
Feb 2006
Posts:
594
Plugin Contributions:
0

Re: Auction Lister Pro (ALP) Support

I fixed it by changing '.php on line 142 to 'english.php

That seemed to work just fine. (so far:P )

1 Aug 2007, 11:40 PM
#34
wtashby avatar

wtashby

Totally Zenned

Join Date:
Feb 2006
Posts:
594
Plugin Contributions:
0

Re: Auction Lister Pro (ALP) Support

A few things:

  1. How do I make my shopping carts products list in ALP under Create Auction?

  2. What causes this:

Fatal error: Call to undefined function: gettransactionarray() in /home/theatcom/public_html/ashbysontheweb/alp/functions/auction_list_helper.php on line 110

  1. and this:

Fatal error: Call to undefined function: getcategoryversion() in /home/theatcom/public_html/ashbysontheweb/alp/getCategoriesSQL.php on line 62

  1. and this:
  • soap-fault: Auth token is invalid.
    • Validation of the authentication token in API request failed.
  1. Is there a "users manual" yet that instructs you on how to use ALP and all it's features?
2 Aug 2007, 12:58 AM
#35
wtashby avatar

wtashby

Totally Zenned

Join Date:
Feb 2006
Posts:
594
Plugin Contributions:
0

Re: Auction Lister Pro (ALP) Support

Ok, I managed to fix the above errors by uploading a fresh copy of ALP and re-installing..The issues listed in my previous post seem to have resovled, but now, I get this at the top:

Warning: session_start() [function.session-start]: open(/hsphere/local/home/wtashby/theashbymint.com/cache/sess_1a4d227d8bfb081ece63bfdaea14bcfd, O_RDWR) failed: No such file or directory (2) in /home/theatcom/public_html/alp/includes/functions/sessions.php on line 68

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/theatcom/public_html/alp/includes/functions/sessions.php:68) in /home/theatcom/public_html/alp/includes/functions/sessions.php on line 68

and this at the bottom:

Warning: Unknown(): Your script possibly relies on a session side-effect which existed until PHP 4.2.3. Please be advised that the session extension does not consider global variables as a source of data, unless register_globals is enabled. You can disable this functionality and this warning by setting session.bug_compat_42 or session.bug_compat_warn to off, respectively. in Unknown on line 0

Warning: Unknown(): open(/hsphere/local/home/wtashby/theashbymint.com/cache/sess_6949ac07bf864ed7c05178f1f99645a7, O_RDWR) failed: No such file or directory (2) in Unknown on line 0

Warning: Unknown(): Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/hsphere/local/home/wtashby/theashbymint.com/cache) in Unknown on line 0

on EVERY single page.

2 Aug 2007, 1:06 AM
#36
wtashby avatar

wtashby

Totally Zenned

Join Date:
Feb 2006
Posts:
594
Plugin Contributions:
0

Re: Auction Lister Pro (ALP) Support

When clicking on "Get Catagories", this is what is in the pop up window:

Warning: session_start() [function.session-start]: open(/hsphere/local/home/wtashby/theashbymint.com/cache/sess_56b09b67f501b4f178c57a9f441f796f, O_RDWR) failed: No such file or directory (2) in /home/theatcom/public_html/alp/includes/functions/sessions.php on line 68

Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /home/theatcom/public_html/alp/includes/functions/sessions.php:68) in /home/theatcom/public_html/alp/includes/functions/sessions.php on line 68

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/theatcom/public_html/alp/includes/functions/sessions.php:68) in /home/theatcom/public_html/alp/includes/functions/sessions.php on line 68

Get Categories

Fatal error: Call to undefined function: getcategoryversion() in /home/theatcom/public_html/alp/getCategoriesSQL.php on line 62

Warning: Unknown(): Your script possibly relies on a session side-effect which existed until PHP 4.2.3. Please be advised that the session extension does not consider global variables as a source of data, unless register_globals is enabled. You can disable this functionality and this warning by setting session.bug_compat_42 or session.bug_compat_warn to off, respectively. in Unknown on line 0

Warning: Unknown(): open(/hsphere/local/home/wtashby/theashbymint.com/cache/sess_56b09b67f501b4f178c57a9f441f796f, O_RDWR) failed: No such file or directory (2) in Unknown on line 0

Warning: Unknown(): Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/hsphere/local/home/wtashby/theashbymint.com/cache) in Unknown on line 0

2 Aug 2007, 8:29 AM
#37
maxrisc avatar

maxrisc

Zen Follower

Join Date:
Mar 2007
Location:
Houston
Posts:
246
Plugin Contributions:
1

Re: Auction Lister Pro (ALP) Support

It looks like it is wanting to write out session files to your /cache folder when there isn't one. You can try creating a folder called /cache and chmod 777 on the folder to see if it resolves this error.

This is not a permanent solution however. I will add a directive to the installation script to change the cache location so you will no longer receive the errors.

3 Aug 2007, 10:40 AM
#38
jcolley avatar

jcolley

New Zenner

Join Date:
Aug 2007
Posts:
5
Plugin Contributions:
0

Re: Auction Lister Pro (ALP) Support

Hello all-
I have loaded a fresh copy of zen 1.3.7 and ALP. 0.5.3 with ssl on the site.

when I create a Ebay listing from the sample data, I get this error after I click this create Auction.

Error - curl_error 61 Unrecognized content encoding type. libcurl understands identity' and deflate' content encodings.

Not sure what to do at this point.

......Jc

3 Aug 2007, 10:51 AM
#39
jcolley avatar

jcolley

New Zenner

Join Date:
Aug 2007
Posts:
5
Plugin Contributions:
0

Re: Auction Lister Pro (ALP) Support

jcolley:

Hello all-
I have loaded a fresh copy of zen 1.3.7 and ALP. 0.5.3 with ssl on the site.

when I create a Ebay listing from the sample data, I get this error after I click this create Auction.

Error - curl_error 61 Unrecognized content encoding type. libcurl understands identity' and deflate' content encodings.

Not sure what to do at this point.

......Jc

Revision Ino:
libcurl/7.10.3 OpenSSL/0.9.6g ipv6 zlib/1.2.1

3 Aug 2007, 3:35 PM
#40
maxrisc avatar

maxrisc

Zen Follower

Join Date:
Mar 2007
Location:
Houston
Posts:
246
Plugin Contributions:
1

Re: Auction Lister Pro (ALP) Support

ALP doesn't currently support SSL transactions with eBay.

It is a known bug and something I am working on.