Zen Cart Logo
Forums / Upgrading from 1.3.x to 1.3.9 / Just Upgraded Getting Error Trying to Load New Products & Coupons

Just Upgraded Getting Error Trying to Load New Products & Coupons

Locked

Views: 2,747

Results 1 to 11 of 11
This thread is locked. New replies are disabled.
2 Aug 2007, 8:05 PM
#1
wsimkins avatar

wsimkins

New Zenner

Join Date:
Aug 2007
Posts:
4
Plugin Contributions:
0

Just Upgraded Getting Error Trying to Load New Products & Coupons

I upgraded on Monday and was trying to load products today. I get an error message similar to the one below.

I was loading new coupons (got 2 of them loaded fine) and then all of a sudden started getting the following message. I am suppose to send 1400 emails tomorrow offering the coupons to my customers and can't seem to find the probelm.

Forbidden
You don't have permission to access /parts/admin/coupon_admin.php on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


Apache/1.3.37 Server at https://www.cunninghamcampers.com Port 80

Any suggestions?

2 Aug 2007, 9:25 PM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Just Upgraded Getting Error Trying to Load New Products & Coupons

What were the details of the coupon you were entering when this happened?
Does it still happen constantly? or is it intermittent?
What does your server's errorlog say about it?

2 Aug 2007, 9:36 PM
#3
wsimkins avatar

wsimkins

New Zenner

Join Date:
Aug 2007
Posts:
4
Plugin Contributions:
0

Re: Just Upgraded Getting Error Trying to Load New Products & Coupons

A simple $5.00 Off Coupon that expires the 31st of this month.

The error now happens all the time.

I checked my server error logs and the error I am receiving is not resident in the log file so I figure it has to be in the software.

Reading further I see others have had problems upgrading through CPanel. I did the upgrade through CPanel and think maybe I should try it manually. You think that will help?

2 Aug 2007, 9:43 PM
#4
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Just Upgraded Getting Error Trying to Load New Products & Coupons

wsimkins:

Reading further I see others have had problems upgrading through CPanel. I did the upgrade through CPanel and think maybe I should try it manually. You think that will help?

You mean you used Fantastico's upgrade option?

Didn't their upgrade instructions warn to NOT use their upgrade option if you've customized your site?
As a general rule, if you've made ANY changes to your site since installation, you should ALWAYS do a manual upgrade.

So, yes, reviewing your upgrade manually is likely a good next step.

2 Aug 2007, 9:44 PM
#5
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Just Upgraded Getting Error Trying to Load New Products & Coupons

wsimkins:

A simple $5.00 Off Coupon that expires the 31st of this month.

The error now happens all the time.Where does it happen?
When does it happen?
Can you access the page at all?
Does it give the error only when submitting the details of a new coupon?
What are the words you're using to describe the new coupon?

2 Aug 2007, 9:50 PM
#6
wsimkins avatar

wsimkins

New Zenner

Join Date:
Aug 2007
Posts:
4
Plugin Contributions:
0

Re: Just Upgraded Getting Error Trying to Load New Products & Coupons

Coupon Name: $5.00 OFF Lynx Levelers 10 Pack

I get the error when I use the preview button once I have input the required info.

You saw the error message. I get the same thing when I try to input new products through admin. I can insert them via Easy Populate just fine.

Beats me, I've been using Zen for several years and have never had a problem. This just happens to be a new store for my employer, not my personal one. I thought maybe it had something to do with the upgrade.

2 Aug 2007, 10:20 PM
#7
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Just Upgraded Getting Error Trying to Load New Products & Coupons

I was wondering if any of the words you were using might be considered as dangerous by some server-side security software. Using terms common to web URLs can often trigger security systems which will forbid access to the page so that if there is a hack attempt occurring, the system remains safe.
From what you've described, I don't think that's the problem in this case.

I recommend a manual upgrade.
Or better yet, try a fresh v1.3.7.1 install in a separate folder and separate database ... then test the coupon thing there. If the error persists, it's a server problem. If not, then it's an upgrade problem.
Then import your current database into the temporary database, and test that. See if the problem continues. If not, then it's an upgrade problem with the files on your site ... which means you need to manually review each.

2 Aug 2007, 10:47 PM
#8
wsimkins avatar

wsimkins

New Zenner

Join Date:
Aug 2007
Posts:
4
Plugin Contributions:
0

Re: Just Upgraded Getting Error Trying to Load New Products & Coupons

Thanks. Am trying that now.

19 Nov 2007, 6:25 AM
#9
shyjo avatar

shyjo

New Zenner

Join Date:
Nov 2007
Posts:
1
Plugin Contributions:
0

Re: Just Upgraded Getting Error Trying to Load New Products & Coupons

I have got the same problem in my sites. When we submit a form with content "Lynx" and followed by a space and any characters .. it shows a forbidden error. I tried to this many times and this is only the problem with UNIX servers. I am also waiting for a solution............

Thanks

:mellow:

19 Nov 2007, 7:49 AM
#10
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Just Upgraded Getting Error Trying to Load New Products & Coupons

There is no solution that can be provided by Zen Cart.
That's a forbidden word on your webserver's configuration.

You'll need to talk to your hosting company about their mod_security configuration and ask them to either turn off the rule preventing the use of the word "lynx" or give you the ability to turn off mod_security for just your website. They might give you something to add to your .htaccess file to turn it off, which they should be able to explain how to change.

"lynx" is the name of a browser, and hackers often use text-based browsers such as lynx to launch attacks on webservers. Thus, many hosts prohibit the word from being used. They'll not likely turn the rule off for you.

19 Nov 2007, 5:09 PM
#11
website_rob avatar

website_rob

Inactive

Join Date:
Oct 2006
Location:
Alberta, Canada
Posts:
4,572
Plugin Contributions:
0

Re: Just Upgraded Getting Error Trying to Load New Products & Coupons

I do believe DrByte is on the correct path.

Check with your Hoster and ask this question.

Is mod_security being used?

if this Rule is used: SecFilter THE_REQUEST "lynx "
will you change it to: SecFilterSelective THE_REQUEST "lynx "

The second Rule will still give the desired protection but allow sites on the Server to use the word "lynx " within Forum postings, Forms, etc.