Zen Cart Logo
Forums / Basic Configuration / Strange Image Error Message!

Strange Image Error Message!

Locked

Views: 2,942

Results 1 to 16 of 16
This thread is locked. New replies are disabled.
12 Aug 2007, 6:00 PM
#1
kimberlyeddy avatar

kimberlyeddy

New Zenner

Join Date:
Sep 2006
Posts:
33
Plugin Contributions:
0

Strange Image Error Message!

In trying to resolve my problems I was having, I installed the newer version of Zen Cart....and everything went well until I looked at my site...

The images for products are not showing up at all, and the images for banners aren't either. In addition, I have a string of error messages (all are very similar) at the bottom of each product page. The error message looks like this:

"Warning: is_dir() [function.is-dir]: Stat failed for images/. (errno=13 - Permission denied) in /home3/mkeddy/joyfulmomma-www/bookstore2/zc/includes/modules/additional_images.php on line **44"

I first double checked my permissions on my folders to make sure I didn't set any too high ,but that doesn't seem to be the problem. all of my images are wehre they are supposed to be. I read someone having a similar but not exactly the same problem on this forum, and I followed the advice given (I installed the additional_images.php file into a new folder under /modules/ for my template name). Nothing seems to be working. I haven't been able to find any information on this exact error anywhere in the forums.:blink:

Any ideas? The shopping cart is located at https://www.joyfulmomma.org/bookstore2/zc/

Thanks!

Kimberly Eddy
**

12 Aug 2007, 6:04 PM
#2
Kim avatar

Kim

Obaa-san

Join Date:
Jun 2003
Location:
West Coast, North America
Posts:
26,616
Plugin Contributions:
0

Re: Strange Image Error Message!

Has the site ever functioned properly?

12 Aug 2007, 6:05 PM
#3
Kim avatar

Kim

Obaa-san

Join Date:
Jun 2003
Location:
West Coast, North America
Posts:
26,616
Plugin Contributions:
0

Re: Strange Image Error Message!

What version are you using? What Addons do you have installed?

12 Aug 2007, 7:47 PM
#4
kimberlyeddy avatar

kimberlyeddy

New Zenner

Join Date:
Sep 2006
Posts:
33
Plugin Contributions:
0

Re: Strange Image Error Message!

The site only functioned properly when it was the old version (up until a few months ago when it was hacked and since then hasn't worked). I was told to upgrade to the new version so I just installed that, and that is what we are working with now. This is the first time I have received this error message.

I'm using version 1.3.7.1 and I have no add ons other than creating a custom template.

blessings,
Kimberly

12 Aug 2007, 8:09 PM
#5
Kim avatar

Kim

Obaa-san

Join Date:
Jun 2003
Location:
West Coast, North America
Posts:
26,616
Plugin Contributions:
0

Re: Strange Image Error Message!

What did you use to change the permissions on the images and their directories?

12 Aug 2007, 8:58 PM
#6
kimberlyeddy avatar

kimberlyeddy

New Zenner

Join Date:
Sep 2006
Posts:
33
Plugin Contributions:
0

Re: Strange Image Error Message!

I used Filezilla (an FTP software) to change the permissions.

14 Aug 2007, 2:56 AM
#7
kimberlyeddy avatar

kimberlyeddy

New Zenner

Join Date:
Sep 2006
Posts:
33
Plugin Contributions:
0

Re: Strange Image Error Message!

Does anyone have any ideas on how to solve this? I still haven't heard back and I'd like to get my site working again.

14 Aug 2007, 4:34 PM
#8
kimberlyeddy avatar

kimberlyeddy

New Zenner

Join Date:
Sep 2006
Posts:
33
Plugin Contributions:
0

Re: Strange Image Error Message!

Hi wise ones,
I posted this on another forum section, but I am assuming that was the wrong area, as I got a few questions but no answers, and I am rather desparate to get my cart working again, as every day is money lost.

My situation:
In trying to resolve my problems I was having, I installed the newer version of Zen Cart....and everything went well until I looked at my site...

The images for products are not showing up at all, and the images for banners aren't either. In addition, I have a string of error messages (all are very similar) at the bottom of each product page. The error message looks like this:

"Warning: is_dir() [function.is-dir]: Stat failed for images/. (errno=13 - Permission denied) in /home3/mkeddy/joyfulmomma-www/bookstore2/zc/includes/modules/additional_images.php on line **44"

** I first double checked my permissions on my folders to make sure I didn't set any too high ,but that doesn't seem to be the problem. all of my images are wehre they are supposed to be. I read someone having a similar but not exactly the same problem on this forum, and I followed the advice given (I installed the additional_images.php file into a new folder under /modules/ for my template name). Nothing seems to be working. I haven't been able to find any information on this exact error anywhere in the forums.:blink:

Any ideas? The shopping cart is located at www.joyfulmomma.org/bookstore2/zc/

I am using 1.3.7, and I reset all of my image folders to 777 using FileZilla. This is the first time I have ever gotten this message. The cart worked well for a year, until I was hacked (proxy server) and when I fixed it, apparently customers were unable to create new accounts ,so by Ajeh's advice, I installed 1.3.7. This has gone smoothly, until I started creating my products. As you can see, product images, as well as banner images don't appear, and on specific product pages, there is a list of error messages like the one above.

Thanks!

Kimberly Eddy

14 Aug 2007, 4:50 PM
#9
Kim avatar

Kim

Obaa-san

Join Date:
Jun 2003
Location:
West Coast, North America
Posts:
26,616
Plugin Contributions:
0

Re: Strange Image Error Message!

Please do not start a new thread for the same problem. The 2 threads have been merged.

14 Aug 2007, 8:55 PM
#10
kimberlyeddy avatar

kimberlyeddy

New Zenner

Join Date:
Sep 2006
Posts:
33
Plugin Contributions:
0

Re: Strange Image Error Message!

I'm sorry, Kim.

Did you have any further ideas as to why this is happening or what i might try?

16 Aug 2007, 8:14 PM
#11
kimberlyeddy avatar

kimberlyeddy

New Zenner

Join Date:
Sep 2006
Posts:
33
Plugin Contributions:
0

Re: Strange Image Error Message!

I noticed something new....the images are also not appearing in my admin area either. When I was going through my admin trying to figure out if there was something in the admin causing this error, it appears that my banners are not appearing in the banner manager, and I get the same error message except that the path receiving the error is

/MYADMIN/banner_manager.php on line 237

I find this really odd as the banners were appearing in there earlier before I created my products and catagories. I bring this up in the hopes someone can help me figure this out.

Kimberly

16 Aug 2007, 8:42 PM
#12
kimberlyeddy avatar

kimberlyeddy

New Zenner

Join Date:
Sep 2006
Posts:
33
Plugin Contributions:
0

Re: Strange Image Error Message!

I mention to also mention...when I was in my admin it turns out that the problem with the images (the original problem) was because when I uploaded images for my banners, it uploaded the images into the /banners/ directory (as instructed) but it also created the file name like this: bannersmybannerfile.jpg. I had go to in and delete the words "banners" in all of the file names.

The problem with the product images disappeared after I dealt with the banners though I have no idea how the two could have possibly been related.

The admin still has no images and lots of error messages relating to missing images.

16 Aug 2007, 9:34 PM
#13
Kim avatar

Kim

Obaa-san

Join Date:
Jun 2003
Location:
West Coast, North America
Posts:
26,616
Plugin Contributions:
0

Re: Strange Image Error Message!

Please post your admin/includes/configure.php without your password.

16 Aug 2007, 10:49 PM
#14
kimberlyeddy avatar

kimberlyeddy

New Zenner

Join Date:
Sep 2006
Posts:
33
Plugin Contributions:
0

Re: Strange Image Error Message!

Here it is:

<?php // // +----------------------------------------------------------------------+ // |zen-cart Open Source E-commerce | // +----------------------------------------------------------------------+ // | Copyright (c) 2003 The zen-cart developers | // | | // | <http://www.zen-cart.com/index.php> | // | | // | Portions Copyright (c) 2003 osCommerce | // +----------------------------------------------------------------------+ // | This source file is subject to version 2.0 of the GPL license, | // | that is bundled with this package in the file LICENSE, and is | // | available through the world-wide-web at the following url: | // | <http://www.zen-cart.com/license/2_0.txt>. | // | If you did not receive a copy of the Zen Cart license and are unable | // | to obtain it through the world-wide-web, please send a note to | // | [email protected] so we can mail you a copy immediately. | // +----------------------------------------------------------------------+ // $Id: dist-configure.php 4095 2006-08-08 02:32:01Z drbyte $ // // Define the webserver and path parameters // HTTP_SERVER is your Main webserver: eg, <http://www.yourdomain.com> // HTTPS_SERVER is your Secure webserver: eg, <https://www.yourdomain.com> // HTTP_CATALOG_SERVER is your Main webserver: eg, <http://www.yourdomain.com> // HTTPS_CATALOG_SERVER is your Secure webserver: eg, <https://www.yourdomain.com> /* * URL's for your site will be built via: * HTTP_SERVER plus DIR_WS_ADMIN or * HTTPS_SERVER plus DIR_WS_HTTPS_ADMIN or * HTTP_SERVER plus DIR_WS_CATALOG or * HTTPS_SERVER plus DIR_WS_HTTPS_CATALOG * ...depending on your system configuration settings */ define('HTTP_SERVER', 'xxxxxxxxxxx); define('HTTPS_SERVER', 'https://1xxxxxxxx'); define('HTTP_CATALOG_SERVER', 'http://xxxxxxxx'); define('HTTPS_CATALOG_SERVER', 'https://xxxxxx'); // secure webserver for catalog module and/or admin areas? define('ENABLE_SSL_CATALOG', 'false'); define('ENABLE_SSL_ADMIN', 'false'); // NOTE: be sure to leave the trailing '/' at the end of these lines if you make changes! // * DIR_WS_* = Webserver directories (virtual/URL) // these paths are relative to top of your webspace ... (ie: under the public_html or httpdocs folder) define('DIR_WS_ADMIN', '/xxxxxxxxxxx(name of my admin folder/'); define('DIR_WS_CATALOG', '/'); define('DIR_WS_HTTPS_ADMIN', '/xxxxxxxxxxx(name of my admin folder/'); define('DIR_WS_HTTPS_CATALOG', '/'); define('DIR_WS_IMAGES', 'images/'); define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/'); define('DIR_WS_CATALOG_IMAGES', HTTP_CATALOG_SERVER . DIR_WS_CATALOG . 'images/'); define('DIR_WS_CATALOG_TEMPLATE', HTTP_CATALOG_SERVER . DIR_WS_CATALOG . 'includes/templates/'); define('DIR_WS_INCLUDES', 'includes/'); define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/'); define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/'); define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/'); define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/'); define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/'); define('DIR_WS_CATALOG_LANGUAGES', HTTP_CATALOG_SERVER . DIR_WS_CATALOG . 'includes/languages/'); // * DIR_FS_* = Filesystem directories (local/physical) //the following path is a COMPLETE path to your Zen Cart files. eg: /var/www/vhost/accountname/public_html/store/ define('DIR_FS_ADMIN', '/xxxxxxxxxxx(name of my admin folder/'); define('DIR_FS_CATALOG', '/'); define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/'); define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/'); define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/'); define('DIR_FS_CATALOG_TEMPLATES', DIR_FS_CATALOG . 'includes/templates/'); define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/'); define('DIR_FS_EMAIL_TEMPLATES', DIR_FS_CATALOG . 'email/'); define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/'); // define our database connection define('DB_TYPE', 'xxxxxx'); define('DB_PREFIX', 'xxxxxx'); define('DB_SERVER', 'xxxxxxx'); define('DB_SERVER_USERNAME', 'xxxxxx'); define('DB_SERVER_PASSWORD', 'xxxxxxxx'); define('DB_DATABASE', ''); define('USE_PCONNECT', 'xxxxxxx'); // use persistent connections? define('STORE_SESSIONS', 'xxxxx'); // use 'db' for best support, or '' for file-based storage // The next 2 "defines" are for SQL cache support. // For SQL_CACHE_METHOD, you can select from: none, database, or file // If you choose "file", then you need to set the DIR_FS_SQL_CACHE to a directory where your apache // or webserver user has write privileges (chmod 666 or 777). We recommend using the "cache" folder inside the Zen Cart folder // ie: /path/to/your/webspace/public_html/zen/cache -- leave no trailing slash define('SQL_CACHE_METHOD', 'none'); define('DIR_FS_SQL_CACHE', '/enter/your/path/to/public_html_or_htdocs/and/zencart/here/zen/cache'); ?
16 Aug 2007, 11:02 PM
#15
Kim avatar

Kim

Obaa-san

Join Date:
Jun 2003
Location:
West Coast, North America
Posts:
26,616
Plugin Contributions:
0

Re: Strange Image Error Message!

Please try it again and LEAVE THE DOMAIN in place.

17 Aug 2007, 1:05 AM
#16
kimberlyeddy avatar

kimberlyeddy

New Zenner

Join Date:
Sep 2006
Posts:
33
Plugin Contributions:
0

Re: Strange Image Error Message!

Here it is

<?php
//
/**
 *
 * @package Configuration Settings
 * @copyright Copyright 2003-2006 Zen Cart Development Team
 * @copyright Portions Copyright 2003 osCommerce
 * @license <http://www.zen-cart.com/license/2_0.txt> GNU Public License V2.0
 */


/*************** NOTE: This file is similar, but DIFFERENT from the "store" version of configure.php. ***********/
/***************       The 2 files should be kept separate and not used to overwrite each other.      ***********/

// Define the webserver and path parameters
  // Main webserver: eg, <http://localhost> - should not be empty for productive servers
  // HTTP_SERVER is your Main webserver: eg, <http://www.yourdomain.com>
  // HTTPS_SERVER is your Secure webserver: eg, <https://www.yourdomain.com>
  // HTTP_CATALOG_SERVER is your Main webserver: eg, <http://www.yourdomain.com>
  // HTTPS_CATALOG_SERVER is your Secure webserver: eg, <https://www.yourdomain.com>
  /* 
   * URLs for your site will be built via:  
   *     HTTP_SERVER plus DIR_WS_ADMIN or
   *     HTTPS_SERVER plus DIR_WS_HTTPS_ADMIN or 
   *     HTTP_SERVER plus DIR_WS_CATALOG or 
   *     HTTPS_SERVER plus DIR_WS_HTTPS_CATALOG
   * ...depending on your system configuration settings
   */
  define('HTTP_SERVER', 'http://joyfulmomma.org');
  define('HTTPS_SERVER', 'https://joyfulmomma.org');
  define('HTTP_CATALOG_SERVER', 'http://joyfulmomma.org');
  define('HTTPS_CATALOG_SERVER', 'https://joyfulmomma.org');

  // Use secure webserver for catalog module and/or admin areas?
  define('ENABLE_SSL_CATALOG', 'false');
  define('ENABLE_SSL_ADMIN', 'false');

// NOTE: be sure to leave the trailing '/' at the end of these lines if you make changes!
// * DIR_WS_* = Webserver directories (virtual/URL)
  // these paths are relative to top of your webspace ... (ie: under the public_html or httpdocs folder)
  define('DIR_WS_ADMIN', '/bookstore2/zc/r14j12k1969/');
  define('DIR_WS_CATALOG', '/bookstore2/zc/');
  define('DIR_WS_HTTPS_ADMIN', '/bookstore2/zc/r14j12k1969/');
  define('DIR_WS_HTTPS_CATALOG', '/bookstore2/zc/');

  define('DIR_WS_IMAGES', 'images/');
  define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
  define('DIR_WS_CATALOG_IMAGES', HTTP_CATALOG_SERVER . DIR_WS_CATALOG . 'images/');
  define('DIR_WS_CATALOG_TEMPLATE', HTTP_CATALOG_SERVER . DIR_WS_CATALOG . 'includes/templates/');
  define('DIR_WS_INCLUDES', 'includes/');
  define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
  define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
  define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
  define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
  define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');
  define('DIR_WS_CATALOG_LANGUAGES', HTTP_CATALOG_SERVER . DIR_WS_CATALOG . 'includes/languages/');

// * DIR_FS_* = Filesystem directories (local/physical)
  //the following path is a COMPLETE path to your Zen Cart files. eg: /var/www/vhost/accountname/public_html/store/
  define('DIR_FS_ADMIN', '/home/mkeddy/joyfulmomma-www/bookstore2/zc/r14j12k1969/');
  define('DIR_FS_CATALOG', '/home/mkeddy/joyfulmomma-www/bookstore2/zc/');

  define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');
  define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');
  define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');
  define('DIR_FS_CATALOG_TEMPLATES', DIR_FS_CATALOG . 'includes/templates/');
  define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');
  define('DIR_FS_EMAIL_TEMPLATES', DIR_FS_CATALOG . 'email/');
  define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

// define our database connection
  define('DB_TYPE', 'mysql');
  define('DB_PREFIX', '');
  define('DB_SERVER', 'localhost');
  define('DB_SERVER_USERNAME', 'xxxxxx');
  define('DB_SERVER_PASSWORD', 'xxxxxxxx');
  define('DB_DATABASE', 'joyfulmomma_org');
  define('USE_PCONNECT', 'false'); // use persistent connections?
  define('STORE_SESSIONS', 'db'); // use 'db' for best support, or '' for file-based storage

  // The next 2 "defines" are for SQL cache support.
  // For SQL_CACHE_METHOD, you can select from:  none, database, or file
  // If you choose "file", then you need to set the DIR_FS_SQL_CACHE to a directory where your apache 
  // or webserver user has write privileges (chmod 666 or 777). We recommend using the "cache" folder inside the Zen Cart folder
  // ie: /path/to/your/webspace/public_html/zen/cache   -- leave no trailing slash  
  define('SQL_CACHE_METHOD', 'none'); 
  define('DIR_FS_SQL_CACHE', '/home/mkeddy/joyfulmomma-www/bookstore2/zc/cache');

?>