Zen Cart Logo
Forums / General Questions / 1054 Unknown column 'c.parent_id' in 'on clause'

1054 Unknown column 'c.parent_id' in 'on clause'

Locked

Views: 1,270

Results 1 to 3 of 3
This thread is locked. New replies are disabled.
27 Aug 2007, 2:41 PM
#1
linkedla avatar

linkedla

New Zenner

Join Date:
Mar 2005
Location:
Bogotá, Colombia
Posts:
32
Plugin Contributions:
1

1054 Unknown column 'c.parent_id' in 'on clause'

Hello, I am having this problem:

1054 Unknown column 'c.parent_id' in 'on clause'
in:
[SELECT c.categories_id as id, c.parent_id, cd.categories_name as cName, cd2.categories_name as pName FROM zce_categories c, zce_categories_description cd LEFT JOIN zce_categories_description cd2 ON c.parent_id=cd2.categories_id AND cd2.language_id='2' WHERE c.categories_id=cd.categories_id AND cd.language_id='2']

The site is in spanish, and this is the DB history:
v1.3.6 [2007-08-27 08:52:21] (Version Update 1.3.5->1.3.6)
v1.3.5 [2007-08-27 08:52:20] (Version Update 1.3.0.2->1.3.5)
v1.3.0.2 [2006-06-23 18:49:13] (Version Update 1.3.0.1->1.3.0.2)
v1.3.0.1 [2006-06-23 18:49:12] (Version Update 1.3.0->1.3.0.1)
v1.3.0.1 [2006-05-31 01:07:12] (Fresh Installation)

but i can not get it to work. :(
Please help.
I am :frusty: now with this.
Thanks for your valuable help.

27 Aug 2007, 5:15 PM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: 1054 Unknown column 'c.parent_id' in 'on clause'

When did this start happening?
What procedures did you follow when upgrading to v1.3.7 ?
What addons/contributions are installed on your site?
What screen(s) do you see this error on ?
Can you provide the URL where we can see the error happening ?

28 Aug 2007, 1:37 PM
#3
linkedla avatar

linkedla

New Zenner

Join Date:
Mar 2005
Location:
Bogotá, Colombia
Posts:
32
Plugin Contributions:
1

Re: 1054 Unknown column 'c.parent_id' in 'on clause'

It seems to be a SEO URL problem.

Add category parent to begining of URLs? I have this on true. now it is false and the site comes to live again, I have now to make the adjustments to the upgrade to correctly reflects the site due to some overwrites in the language files, (my mistake) but it solves all the problem just a change from true to false. in this:

Add category parent to begining of URLs?

in the SEO URLs at the bottom of the menu in Admin--> Configure

I have on this site IH2, Quick Updates, SEO URLs, this I do not remember if is a mod or is native in the original install, sorry i am not an expert on Zen :oops:

I hope this can help us all.

For the upgrade i did the procedures as in the manual, upload and upgrade button.
the error comes in homepage so I can't never pass form here but i think the error comes in all the site.
https://www.electrogeno.com, but now this is working ok without the Add category parent to begining of URLs? iin false.