Zen Cart Logo
Forums / Installing on a Linux/Unix Server / * Error encountered while writing /includes/configure.php - GOING MAD!!!!!!!

* Error encountered while writing /includes/configure.php - GOING MAD!!!!!!!

Locked

Views: 3,663

Results 1 to 12 of 12
This thread is locked. New replies are disabled.
2 Sep 2007, 3:09 PM
#1
effect avatar

effect

New Zenner

Join Date:
Aug 2007
Posts:
15
Plugin Contributions:
0

* Error encountered while writing /includes/configure.php - GOING MAD!!!!!!!

ok so ive tried to install serveral times now and on the install script i get to the database thing and get this msg,

  • Error encountered while writing /includes/configure.php

what do i have to do? ive checked on the ftp and they are set to 777, also renamed....do i have to do anything else to them? edit them etc?

PLEASE HELP

msn or aim anyone?

2 Sep 2007, 3:22 PM
#2
heathenmagic avatar

heathenmagic

Totally Zenned

Join Date:
May 2005
Location:
England
Posts:
733
Plugin Contributions:
0

Re: * Error encountered while writing /includes/configure.php - GOING MAD!!!!!!!

Hello there,

I haven't used the installer for ages, I do it all manual, but I think you have to fill in the Database name, user name and password. And an extra one aswell, unsure what it is called. One answer is usually localhost, but the rest you have to get off your host. Does your host have an admin interface that you can connect to?

:smile:

2 Sep 2007, 3:26 PM
#3
effect avatar

effect

New Zenner

Join Date:
Aug 2007
Posts:
15
Plugin Contributions:
0

Re: * Error encountered while writing /includes/configure.php - GOING MAD!!!!!!!

no thats fine...the database info is fine but then i get this error,

Error encountered while writing /includes/configure.php more info...

2 Sep 2007, 3:33 PM
#4
effect avatar

effect

New Zenner

Join Date:
Aug 2007
Posts:
15
Plugin Contributions:
0

Re: * Error encountered while writing /includes/configure.php - GOING MAD!!!!!!!

http://www.sellmysound.com/store/

thats my store url....

do i have to edit the configure files other than chnaging them to 777 and renaming

2 Sep 2007, 3:59 PM
#5
Kim avatar

Kim

Obaa-san

Join Date:
Jun 2003
Location:
West Coast, North America
Posts:
26,659
Plugin Contributions:
0

Re: * Error encountered while writing /includes/configure.php - GOING MAD!!!!!!!

Ask your host if scripts are allowed to write to files on your server.

Please do not PM for support issues: a private solution doesn't benefit the community.

Be careful with unsolicited advice via email or PM - Make sure the person you are talking to is a reliable source.

2 Sep 2007, 5:04 PM
#6
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: * Error encountered while writing /includes/configure.php - GOING MAD!!!!!!!

Effect:

  • Error encountered while writing /includes/configure.phpThat message means that after the installer "wrote" the settings to the configure.php files , and tried to read them back to verify that they wrote successfully, it found different or incomplete information.

The installer cannot guess "why" the information is wrong. It just knows that the writing of the changes it needed to make ... failed.

That's usually a result of permissions blockages or insufficient disk space available in your hosting account.

Additionally, at the bottom of this page, under "Similar Threads", you'll see 4 more links to posts on the same topic. They boid down to basically the same root causes as I just stated, but if you want to read others' experiences and some of the things they tried in order to resolve the problem, go take a look.

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

2 Sep 2007, 7:05 PM
#7
effect avatar

effect

New Zenner

Join Date:
Aug 2007
Posts:
15
Plugin Contributions:
0

Re: * Error encountered while writing /includes/configure.php - GOING MAD!!!!!!!

thanks for the reply however i am really new to this so could you please breakdown what you think i should try to do to fix this.

2 Sep 2007, 7:40 PM
#8
effect avatar

effect

New Zenner

Join Date:
Aug 2007
Posts:
15
Plugin Contributions:
0

Re: * Error encountered while writing /includes/configure.php - GOING MAD!!!!!!!

  • Nick says:
    tell him that
  • Nick says:
    you checked the permissions
  • Nick says:
    and the disk space is fine
  • Nick says:
    and see what he says
  • Nick says:
    and btw
  • Nick says:
    the files do appear to be writing correctly

strate from my hosts mouth

2 Sep 2007, 9:19 PM
#9
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: * Error encountered while writing /includes/configure.php - GOING MAD!!!!!!!

First, you have a warning in the installer about PHP magic_quotes_runtime.

I'd start by turning those off, according to the instructions in the help text under "Click here for more info"

Next, post the /includes/configure.php file contents that it's built for you so far.

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

2 Sep 2007, 9:26 PM
#10
effect avatar

effect

New Zenner

Join Date:
Aug 2007
Posts:
15
Plugin Contributions:
0

Re: * Error encountered while writing /includes/configure.php - GOING MAD!!!!!!!

<?php // /** * * @package Configuration Settings * @copyright Copyright 2003-2006 Zen Cart Development Team * @copyright Portions Copyright 2003 osCommerce * @license <http://www.zen-cart.com/license/2_0.txt> GNU Public License V2.0 */ /*************** NOTE: This file is similar, but DIFFERENT from the "store" version of configure.php. ***********/ /*************** The 2 files should be kept separate and not used to overwrite each other. ***********/ // Define the webserver and path parameters // Main webserver: eg, <http://localhost> - should not be empty for productive servers // HTTP_SERVER is your Main webserver: eg, <http://www.yourdomain.com> // HTTPS_SERVER is your Secure webserver: eg, <https://www.yourdomain.com> // HTTP_CATALOG_SERVER is your Main webserver: eg, <http://www.yourdomain.com> // HTTPS_CATALOG_SERVER is your Secure webserver: eg, <https://www.yourdomain.com> /* * URLs for your site will be built via: * HTTP_SERVER plus DIR_WS_ADMIN or * HTTPS_SERVER plus DIR_WS_HTTPS_ADMIN or * HTTP_SERVER plus DIR_WS_CATALOG or * HTTPS_SERVER plus DIR_WS_HTTPS_CATALOG * ...depending on your system configuration settings */ define('HTTP_SERVER', 'http://sellmysound.com'); define('HTTPS_SERVER', 'https://sellmysound.com'); define('HTTP_CATALOG_SERVER', 'http://sellmysound.com'); define('HTTPS_CATALOG_SERVER', 'https://sellmysound.com'); // Use secure webserver for catalog module and/or admin areas? define('ENABLE_SSL_CATALOG', 'false'); define('ENABLE_SSL_ADMIN', 'false'); // NOTE: be sure to leave the trailing '/' at the end of these lines if you make changes! // * DIR_WS_* = Webserver directories (virtual/URL) // these paths are relative to top of your webspace ... (ie: under the public_html or httpdocs folder) define('DIR_WS_ADMIN', '/store/admin/'); define('DIR_WS_CATALOG', '/store/'); define('DIR_WS_HTTPS_ADMIN', '/store/admin/'); define('DIR_WS_HTTPS_CATALOG', '/store/'); define('DIR_WS_IMAGES', 'images/'); define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/'); define('DIR_WS_CATALOG_IMAGES', HTTP_CATALOG_SERVER . DIR_WS_CATALOG . 'images/'); define('DIR_WS_CATALOG_TEMPLATE', HTTP_CATALOG_SERVER . DIR_WS_CATALOG . 'includes/templates/'); define('DIR_WS_INCLUDES', 'includes/'); define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/'); define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/'); define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/'); define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/'); define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/'); define('DIR_WS_CATALOG_LANGUAGES', HTTP_CATALOG_SERVER . DIR_WS_CATALOG . 'includes/languages/'); // * DIR_FS_* = Filesystem directories (local/physical) //the following path is a COMPLETE path to your Zen Cart files. eg: /var/www/vhost/accountname/public_html/store/ define('DIR_FS_ADMIN', '/home/imk/public_html/store/admin/'); define('DIR_FS_CATALOG', '/home/imk/public_html/store/'); define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/'); define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/'); define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/'); define('DIR_FS_CATALOG_TEMPLATES', DIR_FS_CATALOG . 'includes/templates/'); define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/'); define('DIR_FS_EMAIL_TEMPLATES', DIR_FS_CATALOG . 'email/'); define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/'); // define our database connection define('DB_TYPE', 'mysql'); define('DB_PREFIX', ''); define('DB_SERVER', 'localhost'); define('DB_SERVER_USERNAME', '+++++t'); define('DB_SERVER_PASSWORD', '+++++'); define('DB_DATABASE', 'imk_zencart'); define('USE_PCONNECT', 'false'); // use persistent connections? define('STORE_SESSIONS', ''); // use 'db' for best support, or '' for file-based storage // The next 2 "defines" are for SQL cache support. // For SQL_CACHE_METHOD, you can select from: none, database, or file // If you choose "file", then you need to set the DIR_FS_SQL_CACHE to a directory where your apache // or webserver user has write privileges (chmod 666 or 777). We recommend using the "cache" folder inside the Zen Cart folder // ie: /path/to/your/webspace/public_html/zen/cache -- leave no trailing slash define('SQL_CACHE_METHOD', 'none'); define('DIR_FS_SQL_CACHE', '/home/imk/public_html/store/cache'); ?>
2 Sep 2007, 9:30 PM
#11
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: * Error encountered while writing /includes/configure.php - GOING MAD!!!!!!!

Well you're a step closer. Last time I looked it wasn't finding your database tables properly. Now it's demonstrating that while the tables exist, they are empty.

What have you done differently?

Oh, and magic-quotes is still on ... you'll want that turned off.

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

3 Sep 2007, 9:53 AM
#12
effect avatar

effect

New Zenner

Join Date:
Aug 2007
Posts:
15
Plugin Contributions:
0

Re: * Error encountered while writing /includes/configure.php - GOING MAD!!!!!!!

i havnt done anything different lol just reinstalled still the same problem tho man........how do i turn of magic quotes?