Zen Cart Logo
Forums / Templates, Stylesheets, Page Layout / Fresh install, very messed up layout.

Fresh install, very messed up layout.

Locked

Views: 2,349

Results 1 to 4 of 4
This thread is locked. New replies are disabled.
22 Sep 2007, 6:40 AM
#1
veazer avatar

veazer

New Zenner

Join Date:
Apr 2005
Posts:
51
Plugin Contributions:
0

Fresh install, very messed up layout.

Sorry, I didn't know what I would search for to solve this...

Fresh install for a friend on a host I've never used. The only warning during the install was:

PHP open_basedir restrictions = /tmp:/usr/share/pear:/home/fhlinux166/k/k-conversions.co.uk/user

Any idea what would mangle the layout like this? I've never had this occur. It's as if there's no css file being used, if not more.

http://www.k-conversions.co.uk/index.php

22 Sep 2007, 8:34 AM
#2
usernamenone avatar

usernamenone

Totally Zenned

Join Date:
Sep 2006
Posts:
541
Plugin Contributions:
0

Re: Fresh install, very messed up layout.

You are missing your style sheets or they are messed up:
This is the errors.
http://www.k-conversions.co.uk/includes/templates/classic/css/stylesheet.css

<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN"> <HTML><HEAD> <TITLE>500 Internal Server Error</TITLE> </HEAD><BODY> <H1>Internal Server Error</H1> The server encountered an internal error or misconfiguration and was unable to complete your request.<P> Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.<P> More information about this error may be available in the server error log.<P> </BODY></HTML>

http://www.k-conversions.co.uk/includes/templates/classic/css/stylesheet_css_buttons.css

<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN"> <HTML><HEAD> <TITLE>500 Internal Server Error</TITLE> </HEAD><BODY> <H1>Internal Server Error</H1> The server encountered an internal error or misconfiguration and was unable to complete your request.<P> Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.<P> More information about this error may be available in the server error log.<P> </BODY></HTML>

http://www.k-conversions.co.uk/includes/templates/classic/css/print_stylesheet.css

<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN"> <HTML><HEAD> <TITLE>500 Internal Server Error</TITLE> </HEAD><BODY> <H1>Internal Server Error</H1> The server encountered an internal error or misconfiguration and was unable to complete your request.<P> Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.<P> More information about this error may be available in the server error log.<P> </BODY></HTML>
22 Sep 2007, 12:47 PM
#4
veazer avatar

veazer

New Zenner

Join Date:
Apr 2005
Posts:
51
Plugin Contributions:
0

Re: Fresh install, very messed up layout.

DrByte:

FAQ: https://www.zen-cart.com/tutorials/index.php?article=235

That was exactly the problem. I should have found that answer, sorry.

Problem is temporarily solved by disabling .htaccess in related folders. However, ince the .htaccess is there for security purposes, is there something more relaxed that will allow ZC to run properly without disabling .htaccess entirely?

Seems like others at this host are having the same issues:
http://www.zen-cart.com/forum/showthread.php?t=70092&highlight=.htaccess

Current .htaccess is:
<Files *.php>
Order Deny,Allow
Deny from all
</Files>