Zen Cart Logo
Forums / General Questions / index.php redirects to zc_install/index.php

index.php redirects to zc_install/index.php

Locked

Views: 11,368

Results 1 to 20 of 25
This thread is locked. New replies are disabled.
1 Oct 2007, 1:11 AM
#1
wmorris avatar

wmorris

Totally Zenned

Join Date:
Aug 2007
Location:
Amarillo, Tx
Posts:
1,683
Plugin Contributions:
0

index.php redirects to zc_install/index.php

Can someone tell me why my index.php re-directs to zc_install after I move move zen-cart from http://www.mysite.com to http://www.mysite.com/zen-cart please help........

1 Oct 2007, 1:31 AM
#2
wmorris avatar

wmorris

Totally Zenned

Join Date:
Aug 2007
Location:
Amarillo, Tx
Posts:
1,683
Plugin Contributions:
0

Re: index.php redirects to zc_install/index.php

and everything was working fine and now in admin I get this error:

Warning: main(/home/content/m/o/r/morristech/html/includes/autoload_func.php): failed to open stream: No such file or directory in /home/content/m/o/r/morristech/html/gift_shop/admin/includes/application_top.php on line 149

Warning: main(/home/content/m/o/r/morristech/html/includes/autoload_func.php): failed to open stream: No such file or directory in /home/content/m/o/r/morristech/html/gift_shop/admin/includes/application_top.php on line 149

Fatal error: main(): Failed opening required '/home/content/m/o/r/morristech/html/includes/autoload_func.php' (include_path='.:/usr/local/lib/php') in /home/content/m/o/r/morristech/html/gift_shop/admin/includes/application_top.php on line 149

1 Oct 2007, 1:32 AM
#3
merlinpa1969 avatar

merlinpa1969

Totally Zenned

Join Date:
Mar 2004
Posts:
13,031
Plugin Contributions:
4

Re: index.php redirects to zc_install/index.php

you need to go into your configure.php files and add the /zencart/ to the server paths
and urls

1 Oct 2007, 1:36 AM
#4
wmorris avatar

wmorris

Totally Zenned

Join Date:
Aug 2007
Location:
Amarillo, Tx
Posts:
1,683
Plugin Contributions:
0

Re: index.php redirects to zc_install/index.php

well actually my zencart is at http://www.mtechama.com/gift_shop/index.php

1 Oct 2007, 1:38 AM
#5
merlinpa1969 avatar

merlinpa1969

Totally Zenned

Join Date:
Mar 2004
Posts:
13,031
Plugin Contributions:
4

Re: index.php redirects to zc_install/index.php

please paste your includes/configure.php file here ( MINUE DB NAMES AND PASSWORDS )

1 Oct 2007, 1:39 AM
#6
merlinpa1969 avatar

merlinpa1969

Totally Zenned

Join Date:
Mar 2004
Posts:
13,031
Plugin Contributions:
4

Re: index.php redirects to zc_install/index.php

you need to find there lines

/home/content/m/o/r/morristech/html/

and make them

/home/content/m/o/r/morristech/html/gift_shop/

your files are looking for files and folders that dont exist

1 Oct 2007, 1:40 AM
#7
wmorris avatar

wmorris

Totally Zenned

Join Date:
Aug 2007
Location:
Amarillo, Tx
Posts:
1,683
Plugin Contributions:
0

Re: index.php redirects to zc_install/index.php

<?php
/**
 *
 * @package Configuration Settings
 * @copyright Copyright 2003-2006 Zen Cart Development Team
 * @copyright Portions Copyright 2003 osCommerce
 * @license http://www.zen-cart.com/license/2_0.txt GNU Public License V2.0
 */


/*************** NOTE: This file is similar, but DIFFERENT from the "admin" version of configure.php. ***********/
/***************       The 2 files should be kept separate and not used to overwrite each other.      ***********/

// Define the webserver and path parameters
  // HTTP_SERVER is your Main webserver: eg, http://www.yourdomain.com
  // HTTPS_SERVER is your Secure webserver: eg, https://www.yourdomain.com
  define('HTTP_SERVER', 'http://www.mtechama.com/gift_shop');
  define('HTTPS_SERVER', 'https://www.mtechama.com/gift_shop');

  // Use secure webserver for checkout procedure?
  define('ENABLE_SSL', 'false');

// NOTE: be sure to leave the trailing '/' at the end of these lines if you make changes!
// * DIR_WS_* = Webserver directories (virtual/URL)
  // these paths are relative to top of your webspace ... (ie: under the public_html or httpdocs folder)
  define('DIR_WS_CATALOG', '/');
  define('DIR_WS_HTTPS_CATALOG', '/');

  define('DIR_WS_IMAGES', 'images/');
  define('DIR_WS_INCLUDES', 'includes/');
  define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
  define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
  define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
  define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');
  define('DIR_WS_DOWNLOAD_PUBLIC', DIR_WS_CATALOG . 'pub/');
  define('DIR_WS_TEMPLATES', DIR_WS_INCLUDES . 'templates/');

  define('DIR_WS_PHPBB', '/');

// * DIR_FS_* = Filesystem directories (local/physical)
  //the following path is a COMPLETE path to your Zen Cart files. eg: /var/www/vhost/accountname/public_html/store/
  define('DIR_FS_CATALOG', '/home/content/m/o/r/morristech/html/');

  define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');
  define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');
  define('DIR_WS_UPLOADS', DIR_WS_IMAGES . 'uploads/');
  define('DIR_FS_UPLOADS', DIR_FS_CATALOG . DIR_WS_UPLOADS);
  define('DIR_FS_EMAIL_TEMPLATES', DIR_FS_CATALOG . 'email/');
1 Oct 2007, 2:16 AM
#8
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: index.php redirects to zc_install/index.php

These:

  define('HTTP_SERVER', 'http://www.mtechama.com/gift_shop');
  define('HTTPS_SERVER', 'https://www.mtechama.com/gift_shop');

Should read:

  define('HTTP_SERVER', 'http://www.mtechama.com');
  define('HTTPS_SERVER', 'https://www.mtechama.com');

These:

  define('DIR_WS_CATALOG', '/');
  define('DIR_WS_HTTPS_CATALOG', '/');

Should read:

  define('DIR_WS_CATALOG', '/gift_shop/');
  define('DIR_WS_HTTPS_CATALOG', '/gift_shop/');

This:

 define('DIR_FS_CATALOG', '/home/content/m/o/r/morristech/html/');

Should probably read:

 define('DIR_FS_CATALOG', '/home/content/m/o/r/morristech/html/gift_shop/');
1 Oct 2007, 2:17 AM
#9
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: index.php redirects to zc_install/index.php

NOTE: you should also check your admin configure.php file as well at:
/admin/includes/configure.php

1 Oct 2007, 2:22 AM
#10
wmorris avatar

wmorris

Totally Zenned

Join Date:
Aug 2007
Location:
Amarillo, Tx
Posts:
1,683
Plugin Contributions:
0

Re: index.php redirects to zc_install/index.php

I have done that but its still doesn't work

1 Oct 2007, 3:11 AM
#11
merlinpa1969 avatar

merlinpa1969

Totally Zenned

Join Date:
Mar 2004
Posts:
13,031
Plugin Contributions:
4

Re: index.php redirects to zc_install/index.php

If you did all this and it still didnt work there are 2 possibilities,

1 clear your cache
2 make sure that the changes you are making to th econfig files are actually taking,

You may have to chmod them to 777 or 755 to make the changes then chmod it back to 644 or 444

1 Oct 2007, 3:27 AM
#12
wmorris avatar

wmorris

Totally Zenned

Join Date:
Aug 2007
Location:
Amarillo, Tx
Posts:
1,683
Plugin Contributions:
0

Re: index.php redirects to zc_install/index.php

ok I got the index page working but I am still getting errors on admin

Warning: main(/home/content/m/o/r/morristech/html/includes/autoload_func.php): failed to open stream: No such file or directory in /home/content/m/o/r/morristech/html/gift_shop/admin/includes/application_top.php on line 149

Warning: main(/home/content/m/o/r/morristech/html/includes/autoload_func.php): failed to open stream: No such file or directory in /home/content/m/o/r/morristech/html/gift_shop/admin/includes/application_top.php on line 149

Fatal error: main(): Failed opening required '/home/content/m/o/r/morristech/html/includes/autoload_func.php' (include_path='.:/usr/local/lib/php') in /home/content/m/o/r/morristech/html/gift_shop/admin/includes/application_top.php on line 149

1 Oct 2007, 3:32 AM
#13
merlinpa1969 avatar

merlinpa1969

Totally Zenned

Join Date:
Mar 2004
Posts:
13,031
Plugin Contributions:
4

Re: index.php redirects to zc_install/index.php

you need to make the same changes to admin/includes/configure.php

1 Oct 2007, 3:42 AM
#14
Kim avatar

Kim

Obaa-san

Join Date:
Jun 2003
Location:
West Coast, North America
Posts:
26,643
Plugin Contributions:
0

Re: index.php redirects to zc_install/index.php

NOTE: That Admin configure is different than the catalog config file.

9 Oct 2007, 12:17 PM
#15
bakerman avatar

bakerman

New Zenner

Join Date:
Sep 2007
Posts:
15
Plugin Contributions:
0

Re: index.php redirects to zc_install/index.php

Just to throw my two pennies in... I had the same problem on my local copy and it was hurting my head for two weeks.

That a look at your MySQL database again and check that it has been setup/imported properly.

Sorting that out and editing the configure.php files (both) is what fixed the problem.

11 Oct 2007, 9:15 PM
#16
dragonspearls avatar

dragonspearls

New Zenner

Join Date:
Oct 2007
Posts:
5
Plugin Contributions:
0

Re: index.php redirects to zc_install/index.php

I'm now having this same problem, sort of. I was having the zc_install directory issue, but after reading this thread, I changed all the paths to point to the directory where ZC is (https://www.dpnaturals.com/shop/). That fixed the initial problem.

Now I'm getting the nddbc.html page which says there's a problem connecting to the database.

I also just checked the error log and found this: PHP Fatal error: Class 'notifier' not found in /includes/autoload_func.php on line 79 I looked at autoload_func.php, but I don't see anything concerning the path.

I am totally frustrated at this point. :cry: I've been working on the cart all day, and had reached the point of just needing to do the ssl when this happened. Actually, there's still a few things to be done, but this is the 'major' point of being able to say I'm open for business.

Any help would be greatly appreciated.

12 Oct 2007, 2:25 AM
#17
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: index.php redirects to zc_install/index.php

Check through your file:
/includes/configure.php

And make sure all paths and database information is correct and there are no typos ...

NOTE: all data is case sensative ...

Currently, it appears that the database information is the problem in your file:
/includes/configure.php

such as the database name or server or username or password ...

12 Oct 2007, 3:37 AM
#18
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: index.php redirects to zc_install/index.php

Dragonspearls:

I've been working on the cart all day, and had reached the point of just needing to do the ssl when this happened.When you attempted to "do the ssl", what exactly did you do?
If it was working fine before you tried to do that, backtrack your steps and undo things until it works again.
Hopefully you make backups periodically as you go along so you can undo things easily ...

12 Oct 2007, 12:13 PM
#19
dragonspearls avatar

dragonspearls

New Zenner

Join Date:
Oct 2007
Posts:
5
Plugin Contributions:
0

Re: index.php redirects to zc_install/index.php

When you attempted to "do the ssl", what exactly did you do?
If it was working fine before you tried to do that, backtrack your steps and undo things until it works again.

First thing I did was make a copy of the configure files so that the originals would remain unchanged. Dropped them into a separate folder like I did with the templates so I could find them easily. This is on my pc, and not online.

Second thing was to change the https server info, and set SSL to true. And that was all I did.

Uploaded the changed copies to the proper directories after changing file permission so I could do it. That's when the zc_install problem started.

Realized that I had totally forgotten about the path thing (changing /cart to /shop) ... my bad. Went and changed the paths, rinse and repeat the uploading.

Problem changed from zc_install to the can't connect to database and the autoload_func.php error.

I have tried re-uploading the original config files since everything was working before those changes/problems. This results in the zc_install problem.

Hopefully you make backups periodically as you go along so you can undo things easily ...

I learned that one early on, with osC several years ago (my first, and only, previous experience with a cart and database). I just made a backup yesterday ... before the problems started, but it was data only.

I can still access the database. It's the cart and admin area I can't get to.

Speaking of the admin area, I get this error message when I go to the log in page: 0 DB_ERROR_NOT_CONNECTED in: [db_cache table]

Do I need to delete info in the database cache table?

12 Oct 2007, 6:08 PM
#20
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: index.php redirects to zc_install/index.php

You'll be redirected to zc_install if the configure.php file contains default settings for certain definitions, or if the files for the database engine specified cannot be loaded, or if the file is missing/unreadable/unreachable.

The database-not-connected error means that the database information mentioned in your configure.php file doesn't match the authentication details required to access your database. The problem could be the host name, username, password, database-name, and/or prefix name. They all have to be correct.