Forums / Installing on a Linux/Unix Server / problem caused by switching server

problem caused by switching server

Locked

Views: 2,753

Results 1 to 11 of 11
This thread is locked. New replies are disabled.
3 Oct 2007, 11:05 AM
#1
teazetoys avatar

teazetoys

New Zenner

Join Date:
Jul 2007
Posts:
30
Plugin Contributions:
0

problem caused by switching server

i have recently changed server and since doing this have been unable to view either my admin or my store can someone please help as my server provider just tells me they don't deal with scripting errors but they caused the error
this is the code i get on my store

The page cannot be found
The page you are looking for might have been removed, had its name changed, or is temporarily unavailable.

Please try the following:

Make sure that the Web site address displayed in the address bar of your browser is spelled and formatted correctly.
If you reached this page by clicking a link, contact the Web site administrator to alert them that the link is incorrectly formatted.
Click the Back button to try another link.
HTTP Error 404 - File or directory not found.
Internet Information Services (IIS)


Technical Information (for support personnel)

Go to Microsoft Product Support Services and perform a title search for the words HTTP and 404.
Open IIS Help, which is accessible in IIS Manager (inetmgr), and search for topics titled Web Site Setup, Common Administrative Tasks, and About Custom Error Messages.

this is what i get on my admin

Warning: main(/home/fhlinux166/t/teazetoys.co.uk/user/htdocs/includes/autoload_func.php) [function.main]: failed to open stream: No such file or directory in e:\domains\t\teazetoys.co.uk\user\htdocs\admin\includes\application_top.php on line 149

Fatal error: main() [function.require]: Failed opening required '/home/fhlinux166/t/teazetoys.co.uk/user/htdocs/includes/autoload_func.php' (include_path='.;c:\php4\pear') in e:\domains\t\teazetoys.co.uk\user\htdocs\admin\includes\application_top.php on line 149

please help as i am new to this and had done a lot of work and dont know where it has all gone or what any of this means:(

3 Oct 2007, 12:57 PM
#2
teazetoys avatar

teazetoys

New Zenner

Join Date:
Jul 2007
Posts:
30
Plugin Contributions:
0

Re: problem caused by switching server

on monday i switched my shop from a linux to a windows server within the same hosting company. now when i go to my admin or shop i am just getting error pages and dont know what they mean. i have to spoken to my hosting company who keep telling me they do not deal with scripting errors and to search google, even thow everything was fine befor they did the switch for me.
i need help i dont know what i even need to search google for?????
please help i have put a lot of work into my store in the last couple of weeks and dont know what is wrong..

the errors say on my admin ....Warning: main(/home/fhlinux166/t/teazetoys.co.uk/user/htdocs/includes/autoload_func.php) [function.main]: failed to open stream: No such file or directory in e:\domains\t\teazetoys.co.uk\user\htdocs\admin\includes\application_top.php on line 149

Fatal error: main() [function.require]: Failed opening required '/home/fhlinux166/t/teazetoys.co.uk/user/htdocs/includes/autoload_func.php' (include_path='.;c:\php4\pear') in e:\domains\t\teazetoys.co.uk\user\htdocs\admin\includes\application_top.php on line 149
and when i go to my store it says........The page cannot be found
The page you are looking for might have been removed, had its name changed, or is temporarily unavailable.

Please try the following:

Make sure that the Web site address displayed in the address bar of your browser is spelled and formatted correctly.
If you reached this page by clicking a link, contact the Web site administrator to alert them that the link is incorrectly formatted.
Click the Back button to try another link.
HTTP Error 404 - File or directory not found.
Internet Information Services (IIS)


Technical Information (for support personnel)

Go to Microsoft Product Support Services and perform a title search for the words HTTP and 404.
Open IIS Help, which is accessible in IIS Manager (inetmgr), and search for topics titled Web Site Setup, Common Administrative Tasks, and About Custom Error Messages.

3 Oct 2007, 1:06 PM
#3
merlinpa1969 avatar

merlinpa1969

Totally Zenned

Join Date:
Mar 2004
Posts:
13,031
Plugin Contributions:
4

Re: problem caused by switching server

the best thing that you can do is to upoad the zc_install folder again,
then run the www.domain/zc_install/index.php and when you get to the 3 rd screen
the one that tells you if your folders are writable, at the bottom choose update config

this will then ONLY update your config files, your server paths are way off

Zen cart PCI compliant Hosting

3 Oct 2007, 1:11 PM
#4
teazetoys avatar

teazetoys

New Zenner

Join Date:
Jul 2007
Posts:
30
Plugin Contributions:
0

Re: problem caused by switching server

what does that mean could this be bad and what has gone wrong is it the fault of my hosting company???

3 Oct 2007, 1:39 PM
#5
merlinpa1969 avatar

merlinpa1969

Totally Zenned

Join Date:
Mar 2004
Posts:
13,031
Plugin Contributions:
4

Re: problem caused by switching server

No what it means is that when the files were moved you didnt open the includes/configure.php and the admin/includes/configure.php and rewrite the server paths,

you will see 2 places inthe includes/configure.php and 3 places in the admin/includes/configure.php
that look like this

/home/fhlinux166/t/teazetoys.co.uk/user/htdocs/

and they should look like this

e:\domains\t\teazetoys.co.uk\user\htdocs\

now you can either manually change them or you let the software fix them by running th econfig updater inthe install

eitherway will get the same result

Zen cart PCI compliant Hosting

3 Oct 2007, 1:41 PM
#6
teazetoys avatar

teazetoys

New Zenner

Join Date:
Jul 2007
Posts:
30
Plugin Contributions:
0

Re: problem caused by switching server

ok thanks and will it automatically detect the correct settings for me or should i speak to my host about this as i have gotten to the page where it says redetect settings but it isnt coming up with anything in my https part

3 Oct 2007, 1:44 PM
#7
merlinpa1969 avatar

merlinpa1969

Totally Zenned

Join Date:
Mar 2004
Posts:
13,031
Plugin Contributions:
4

Re: problem caused by switching server

if you want to PM me with your 2 config files and I will fix em and send em back, you can then just upload em to the server

Zen cart PCI compliant Hosting

3 Oct 2007, 2:04 PM
#8
teazetoys avatar

teazetoys

New Zenner

Join Date:
Jul 2007
Posts:
30
Plugin Contributions:
0

Re: problem caused by switching server

ok i cant work out how to pm you it is asking me which database i want to upgrade from it says this ..Database Information -- Upgrade Sniffer predicts: *** No upgrade required ***
Database Type = mysql
Database Host = mysql11.streamline.net
Database Name = teazetoys
Database Username = teazetoys
Database Table-Prefix = teazetoys
Database Privileges = Not Checked

and then there is a list of about 12 database options

3 Oct 2007, 6:42 PM
#9
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: problem caused by switching server

Yikes -- why did you switch to a windows server? eek

The details in your /includes/configure.php file and likely also the /admin/includes/configure.php file are not correct for your new server.

Please post the contents of those files ... without the database password.

FAQs on switching servers
https://www.zen-cart.com/tutorials/index.php?article=99
http://www.zen-cart.com/wiki/index.php/Server_Admin_-_Switch_Servers

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

3 Oct 2007, 7:02 PM
#10
teazetoys avatar

teazetoys

New Zenner

Join Date:
Jul 2007
Posts:
30
Plugin Contributions:
0

Re: problem caused by switching server

well i realise that now, i am going to change back to i linux as this has just piffed me off and i had done so much work i hope this doesnt mess anything up

4 Oct 2007, 7:07 AM
#11
teazetoys avatar

teazetoys

New Zenner

Join Date:
Jul 2007
Posts:
30
Plugin Contributions:
0

Re: problem caused by switching server

oh my god things just got worse they switched me back to linux and all my products have disappeared which took me ages to put on and i got this error message now on my admin area
Parse error: syntax error, unexpected '(' in /home/fhlinux162/t/teazetoys.co.uk/user/htdocs/admin/includes/application_top.php on line 149
dont know what that mean and i am generally very unhappy:(

i dont know how to use my php/my admin as i am sure that everthing should be on there as my hosting company auto updates it on a daily basis hhhheeellllppppp:frusty: