Zen Cart Logo
Forums / Installing on a Linux/Unix Server / After transferring to a new host I get errors

After transferring to a new host I get errors

Locked

Views: 1,536

Results 1 to 5 of 5
This thread is locked. New replies are disabled.
17 Oct 2007, 2:08 PM
#1
brimsjewelry avatar

brimsjewelry

Zen Follower

Join Date:
May 2006
Posts:
188
Plugin Contributions:
0

After transferring to a new host I get errors

I followed the tutorial for moving from one host to another https://www.zen-cart.com/tutorials/index.php?article=100. I got the database imported and all the files uploaded. Admin seems to be working ok. But when I try to go to the home page I get the following:

] . " set user_email='" . $email_address . "' where user_email = '" . $old_email . "'"; $phpbb_users = $this->db_phpbb->Execute($sql); } function phpbb_change_nick($old_nick, $new_nick) { // before utilizing this function, we should do an MD5 password validation first if ($this->phpBB['installed'] != true || !zen_not_null($nick) || $nick == '') return false; $sql = "update " . $this->phpBB['users_table'] . " set username='" . $new_nick . "' where username = '" . $old_nick . "'"; $phpbb_users = $this->db_phpbb->Execute($sql); } } ?>
Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /home/xxxxxxxx/public_html/includes/classes/class.phpbb.php:256) in /home/xxxxxxxx/public_html/includes/functions/sessions.php on line 108

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/xxxxxxxx/public_html/includes/classes/class.phpbb.php:256) in /home/xxxxxxxx/public_html/includes/functions/sessions.php on line 108

Warning: Cannot modify header information - headers already sent by (output started at /home/xxxxxxxx/public_html/includes/classes/class.phpbb.php:256) in /home/xxxxxxxx/public_html/includes/init_includes/init_templates.php on line 78

Warning: main(/home/xxxxxxxx/public_html/includes/m1_cache.class.php) [function.main]: failed to open stream: No such file or directory in /home/xxxxxxxx/public_html/includes/application_top.php on line 284

Fatal error: main() [function.require]: Failed opening required '/home/xxxxxxxx/public_html/includes/m1_cache.class.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/xxxxxxxx/public_html/includes/application_top.php on line 284

17 Oct 2007, 2:33 PM
#2
brimsjewelry avatar

brimsjewelry

Zen Follower

Join Date:
May 2006
Posts:
188
Plugin Contributions:
0

Re: After transferring to a new host I get errors

I managed to get a couple of the errors fixed. Here is what is showing now:

] . " set user_email='" . $email_address . "' where user_email = '" . $old_email . "'"; $phpbb_users = $this->db_phpbb->Execute($sql); } function phpbb_change_nick($old_nick, $new_nick) { // before utilizing this function, we should do an MD5 password validation first if ($this->phpBB['installed'] != true || !zen_not_null($nick) || $nick == '') return false; $sql = "update " . $this->phpBB['users_table'] . " set username='" . $new_nick . "' where username = '" . $old_nick . "'"; $phpbb_users = $this->db_phpbb->Execute($sql); } } ?>
Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/xxxx/public_html/includes/classes/class.phpbb.php:256) in /home/xxxx/public_html/includes/functions/sessions.php on line 108

Warning: Cannot modify header information - headers already sent by (output started at /home/xxxx/public_html/includes/classes/class.phpbb.php:256) in /home/xxxx/public_html/includes/init_includes/init_templates.php on line 78

17 Oct 2007, 6:55 PM
#3
merlinpa1969 avatar

merlinpa1969

Totally Zenned

Join Date:
Mar 2004
Posts:
13,031
Plugin Contributions:
4

Re: After transferring to a new host I get errors

try opening this file
/home/xxxx/public_html/includes/classes/class.phpbb.php and going to the very bottom put cursor directly after the last ?> and hit delete about 10 times save and re-upload

Zen cart PCI compliant Hosting

17 Oct 2007, 7:52 PM
#4
brimsjewelry avatar

brimsjewelry

Zen Follower

Join Date:
May 2006
Posts:
188
Plugin Contributions:
0

Re: After transferring to a new host I get errors

Merlinpa1969:

try opening this file
/home/xxxx/public_html/includes/classes/class.phpbb.php and going to the very bottom put cursor directly after the last ?> and hit delete about 10 times save and re-upload

Ok, I did that but no change. Just looking at the file, it doesnt look exploded or anything. But I did notice this section was not parsed by my php editor beginning on line 249 near the end of the file:

?>] . " set user_email='" . $email_address . "'
where user_email = '" . $old_email . "'";
$phpbb_users = $this->db_phpbb->Execute($sql);
}

function phpbb_change_nick($old_nick, $new_nick) {
// before utilizing this function, we should do an MD5 password validation first
  if ($this->phpBB['installed'] != true || !zen_not_null($nick) || $nick == '') return false;
    $sql = "update " . $this->phpBB['users_table'] . " set username='" . $new_nick . "'
            where username = '" . $old_nick . "'";
    $phpbb_users = $this->db_phpbb->Execute($sql);
}

}
?>

Also, Now I'm getting another related error on the home page which is this:

Warning: Cannot modify header information - headers already sent by (output started at /home/XXXXX/public_html/includes/classes/class.phpbb.php:256) in /home/XXXXX/public_html/includes/init_includes/init_templates.php on line 78

Thanks for your help. It's much appreciated.

Jason

17 Oct 2007, 8:05 PM
#5
brimsjewelry avatar

brimsjewelry

Zen Follower

Join Date:
May 2006
Posts:
188
Plugin Contributions:
0

Re: After transferring to a new host I get errors

FIXED IT! I just copied the old file again from the old installation to the new one. That last part of code had gotten corrupted in the ftp. Everything looks great now!

Thanks!

Jason