Forums / General Questions / Transferred Store to new host and received this error

Transferred Store to new host and received this error

Locked

Views: 951

Results 1 to 5 of 5
This thread is locked. New replies are disabled.
20 Nov 2007, 9:19 PM
#1
raichumaximus avatar

raichumaximus

New Zenner

Join Date:
Oct 2007
Posts:
18
Plugin Contributions:
0

Transferred Store to new host and received this error

Hi,

I recently transferred my entire store to a new host and everything is working fine except when sometimes I select my categories I receive a warning message and a blank page. Also for some strange reason, when I remove the item from the non working category, the link works. Here is the message I receive when it is not working :

Warning: Cannot modify header information - headers already sent by (output started at /home/myusername/public_html/Store/includes/languages/english/index.php:107) in /home/myusername/public_html/Store/includes/functions/functions_general.php on line 44

Any help would be great, thanks :)

20 Nov 2007, 10:47 PM
#2
merlinpa1969 avatar

merlinpa1969

Totally Zenned

Join Date:
Mar 2004
Posts:
13,031
Plugin Contributions:
4

Re: Transferred Store to new host and received this error

openthis page

/home/myusername/public_html/Store/includes/languages/english/index.php

put cursor at very bottom of page right behind the ?> hit delete 5 times save and re-upload

Zen cart PCI compliant Hosting

20 Nov 2007, 11:43 PM
#3
raichumaximus avatar

raichumaximus

New Zenner

Join Date:
Oct 2007
Posts:
18
Plugin Contributions:
0

Re: Transferred Store to new host and received this error

Hi,

Thanks for the response. Just wondering, would this be the same as running the Fix Cache Key where the index.php is, when I ran the fix cache key I placed it in the Store directory and not in the directory where the index.php was. Also when you meant re-upload, did you mean re-upload the whole store? Thanks :)

21 Nov 2007, 12:38 AM
#4
merlinpa1969 avatar

merlinpa1969

Totally Zenned

Join Date:
Mar 2004
Posts:
13,031
Plugin Contributions:
4

Re: Transferred Store to new host and received this error

no this is not the same,
fix cache key make an index key change inth edatabase,

this eliminates the white space at the end of the file thats causing the error

Zen cart PCI compliant Hosting

21 Nov 2007, 1:19 AM
#5
raichumaximus avatar

raichumaximus

New Zenner

Join Date:
Oct 2007
Posts:
18
Plugin Contributions:
0

Re: Transferred Store to new host and received this error

I replaced the index.php with an older one (luckily for back-ups), and now it seems to be working fine :)