Zen Cart Logo
Forums / General Questions / Teimout with additional_images

Teimout with additional_images

Locked

Views: 964

Results 1 to 4 of 4
This thread is locked. New replies are disabled.
29 Nov 2007, 11:40 PM
#1
needainstall avatar

needainstall

New Zenner

Join Date:
Nov 2007
Posts:
34
Plugin Contributions:
0

Teimout with additional_images

Having a problem on my local test server with errors generated by additional_images.php

The exact error is
Fatal error: Maximum execution time of 60 seconds exceeded in (path to where my test server is)\includes\modules\additional_images.php on line 45

I'm not even sure what function this if performs, so for the time being I simply commented out lines 45-59 and all is fine. I'm just not sure what functionality I'm loosing, if any.

1 Dec 2007, 6:45 PM
#2
needainstall avatar

needainstall

New Zenner

Join Date:
Nov 2007
Posts:
34
Plugin Contributions:
0

Re: Teimout with additional_images

anyone know what functions these lines perform and if they are pertinent to the proper operation of the store??

1 Dec 2007, 7:40 PM
#3
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Teimout with additional_images

Given the other problems you've reported with your local server, it sounds like you've got several issues that all have a common root: something weird on your server's configuration or functionality.

Anyway, back to your question ...
line 45 of the additional_images module in v1.3.7 is processing the results of image files from a directory listing on your server. I suppose that if you have a zillion images it may take awhile to process them, esp if the server has limited CPU, RAM, disk capacity and maybe has a lot of disk fragmentation. But normally that process should be very quick.

If you don't need additional_image support, turn it off in Admin->Catalog->Product Types->Product General->Edit Layout-> Show Additional Images = 0

More importantly, fix your server issues before beating your head against the wall on all the various symptoms you're experiencing.

3 Dec 2007, 6:44 AM
#4
needainstall avatar

needainstall

New Zenner

Join Date:
Nov 2007
Posts:
34
Plugin Contributions:
0

Re: Teimout with additional_images

You are so correct! I have narrowed the problem down to the WAMP - XAMPP - that I am using.

The system config on the test server is otherwise decently strong, a P4 3Ghz w/2GB.

I've also discovered other problems with xampp (or at least the build I have), like some sort of memory leakage that slowly eats away at my system memory until all fails - about every 6 hours or so.

Anyway, I've got the exact same setup running on a linux server without any of the other problems that I've reported on the forums here with my test server - with the exception of the captchable error - it's on the linux as well.

I'm going back on the hunt tomorrow for a decent WAMP and will move everything over to the new config probably by the end of the day.

Thank you for your help.