Zen Cart Logo
Forums / Upgrading from 1.3.x to 1.3.9 / Blank screen on database-upgrade step

Blank screen on database-upgrade step

Locked

Views: 3,492

Results 1 to 8 of 8
This thread is locked. New replies are disabled.
10 Dec 2007, 8:02 AM
#1
wittymom avatar

wittymom

New Zenner

Join Date:
Sep 2005
Posts:
51
Plugin Contributions:
0

Blank screen on database-upgrade step

I'm having an issue on two different sites. I click "Upgrade Database" and get a blank screen. I tried the .htaccess fix posted elsewhere but it must not apply to this particular problem.

Both carts are 1.3.7 currently. It's hanging at this URL:

/zc_install/index.php?main_page=database_upgrade

Any ideas would be great. Thanks!

10 Dec 2007, 4:07 PM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Blank screen on database-upgrade step

What's the URL to zc_install for one of the sites?
Are they both on the same server?
Have you tried re-uploading the full zc_install folder, just in case some files got missed?
Do you have access to your server's errorlog? Is there an error being reported there when the blank page happens?
In your /cache folder will be a zcInstall log file. Can you post its contents here?

10 Dec 2007, 6:57 PM
#3
wittymom avatar

wittymom

New Zenner

Join Date:
Sep 2005
Posts:
51
Plugin Contributions:
0

Re: Blank screen on database-upgrade step

I am working with two different carts/hosts. This particular one is BlueHost, here's the log file:

URL:
http://www.oneofakindbylexi.com/shop/

LOG FILE:

---------------
Dec 10 2007 9:37 -- inspect
System Inspection Results: 
------------------------------
NA: Webserver => Apache/1.3.39 (Unix) mod_fastcgi/2.4.2 mod_auth_passthrough/1.8 mod_log_bytes/1.2 mod_bwlimited/1.4 FrontPage/5.0.2.2635.SR1.2 mod_ssl/2.8.30 OpenSSL/0.9.7a PHP-CGI/0.1b
NA: HTTP Host => www.oneofakindbylexi.com
NA: Path_Translated => /home/*****/public_html/shop/zc_install/index.php(SCRIPT_FILENAME)
NA: Real Path => /home/*****/public_html/shop
NA: Server Free Disk Space => 99.59 GB
NA: PHP O/S => Linux
WARN: PHP API Mode => cgi-fcgi
NA: PHP Max Execution Time per page => 30
OK: Register Globals => OFF
OK: MySQL Support => ON
OK: MySQL Version => 4.1.22-standard-log
OK: PHP Version => 4.4.7
OK: PHP Safe Mode => OFF
OK: PHP Sessions Support => ON
OK: PHP Session.AutoStart => OFF
OK: PHP session.use_trans_sid => OFF
OK: Current SQL Cache Folder => /home/*****/public_html/shop/cache-->Writeable
OK: Suggested SQL Cache Folder => /home/*****/public_html/shop/cache
OK: PHP magic_quotes_runtime setting => OFF
OK: PHP magic_quotes_sybase setting => OFF
OK: PHP GD Support => ON
OK: GD Version => GD bundled (2.0.28 compatible)
OK: PHP ZLIB Compression Support => ON
OK: PHP OpenSSL Support => ON
OK: PHP cURL Support => ON
OK: CURL NON-SSL Capability => Okay
OK: CURL SSL Capability => Okay
OK: PHP Upload Support => ON upload_max_filesize=2M; post_max_size=8M
OK: PHP Upload TMP dir => 
NA: PHP include_path => .:/usr/lib/php:/usr/local/lib/php
NA: PHP SMTP destination => localhost
NA: PHP sendmail path => /usr/sbin/sendmail -t -i
NA: PHP sendmail 'from' => 
OK: PHP open_basedir restrictions => 
WARN: PHP Output Buffering (gzip) => OFF
OK: PHP FTP Support => ON
OK: PHP XML Support => ON
OK: PHP Session.Save_Path => /home/*****/public_html/shop/cache-->Writeable
OK: includes/configure.php => Writeable
OK: admin/includes/configure.php => Writeable
OK: cache => OK 777 read/write/execute
OK: images => OK 777 read/write/execute (INCLUDE SUBDIRECTORIES TOO)
OK: includes/languages/english/html_includes => OK 777 read/write (INCLUDE SUBDIRECTORIES TOO)
OK: media => OK 777 read/write/execute
OK: pub => OK 777 read/write/execute
OK: admin/backups => OK 777 read/write
OK: admin/images/graphs => OK 777 read/write/execute
PHP Extensions compiled: xslt, xml, tokenizer, standard, sockets, session, pspell, posix, pgsql, pdf, overload, mysql, mhash, mcrypt, mbstring, imap, iconv, gettext, gd, ftp, exif, domxml, curl, ctype, calendar, bcmath, zlib, pcre, openssl, Zend Optimizer
------------------------------


---------------
Dec 10 2007 9:38 -- database_setup1
Installer - Page: database_setup -- collected information: Array
(
[language] => english
[DIR_FS_SQL_CACHE] => /home/*****/public_html/shop/cache
[is_upgrade] => 1
[DB_TYPE] => mysql
[DB_PREFIX] => 
[DB_SERVER] => localhost
[DB_SERVER_USERNAME] => **********
[DB_SERVER_PASSWORD] => *****
[DB_DATABASE] => **********
[STORE_SESSIONS] => db
[USE_PCONNECT] => 
[SQL_CACHE_METHOD] => none
)

This line "WARN: PHP API Mode => cgi-fcgi" -- I'm sorry, I don't know what that means. I'm reading about it but don't know how to fix it. Is it something in cPanel?

Thanks!!

** I also turned the GZip ON after this log file. **

10 Dec 2007, 8:06 PM
#4
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Blank screen on database-upgrade step

You likely don't need to worry about the cgi message.

I find most often that the blank-screen phenomenon happens when mistyping the admin username/password when attempting to do the upgrade.

10 Dec 2007, 9:00 PM
#5
wittymom avatar

wittymom

New Zenner

Join Date:
Sep 2005
Posts:
51
Plugin Contributions:
0

Re: Blank screen on database-upgrade step

Everything is correct, I checked it against the original config files and settings are exact. I tried entering an incorrect PW and got an error.

Is there a way to manually run the patch? I'm stuck here.

Thanks for your help, I really appreciate it.

10 Dec 2007, 9:20 PM
#6
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Blank screen on database-upgrade step

wittymom:

Is there a way to manually run the patch?

If you're not using any database table-prefixes, just use phpMyAdmin and run the /zc_install/sql/mysql_upgrade_zencart_137_to_138.sql directly.

I strongly recommend against doing it manually. But, if you're stuck with no other option, do it as described above.

11 Dec 2007, 4:10 PM
#7
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Blank screen on database-upgrade step

wittymom:

Both carts are 1.3.7 currently. It's hanging at this URL:

/zc_install/index.php?main_page=database_upgrade

DrByte:

I find most often that the blank-screen phenomenon happens when mistyping the admin username/password when attempting to do the upgrade.

:eek: I found the bug ...

/zc_install/includes/classes/installer.php
lines 648 and 651 say this:$zc_install->setError(ERROR_TEXT_ADMIN_PWD_REQUIRED, ERROR_CODE_ADMIN_PWD_REQUIRED, true);but it should be this:```
$[B]this[/B]->setError(ERROR_TEXT_ADMIN_PWD_REQUIRED, ERROR_CODE_ADMIN_PWD_REQUIRED, true);


**
NOTE: THIS FIX IS INCLUDED IN v1.3.8a**
12 Sep 2008, 7:13 PM
#8
warstormer avatar

warstormer

Zen Follower

Join Date:
Aug 2007
Posts:
120
Plugin Contributions:
0

Re: Blank screen on database-upgrade step

Trying to get from 1.2.6 to 1.3.8. I just made those changes as I was getting the blank screen, and now the blank screen says:

in:
[select admin_id, admin_name, admin_pass from zen_admin where admin_name = 'admin']

Really, should I just start again?