Zen Cart Logo
Forums / Templates, Stylesheets, Page Layout / MySQL error ... near '000000 where products_id = '50'

MySQL error ... near '000000 where products_id = '50'

Locked

Views: 2,704

Results 1 to 3 of 3
This thread is locked. New replies are disabled.
17 Dec 2007, 11:33 PM
#1
kairen avatar

kairen

New Zenner

Join Date:
Nov 2007
Posts:
18
Plugin Contributions:
0

MySQL error ... near '000000 where products_id = '50'

Hello.

So I finally got around to getting the new tables and updated content to the net at www.ecuras.fi/zencart/ (all page content is in Finnish, but English language button enables english buttons/and english product descriptions). The pages are far from finished yet... I just wanted to run it on the designated server and start working and solving problems from there.

So everything was brightening up as I finally got the chance to update the tables after getting a mate at the firm (the :smartalec: unix-guy, I wish I had the skillz :wacko:) to get me a good User-Friendly environment to run table updates on, namely PHPMyAdmin, which I use at home on the XAMPP anyways.

Problem is: The DB of the shop is in MySQL 5.0.45 on my developing environment with the latest XAMPP, that I'm running at home, and THE DB on the real server is version 5.0.22, although the MySQL Server that the ISP of the firm uses is 4.1.22... or as PHPMyAdmin states:

Your PHP MySQL library version 5.0.22 differs from your MySQL server version 4.1.22. This may cause unpredictable behavior

So I dropped the olden tables with whacked umlauts and wrong character-sets and messy layout. I then took my newer, umlaut-fixed, email-should-be-working, new-layout-settings&yadayada tables from my own PHPMyAdmin and exported them as a *.sql file with compatibility NONE. Then imported them succesfully into the DB on the server. :yes:

Then I went to try it out with my registered customer I used for testing emails at home, went through 3 Steps of Checkup until the confirm button, clicked it, and then I hit the first brick wall :frusty: :

1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '000000 where products_id = '50'' at line 1
in:
[update ecuras_zen_products set products_ordered = products_ordered + 1,000000 where products_id = '50']

So now I sit here and wonder. Any suggestions? Ask ISP if they have a newer MySQL Server coming up or available on different host? Change the whole table to Server version compatible? The thing is the firm has other tables in the DB as well, unrelated to ZenCart. And I don't know anything about those programs, and if those need the newer SQL DB. Anyone else had to solve a similar issue?

Anyways... I need some help with this

-NoobZenner

18 Dec 2007, 1:00 AM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: MySQL error ... near '000000 where products_id = '50'

You'll need to configure your finnish language files to use the correct locale settings. See this FAQ:
https://www.zen-cart.com/tutorials/index.php?article=27

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

18 Dec 2007, 10:22 AM
#3
kairen avatar

kairen

New Zenner

Join Date:
Nov 2007
Posts:
18
Plugin Contributions:
0

Re: MySQL error ... near '000000 where products_id = '50'

Thanks a lot :clap:

Good that I didn't continue thinking about it but went to bed. Well now it has no SQl Syntax error, BUT it tells me with an SMTP Error, that the e-mail given isn't a right address.

I changed my settings to not check addresses with DNS, and set E-Mail friendly errors to true. So know it worked and i made my first online order :bigups:

Thank you DrByte

(now back to simpler stuff, like content optimization)