Zen Cart Logo
Forums / Upgrading from 1.3.x to 1.3.9 / Upgrade error 1.3.7->1.3.8a

Upgrade error 1.3.7->1.3.8a

Locked

Views: 11,631

Results 21 to 36 of 36
This thread is locked. New replies are disabled.
11 Jan 2008, 8:34 AM
#21
quentinjs avatar

quentinjs

Zen Follower

Join Date:
Mar 2004
Location:
Calgary, Alberta
Posts:
289
Plugin Contributions:
0

Upgrade error 1.3.7->1.3.8a

So my other problem is CURL.... I'd have thought this would be a no brainer, just turn on the extension and away it goes. I spent a few hours on it, I looked at the CURL site, ect, and nothing seemed to help. I thought I'd take a stab at getting thhe system up without it and its worked, but now I need to know what I need to do to get it working as well.

Environment:
Windows - IIS
PHP 5
MySQL 5

The windows php doesn't have the CURL compiled in.and the installer complained about that. NOW... I haven't done a test to see if CURL is really there, as I assumed that the installer was right.

Oh and no problem on the oversight, I have had that happen many many a time....

11 Jan 2008, 8:36 AM
#22
quentinjs avatar

quentinjs

Zen Follower

Join Date:
Mar 2004
Location:
Calgary, Alberta
Posts:
289
Plugin Contributions:
0

Re: Upgrade error 1.3.7->1.3.8a

DrByte:

"all" ?

Um, what do you mean by "all" ?

11 Jan 2008, 8:38 AM
#23
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Upgrade error 1.3.7->1.3.8a

quentinjs:

So my other problem is CURL.... I'd have thought this would be a no brainer, just turn on the extension and away it goes.If the files are present, and you are editing the correct php.ini file to enable the extension, and you have also enabled the SSL extension, then it normally "just works" ... after you restart your webserver service.

You can check for CURL via a phpinfo script. There's one in the installer on the system inspection page or in the zc_install/includes folder. Or you can view it via your Admin on the Tools->Server Info page.
In the /extras folder is a curltest.php script which will test a CURL connection over standard port 80. Adding ?ssl=1 to the URL will test SSL as well. These same tests are done by the system inspection screen of the installer.

11 Jan 2008, 8:39 AM
#24
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Upgrade error 1.3.7->1.3.8a

quentinjs:

Um, what do you mean by "all" ?

You said your table structure was:

_keys_list **all **TEXT NULL

What did you mean by "all" ? :smile:

11 Jan 2008, 8:42 AM
#25
quentinjs avatar

quentinjs

Zen Follower

Join Date:
Mar 2004
Location:
Calgary, Alberta
Posts:
289
Plugin Contributions:
0

Re: Upgrade error 1.3.7->1.3.8a

oh... slip of the fingers. as I hand typed it..... so ideas on my CURL nemesis ?

11 Jan 2008, 8:46 AM
#26
quentinjs avatar

quentinjs

Zen Follower

Join Date:
Mar 2004
Location:
Calgary, Alberta
Posts:
289
Plugin Contributions:
0

Re: Upgrade error 1.3.7->1.3.8a

So I looked at the PHP Info and nothing for curl in it.

I do have a weird message
" Your database appears to need patching to a higher level. See Tools->Server Information to review patch levels." on the "Admin Home Page"

But it says the following on the info page:
Zen Cart 1.3.8a
Database Patch Level: 1.3.8
v1.3.8 [2008-01-11 01:24:04] (Version Update 1.3.7->1.3.8)
v1.3.7 [2007-01-20 00:04:36] (Version Update 1.3.6->1.3.7)
v1.3.6 [2006-10-29 00:43:32] (Version Update 1.3.5->1.3.6)
v1.3.5 [2006-09-12 09:32:05] (Version Update 1.3.0.2->1.3.5)
v1.3.0.2 [2006-06-21 23:40:49] (Version Update 1.3.0.1->1.3.0.2)
v1.3.0.1 [2006-06-21 21:57:21] (Version Update 1.3.0->1.3.0.1)
v1.3.0 [2006-03-30 23:01:48] (Version Update 1.2.7->1.3.0)
v1.2.7 [2006-02-26 21:30:09] (Version Update 1.2.6->1.2.7)
v1.2.6 [2005-11-28 23:38:19] (Version Update 1.2.5->1.2.6)
v1.2.5 [2005-11-28 23:38:19] (Version Update 1.2.4->1.2.5)
v1.2.4 [2005-11-28 23:38:12] (Version Update 1.2.3->1.2.4)
v1.2.3 [2005-11-28 23:38:10] (Version Update 1.2.2->1.2.3)
v1.2.2 [2005-11-28 23:38:10] (Zen-Cart Core Files Version Info)

11 Jan 2008, 8:49 AM
#27
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Upgrade error 1.3.7->1.3.8a

quentinjs:

So I looked at the PHP Info and nothing for curl in it.Then your curl extension isn't enabling correctly in PHP.
I'm not sure I'll be much further help on that area, other than the ideas I posted above.

quentinjs:

I do have a weird message
" Your database appears to need patching to a higher level. See Tools->Server Information to review patch levels." on the "Admin Home Page"

But it says the following on the info page:
Zen Cart 1.3.8a
Database Patch Level: 1.3.8
v1.3.8 [2008-01-11 01:24:04] (Version Update 1.3.7->1.3.8)
...Do you see the same on the storefront?

11 Jan 2008, 8:53 AM
#28
quentinjs avatar

quentinjs

Zen Follower

Join Date:
Mar 2004
Location:
Calgary, Alberta
Posts:
289
Plugin Contributions:
0

Re: Upgrade error 1.3.7->1.3.8a

Currently no I don't see it on the storefront, but I had seen it in the past...

and CURL I guess will have to wait for now

11 Jan 2008, 7:31 PM
#29
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Upgrade error 1.3.7->1.3.8a

Can you confirm that your /admin/includes/configure.php database details, including DB_PREFIX match your /includes/configure.php settings?

12 Jan 2008, 3:18 AM
#30
tweakservers avatar

tweakservers

New Zenner

Join Date:
Sep 2007
Posts:
67
Plugin Contributions:
0

Re: Upgrade error 1.3.7->1.3.8a

DrByte:

Can you confirm that your /admin/includes/configure.php database details, including DB_PREFIX match your /includes/configure.php settings?

I am getting the same message as well in both store front and the admin session when I was trying to run the same test upgrade on the 1.3.7.

I have cross checked both the configure.php file and it looks to be showing the same configuration details. Basically I have edited both the configure.php file manually, create a new database and copy the existing tables over to the new upgrade for testing.

13 Jan 2008, 9:08 AM
#31
tweakservers avatar

tweakservers

New Zenner

Join Date:
Sep 2007
Posts:
67
Plugin Contributions:
0

Re: Upgrade error 1.3.7->1.3.8a

I rerun the upgrade again and this time the message is being taken care off ... :clap::clap::clap::clap:

24 Jan 2008, 2:38 PM
#32
brent3721 avatar

brent3721

New Zenner

Join Date:
Apr 2007
Posts:
8
Plugin Contributions:
0

Re: Upgrade error 1.3.7->1.3.8a

I just got the same error:

Cannot ALTER or INSERT/REPLACE into table linkpoint_api because it does not exist. CHECK PREFIXES!

when trying to update the database from 1.37 to 1.38a

I have a fresh install of 1.37 that was done through a one click installer, so there's not added products to the database yet. Can I just ignore this error?

b r e n t

24 Jan 2008, 2:55 PM
#33
brent3721 avatar

brent3721

New Zenner

Join Date:
Apr 2007
Posts:
8
Plugin Contributions:
0

Re: Upgrade error 1.3.7->1.3.8a

I also should mention that I don't have a prefix for my database tables, is this necessary ? :unsure:

-b

24 Jan 2008, 7:09 PM
#34
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Upgrade error 1.3.7->1.3.8a

brent3721:

I just got the same error:

Cannot ALTER or INSERT/REPLACE into table linkpoint_api because it does not exist. CHECK PREFIXES!

when trying to update the database from 1.37 to 1.38aThat's a normal information message if you don't have the linkpoint module enabled.

25 Jan 2008, 2:23 AM
#35
brent3721 avatar

brent3721

New Zenner

Join Date:
Apr 2007
Posts:
8
Plugin Contributions:
0

Re: Upgrade error 1.3.7->1.3.8a

Thanks Doc, can you tell me what the linkpoint module is in a few words? I'm assuming it's something I need if it came up as a standard error that it wasn't installed.

  • b r e n t

:lamo:

25 Jan 2008, 9:23 AM
#36
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Upgrade error 1.3.7->1.3.8a

brent3721:

Thanks Doc, can you tell me what the linkpoint module is in a few words? I'm assuming it's something I need if it came up as a standard error that it wasn't installed.

Linkpoint is a credit card payment module which you would use if you had signed up to process credit cards through a gateway which used the linkpoint services.
It's not needed if you aren't using it.