Zen Cart Logo
Forums / Installing on a Linux/Unix Server / 500 Internal Error

500 Internal Error

Locked

Views: 14,464

Results 21 to 31 of 31
This thread is locked. New replies are disabled.
12 Oct 2008, 2:02 PM
#21
cottagepeople avatar

cottagepeople

New Zenner

Join Date:
Oct 2008
Posts:
1
Plugin Contributions:
0

500 Internal Error

DrByte:

Zen Cart v1.3.8 is much less prone to mod_security blocks during install-time than prior versions were.
The /zc_install/.htaccess file may be no longer needed, and might be removed in v1.4 to help avoid this issue.
I too am getting this 500 after a successful install. I try access the web page for my zen cart and I get 500 error.
I deleted the htacess and zc install folder and still nothing. I am so new at this I could scream.

12 Oct 2008, 8:10 PM
#22
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: 500 Internal Error

You'll probably have to ask your hosting company / server administrator what's causing the block, since 500 errors are always a result of the server's own unique configuration rejecting something that you're trying to do on your site.

12 Oct 2008, 8:13 PM
#23
atomiksteve avatar

atomiksteve

New Zenner

Join Date:
Jul 2008
Posts:
43
Plugin Contributions:
0

Re: 500 Internal Error

I started getting the 500 Internal Server Error this morning. My site has been functional for months now (although hidden from the public). I was about to go live with it today... Can anyone point me in the right direction as to why this is happening? I did not change anything on the store since I checked on Friday night.

Please help! Thanks!
:frusty:

12 Oct 2008, 9:56 PM
#24
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: 500 Internal Error

Same answer. 500 errors are the result of server-side configuration rules being violated by something. Your hosting company is the one who selects the rules. So, it's them who must tell you what rules you're breaking in order for you to know what needs fixing.

13 Oct 2008, 12:57 AM
#25
atomiksteve avatar

atomiksteve

New Zenner

Join Date:
Jul 2008
Posts:
43
Plugin Contributions:
0

Re: 500 Internal Error

DrByte:

Same answer. 500 errors are the result of server-side configuration rules being violated by something. Your hosting company is the one who selects the rules. So, it's them who must tell you what rules you're breaking in order for you to know what needs fixing.

Thanks...I think I was writing my post while yours went up. I did contact them...they haven't written back yet, but it seems to have resolved itself. I guess they did something... oh well, as long as it works.

25 Nov 2008, 12:28 PM
#26
christophert avatar

christophert

New Zenner

Join Date:
Nov 2008
Posts:
32
Plugin Contributions:
0

Re: 500 Internal Error

is it not dangerous security-wise to delete the .htaccess?:ohmy:

7 Jun 2010, 4:04 PM
#28
billysnake13 avatar

billysnake13

New Zenner

Join Date:
Mar 2010
Posts:
11
Plugin Contributions:
0

Re: 500 Internal Error

Hello,

Anyone know what my problem is: I keep getting a Error 500 on zencart 1.38

here is what the error log says:

[Mon Jun 07 10:52:58 2010] [error] [client 66.249.71.132] File does not exist: /home/bmwparts/public_html/500.shtml

but the files do exist? Any help would be appreciated

7 Aug 2010, 1:49 PM
#29
hammerntx avatar

hammerntx

New Zenner

Join Date:
Aug 2010
Posts:
2
Plugin Contributions:
0

Re: 500 Internal Error

I am getting this error and have removed the .htaccess file and am still getting the error. Here is my php info.

http://tvtandme.com/info.php

Thanks in advance!:flex:

7 Aug 2010, 1:54 PM
#30
hammerntx avatar

hammerntx

New Zenner

Join Date:
Aug 2010
Posts:
2
Plugin Contributions:
0

Re: 500 Internal Error

BTW, this is the error message in my log.

[07/Aug/2010:00:03:53 -0400] "GET /zc_install/ HTTP/1.0" 404 1182 "-" "Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.11) Gecko/20100701 Firefox/3.5.11 (.NET CLR 3.0.30729)"

7 Aug 2010, 3:15 PM
#31
kuroi avatar

kuroi

Totally Zenned

Join Date:
Apr 2006
Location:
London, UK
Posts:
10,475
Plugin Contributions:
11

Re: 500 Internal Error

Please read post #22.