Zen Cart Logo
Forums / General Questions / After two years, customers starting to get errors

After two years, customers starting to get errors

Locked

Views: 961

Results 1 to 6 of 6
This thread is locked. New replies are disabled.
6 Jan 2008, 11:58 PM
#1
ronnyo avatar

ronnyo

New Zenner

Join Date:
Dec 2005
Posts:
17
Plugin Contributions:
0

After two years, customers starting to get errors

I´ve been using zen-cart for two years. Have always had Zen Cart 1.2.7.

This has worked fine, untill now. First I got some errors in my database which had to be corected, and now I get noumerous other errors, a couple every day, which stop the customers to reach the site. Theese problems hangs in there for a couple of minutes,

Normaly I still get in to the admin, but when I get this specific error I cant see any products under categories/products.

The erros can look like this.

1030 Got error 28 from storage engine

There has been other errors to besides the sql-errors, but I has not ben writing them down.

Is this a zen-cart problem or is it because my host has problems?

Thanks!

7 Jan 2008, 12:13 AM
#2
birdoasis avatar

birdoasis

Inactive

Join Date:
Jun 2005
Location:
Cheney WA
Posts:
1,123
Plugin Contributions:
0

Re: After two years, customers starting to get errors

That's how it works. After the warranty runs out the errors start coming up. hehe

I have a feeling that your host company upgraded php and mysql. Ask them if they've made any changes lately.

John Patrick
A Zen Cart Advocate!

7 Jan 2008, 12:14 AM
#3
birdoasis avatar

birdoasis

Inactive

Join Date:
Jun 2005
Location:
Cheney WA
Posts:
1,123
Plugin Contributions:
0

Re: After two years, customers starting to get errors

oh yea,

If you upgrade to the latest version, the errors may go away.

John Patrick
A Zen Cart Advocate!

7 Jan 2008, 12:43 AM
#4
Kim avatar

Kim

Obaa-san

Join Date:
Jun 2003
Location:
West Coast, North America
Posts:
26,659
Plugin Contributions:
0

Re: After two years, customers starting to get errors

Definitely check with your hosting company to see what may have changed - If you are getting MYSQL errors that is definitely the database.

You do need to consider upgrading soon no matter what - php5 is coming to hosts soon and the v1.2 series is not compliant with php5.

Please do not PM for support issues: a private solution doesn't benefit the community.

Be careful with unsolicited advice via email or PM - Make sure the person you are talking to is a reliable source.

7 Jan 2008, 2:15 AM
#5
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: After two years, customers starting to get errors

Error code 28: No space left on device

One or more sections of your server is "out of space" or doesn't have "enough" space to do whatever it wants to do with the database. You need to talk to your hosting company about what's causing the problem.

Maybe your hosting account has maxed-out its allowed disk space?
Or maybe the server is having disk problems.

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

7 Jan 2008, 3:03 AM
#6
birdoasis avatar

birdoasis

Inactive

Join Date:
Jun 2005
Location:
Cheney WA
Posts:
1,123
Plugin Contributions:
0

Re: After two years, customers starting to get errors

Kind of scares me that you know error codes. :lookaroun
But I guess that's why your the Doctor.

John Patrick
A Zen Cart Advocate!