Zen Cart Logo
Forums / Installing on a Linux/Unix Server / Internal Server Error after editing .htaccess --- Argghhhh

Internal Server Error after editing .htaccess --- Argghhhh

Locked

Views: 2,213

Results 1 to 1 of 1
This thread is locked. New replies are disabled.
11 Jan 2008, 6:46 PM
#1
chiefintegrity avatar

chiefintegrity

New Zenner

Join Date:
Aug 2006
Posts:
8
Plugin Contributions:
0

Internal Server Error after editing .htaccess --- Argghhhh

I hope this is the most appropriate category

Please help I feel I am going mad.

I installed zen cart a few months ago. During installation the program made several recommendations of lines to add to a .htaccess file. The lines suggested were:-

php_value session.use_trans_sid off
php_value register_globals off
#php_value register_globals off
<Files ".ht*">
deny from all
</Files>

I added them and everything worked fine....

Until today when I decided to make my own 404 page as it was showing an advertisement page for my web hosts.

I added the line below to the .htaccess file:-

ErrorDocument 404 http://mywebsite/index.php

When trying to access the site I got the error:-

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
....
Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

So I took the new line out again but still got the error!
I have tried everything I can think of. Ironically I have now got a .htaccess file with the 404 page code in and it works but the original and probably much more important code will not work.

I feel like I must be imagining that it ever worked. Please save my sanity. What can I do to make my site secure again? And how did this happen?

I would be very greatful if someone can help.

John