Zen Cart Logo
Forums / Upgrading from 1.3.x to 1.3.9 / 1.3.7 to 1.3.8, can't make changes to database

1.3.7 to 1.3.8, can't make changes to database

Locked

Views: 1,897

Results 1 to 7 of 7
This thread is locked. New replies are disabled.
17 Jan 2008, 1:17 PM
#1
ptoly avatar

ptoly

New Zenner

Join Date:
Sep 2004
Posts:
19
Plugin Contributions:
0

1.3.7 to 1.3.8, can't make changes to database

Okay, here goes a lot of information. Tried to find anything like this in the forums but can't find a similar thread....

I've created a test version of 1.3.8a and updated the new database but once I've done this I can't make any changes from the admin area. If I, say try and delete a product, when I click on the delete button I get the normal warning and but nothing happens. I am simply returned to the list of products, said product still there. I also can't modify any settings in the payment modules. Same thing, click on the update button and nothing happens, just returned to the page as if nothing happens.

The Debug Error I get is: ```
[16-Jan-2008 23:08:58] PHP Warning: Variable passed to each() is not an array or object in /mysite/admin/modules.php on line 56


It has been a merry chase these last two days.

First I created a copy of my database and a virgin copy of 1.3.8a, uploaded and updated the modified code for the modules I've added. Update went fine and I thought I was golden until I found I could not modify the database or post SQL via the admin panel. Message is: ```
 Error: Nothing to do - no query or query-file specified.

So I backed off and tried a more virgin version with no third party stuff. I dumped the database, reverted to a back up, and went through the upgrade process once again.

I found out that if I tried to add a prefix using the upgrade system I get odd messages like: ```
in:
[SHOW TABLES]


I thought I was golden once again because I could log in to the admin area and move around. 

Then I found I still could'nt touch the database.

I went back to an older back up of the database, just to check. Dumped and reimported that. Went through the update process and still I can't get any contact with my data with this upgraded version.

Database: MySQL 5.0.24a-standard-log
PHP Version: 5.2.3 (Zend: 2.2.0)   PHP Memory Limit: 90M  	PHP Safe Mode: Off
PHP File Uploads: On    Max Size: 7M 	POST Max Size: 8M

Any help will be gratefully accepted.
Thanks!
17 Jan 2008, 3:52 PM
#2
rainthebat avatar

rainthebat

Zen Follower

Join Date:
Feb 2007
Posts:
314
Plugin Contributions:
0

Re: 1.3.7 to 1.3.8, can't make changes to database

You sound like a pretty advance user when it comes to this stuff, just want to make sure that you checked in includes/configure.php to make sure that your database prefix's are set up to match the actual prefix's you use in the database i.e. define('DB_PREFIX', 'prefixHere_');''

Although your errors don't seem to point to this I thought to suggest this as no one has replied to your post yet.

17 Jan 2008, 4:02 PM
#3
website_rob avatar

website_rob

Inactive

Join Date:
Oct 2006
Location:
Alberta, Canada
Posts:
4,572
Plugin Contributions:
0

Re: 1.3.7 to 1.3.8, can't make changes to database

First, I would turn SafeMode ON.

Second, sounds like a permission and/or path problem. It is not uncommon when working with multiple db's such as when testing, to use incorrect settings for different db's. I would verify that the paths used and db Username/Password are correct, for each Zen Cart setup.

Also, are you setup on a personal Server or a Hosting account?

17 Jan 2008, 9:27 PM
#4
ptoly avatar

ptoly

New Zenner

Join Date:
Sep 2004
Posts:
19
Plugin Contributions:
0

Re: 1.3.7 to 1.3.8, can't make changes to database

Thanks to both rainthebat and Website Rob for your replies.

Funnily enough I woke up this morning thinking it might be the prefix, but no joy. Checked them and the configure.php file are in sync.

I'm on a hosting site. I've been through the configuration with a fine tooth comb and can't find any error. I'll look again, just in case. It does seem like some kind of paths or permissions problem, agreed.

Thanks

17 Jan 2008, 11:49 PM
#5
ptoly avatar

ptoly

New Zenner

Join Date:
Sep 2004
Posts:
19
Plugin Contributions:
0

Re: 1.3.7 to 1.3.8, can't make changes to database

Hmm,
Dr. Byte recommended to actually NOT run with Safe Mode ON. See here: http://www.zen-cart.com/forum/showthread.php?t=76740

18 Jan 2008, 3:55 AM
#6
website_rob avatar

website_rob

Inactive

Join Date:
Oct 2006
Location:
Alberta, Canada
Posts:
4,572
Plugin Contributions:
0

Re: 1.3.7 to 1.3.8, can't make changes to database

Yes, SafeMode OFF is better.

Wasn't thinking when I stated otherwise or the Coffee hadn't kicked, not sure which. :wink:

20 Jan 2008, 11:17 PM
#7
ptoly avatar

ptoly

New Zenner

Join Date:
Sep 2004
Posts:
19
Plugin Contributions:
0

Re: 1.3.7 to 1.3.8, can't make changes to database

I think I've resolved this. Since I did not get any answer I went ahead and simply erased the database and did a clean install from the installer into the new/temp database. I then exported an updated version of the original and up to date data, imported it into the clean install. I got a number of error messages but everything seems to be working. So far.

Will have to spend some more time looking.

Still don't know why a simple upgrade did not work.