Zen Cart Logo
Forums / Installing on a Linux/Unix Server / 500 Error after accepting terms from install

500 Error after accepting terms from install

Locked

Views: 1,574

Results 1 to 10 of 10
This thread is locked. New replies are disabled.
18 Jan 2008, 6:28 PM
#1
webaddict avatar

webaddict

New Zenner

Join Date:
Jan 2008
Posts:
7
Plugin Contributions:
0

500 Error after accepting terms from install

Hello,
Any idea where to go? I get the following error when click on continue after accepting terms in install. configure.php is setup correctly.

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.


[Secure NsHosts] Server at https://www.riveroflifehealthresort.com Port 80

Thanks:lamo:

18 Jan 2008, 6:36 PM
#3
webaddict avatar

webaddict

New Zenner

Join Date:
Jan 2008
Posts:
7
Plugin Contributions:
0

Re: 500 Error after accepting terms from install

I did an info.php check and got API server CGI. Does this matter?

18 Jan 2008, 6:37 PM
#4
merlinpa1969 avatar

merlinpa1969

Totally Zenned

Join Date:
Mar 2004
Posts:
13,031
Plugin Contributions:
4

Re: 500 Error after accepting terms from install

you need to go in and set the folders that you changed to 777 back to 755
and the files that you changed back to 644

once install is done you will need to set configure.php files to 444

18 Jan 2008, 6:55 PM
#5
superprg avatar

superprg

Totally Zenned

Join Date:
Feb 2006
Location:
Chicago
Posts:
1,349
Plugin Contributions:
0

Re: 500 Error after accepting terms from install

Merlinpa1969:

you need to go in and set the folders that you changed to 777 back to 755
and the files that you changed back to 644

once install is done you will need to set configure.php files to 444

Shouldn't this error message be a part of the install itself?

18 Jan 2008, 7:17 PM
#6
webaddict avatar

webaddict

New Zenner

Join Date:
Jan 2008
Posts:
7
Plugin Contributions:
0

Re: 500 Error after accepting terms from install

ok
I'm reinstalling zencart
I'll try that change, but don't you change that configure.php back to 755 after install? I would think you need to right to the files during install.:cool:

18 Jan 2008, 7:21 PM
#7
merlinpa1969 avatar

merlinpa1969

Totally Zenned

Join Date:
Mar 2004
Posts:
13,031
Plugin Contributions:
4

Re: 500 Error after accepting terms from install

not if you r running php as cgi

this will cause the 500 error, since php as cgi dosnt allow 777

18 Jan 2008, 7:30 PM
#8
webaddict avatar

webaddict

New Zenner

Join Date:
Jan 2008
Posts:
7
Plugin Contributions:
0

Re: 500 Error after accepting terms from install

oh:frusty:
I wish i didn't delete it yet. I'm in process of uploading zen cart again. Will this fix the php cgi issue?

18 Jan 2008, 9:37 PM
#9
merlinpa1969 avatar

merlinpa1969

Totally Zenned

Join Date:
Mar 2004
Posts:
13,031
Plugin Contributions:
4

Re: 500 Error after accepting terms from install

Yes,
as soon as you get all the files uploaded, DONT change any permissions,
just run the installer,

19 Jan 2008, 8:16 PM
#10
webaddict avatar

webaddict

New Zenner

Join Date:
Jan 2008
Posts:
7
Plugin Contributions:
0

Re: 500 Error after accepting terms from install

Well still does not work. Played around it for some time. So I put zencart on another host. I found a thought in help section about if host not working with PHP as CGI correctly, to get another host. It work first time install on new host. Now a problem arises. The new host does not have SSL and I want to use Google Check Out (cheaper than Paypal), but it requires https:// so I need to tell zencart on new host to point to Google Check Out on old host SSL link. I have put this issue in another post about shipping and module issues. Any ideas?