Zen Cart Logo
Forums / Installing on a Windows Server / help please? - admin says failed to open /includes/autoload_func.php

help please? - admin says failed to open /includes/autoload_func.php

Locked

Views: 4,882

Results 1 to 15 of 15
This thread is locked. New replies are disabled.
19 Jan 2008, 6:29 PM
#1
lj111970 avatar

lj111970

New Zenner

Join Date:
Apr 2007
Location:
Ontario, Canada
Posts:
97
Plugin Contributions:
0

help please? - admin says failed to open /includes/autoload_func.php

Good day (well maybe for you).
I have installed zen carts on my last 2 hosts with no trouble but now that I have moved to this new host I can not get it going and have no clue why not. I was wondering if someone could suggest something?

I downloaded, unzipped and uploaded (via ftp) thelatest version of Zen cart to my server (am using readyhosting).
I ran the install and it went through ok. When I clicked "go to mys tore" I get a blank white page. When I click "go to mya dmin" I get this error.

[Warning: main(/nawinfs02/home/users/web/b839/rh.lj111970/includes/autoload_func.php): failed to open stream: No such file or directory in \nawinfs02\home\users\web\b839\rh.lj111970\admin\includes\application_top.php on line 130

Fatal error: main(): Failed opening required '/nawinfs02/home/users/web/b839/rh.lj111970/includes/autoload_func.php' (include_path='.;c:\php\includes') in \nawinfs02\home\users\web\b839\rh.lj111970\admin\includes\application_top.php on line 130

I have uninstalled an re installed 4 times now and continue to get this error. What am I missing? I am getting so frustrated here :(

ps - my site is located here http://lj111970.readyhosting.com
due to the fact that my domain nameservers have not yet resolved. My site will be http://ljgdesign.com once they resolve (within 24 hours)

Thanks for any help anyone can offer!

19 Jan 2008, 7:26 PM
#2
lj111970 avatar

lj111970

New Zenner

Join Date:
Apr 2007
Location:
Ontario, Canada
Posts:
97
Plugin Contributions:
0

Re: help please? - admin says failed to open /includes/autoload_func.php

admin/includes/application_top.php
lines 120 to 130

if (isset($loaderPrefix)) {
$loaderPrefix = preg_replace('/[a-z_]^/', '', $loaderPrefix);
} else {
$loaderPrefix = 'config';
}
$loader_file = $loaderPrefix . '.core.php';
require('includes/initsystem.php');
/**

  • load the autoloader interpreter code.
    */
    require(DIR_FS_CATALOG . 'includes/autoload_func.php');
    ?>

includes/autoload_func.php

<?php /** * File contains the autoloader loop * * The autoloader loop takes the array from the auto_loaders directory * and uses this this to constuct the InitSysytem. * see [{@link](mailto:"{@link") <http://www.zen-cart.com/wiki/index.php/Developers_API_Tutorials#InitSystem>} for more details. * * @package initSystem * @copyright Copyright 2003-2007 Zen Cart Development Team * @copyright Portions Copyright 2003 osCommerce * @license <http://www.zen-cart.com/license/2_0.txt> GNU Public License V2.0 * @version $Id: autoload_func.php 6559 2007-07-05 06:42:51Z drbyte $ */ if (!defined('IS_ADMIN_FLAG')) { die('Illegal Access'); } reset($autoLoadConfig); ksort($autoLoadConfig); foreach ($autoLoadConfig as $actionPoint => $row) { $debugOutput = ""; foreach($row as $entry) { $debugOutput = 'actionPoint=>'.$actionPoint . ' '; // $entry['loadFile'] = str_replace(array(':', '\\\\'), '', $entry['loadFile']); switch($entry['autoType']) { case 'include': /** * include a file as specified by autoloader array */ if (file_exists($entry['loadFile'])) include($entry['loadFile']); else $debugOutput .= 'FAILED: '; $debugOutput .= 'include(\'' . $entry['loadFile'] . '\');' . '<br />'; break; case 'require': /** * require a file as specified by autoloader array */ if (file_exists($entry['loadFile'])) require($entry['loadFile']); else $debugOutput .= 'FAILED: '; $debugOutput .= 'require(\'' . $entry['loadFile'] . '\');' . '<br />'; break; case 'init_script': $baseDir = DIR_WS_INCLUDES . 'init_includes/'; if (file_exists(DIR_WS_INCLUDES . 'init_includes/overrides/' . $entry['loadFile'])) { $baseDir = DIR_WS_INCLUDES . 'init_includes/overrides/'; } /** * include an init_script as specified by autoloader array */ if (file_exists($baseDir . $entry['loadFile'])) include($baseDir . $entry['loadFile']); else $debugOutput .= 'FAILED: '; $debugOutput .= 'include(\'' . $baseDir . $entry['loadFile'] . '\');' . '<br />'; break; case 'class': if (isset($entry['classPath'])) { $classPath = $entry['classPath']; } else { $classPath = DIR_FS_CATALOG . DIR_WS_CLASSES; } /** * include a class definition as specified by autoloader array */ if (file_exists($classPath . $entry['loadFile'])) include($classPath . $entry['loadFile']); else $debugOutput .= 'FAILED: '; $debugOutput .= 'include(\'' . $classPath . $entry['loadFile'] . '\');' . '<br />'; break; case 'classInstantiate': $objectName = $entry['objectName']; $className = $entry['className']; if (isset($entry['classSession']) && $entry['classSession'] === true) { if (isset($entry['checkInstantiated']) && $entry['checkInstantiated'] === true) { if (!isset($_SESSION[$objectName])) { $_SESSION[$objectName] = new $className(); $debugOutput .= 'if (!$_SESSION[' . $objectName . ']) { '; $debugOutput .= '$_SESSION[' . $objectName . '] = new ' . $className . '();'; $debugOutput .= ' }<br />'; } } else { $_SESSION[$objectName] = new $className(); $debugOutput .= ' $_SESSION[' . $objectName . '] = new ' . $className . '();<br />'; } } else { $$objectName = new $className(); $debugOutput .= '$' . $objectName . ' = new ' . $className . '();<br />'; } break; case 'objectMethod': $objectName = $entry['objectName']; $methodName = $entry['methodName']; if (is_object($_SESSION[$objectName])) { $_SESSION[$objectName]->$methodName(); $debugOutput .= '$_SESSION[' . $objectName . ']->' . $methodName . '();<br />'; } else { $$objectName->$methodName(); $debugOutput .= '$' . $objectName . '->' . $methodName . '();<br />'; } break; } if (DEBUG_AUTOLOAD === true) echo $debugOutput; } } ?>

Not sure if those codes help

20 Jan 2008, 6:40 PM
#3
lj111970 avatar

lj111970

New Zenner

Join Date:
Apr 2007
Location:
Ontario, Canada
Posts:
97
Plugin Contributions:
0

Re: help please? - admin says failed to open /includes/autoload_func.php

only have about 4 hairs left - can anyone help?
I have contacted my host to verify teh servers but heard nothing back form them either - do I smell? hehehe

21 Jan 2008, 9:15 AM
#4
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: help please? - admin says failed to open /includes/autoload_func.php

lj111970:

[Warning: main(/nawinfs02/home/users/web/b839/rh.lj111970/includes/autoload_func.php): failed to open stream: No such file or directory in \nawinfs02\home\users\web\b839\rh.lj111970\admin\includes\application_top.php on line 130

It's telling you that a required file cannot be located on the server.

Your DIR_FS_CATALOG settings are probably incorrect.
You're on a Windows host that's using \nawinfs02\home as the server/drive/share location of your webstore files.
But PHP doesn't recognize \nawinfs02\home the same as /nawinfos02/home

You'd be safer using a drive letter mapped to that server/share, or else alter your DIR_FS_CATALOG (and other) setting(s) that use /nawinfs02/home to use: \\nawinfs02\home ...

(Yes, the doubled-up backslashes are required due to the way Windows works and how PHP interprets a backslash.)

Perhaps your hosting company can instruct you on the correct path to use.

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

21 Jan 2008, 3:05 PM
#5
fcegarra avatar

fcegarra

New Zenner

Join Date:
Jul 2007
Posts:
61
Plugin Contributions:
0

Re: help please? - admin says failed to open /includes/autoload_func.php

Hello everyone,

Thanks Dr Byte for your help, you are really helpful!!:blush:

I have the same issue but actually what I want to do it is install on the same server a test webstore to work on it if necessary.
I have my main webstore in the folder public_html/zen/ and my test webstore is in this folder public_html/testvm/store/

When I want to access to the admin section in my test website, I have this error message poping up :

Warning: require(/data/14/1/130/41/1293367/user/1384328/htdocs/zen/includes/autoload_func.php) [function.require]: failed to open stream: No such file or directory in /home/viamccom/public_html/testvm/store/admin/includes/application_top.php on line 149

in my configure.php file I have that :
define('DIR_WS_CATALOG', '/testvm/store/');
define('DIR_WS_HTTPS_CATALOG', '/testvm/store/');
define('DIR_WS_IMAGES', 'images/');
define('DIR_WS_INCLUDES', 'includes/');
define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');
define('DIR_WS_DOWNLOAD_PUBLIC', DIR_WS_CATALOG . 'pub/');
define('DIR_WS_TEMPLATES', DIR_WS_INCLUDES . 'templates/');

My main webstore and main admin section is working fine but not my test webstore. I don't know what I can do. I can code but I can't find the problem...
Thanks a lot for your help!

have a great day,

F.

21 Jan 2008, 3:32 PM
#6
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: help please? - admin says failed to open /includes/autoload_func.php

fcegarra:

Warning: require(/data/14/1/130/41/1293367/user/1384328/htdocs/zen/includes/autoload_func.php) [function.require]: failed to open stream: No such file or directory in /home/viamccom/public_html/testvm/store/admin/includes/application_top.phpYou probably haven't updated your DIR_FS_xxxxxxx settings in your configure.php files to suit your new server's settings

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

21 Jan 2008, 3:40 PM
#7
fcegarra avatar

fcegarra

New Zenner

Join Date:
Jul 2007
Posts:
61
Plugin Contributions:
0

Re: help please? - admin says failed to open /includes/autoload_func.php

Thanks for this so quick answer. I really appreciate!

public_html/testvm/store/ is my test webstore
public_html/zen is my main and live webstore
I am actually on the same server but on a different folder and I have that in my configure.php :

define('DIR_FS_CATALOG', '/home/viamccom/public_html/testvm/store/');
define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');
define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');
define('DIR_WS_UPLOADS', DIR_WS_IMAGES . 'uploads/');
define('DIR_FS_UPLOADS', DIR_FS_CATALOG . DIR_WS_UPLOADS);
define('DIR_FS_EMAIL_TEMPLATES', DIR_FS_CATALOG . 'email/');

I have no clue where It is wrong..I got headache already at 10.30 am..arffff :(
Do you know if I need to setup /edit something else. I asked my host company "camelot hosting" but they haven't got back to me yet.

Thanks!!!!

F.

21 Jan 2008, 3:44 PM
#8
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: help please? - admin says failed to open /includes/autoload_func.php

You have 2 configure.php files.
Have you updated both?

Were they read-only before you updated them? If so, did you make them writable before uploading changes? If not, the upload likely failed.

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

21 Jan 2008, 4:07 PM
#9
fcegarra avatar

fcegarra

New Zenner

Join Date:
Jul 2007
Posts:
61
Plugin Contributions:
0

Re: help please? - admin says failed to open /includes/autoload_func.php

I am dumb sometimes I had not updated the admin/includes/configure.php file. I just did it but I have the foolowinf error :

Warning: require(/data/14/1/130/41/1293367/user/1384328/htdocs/testvm/store/includes/autoload_func.php) [function.require]: failed to open stream: No such file or directory in /home/viamccom/public_html/testvm/store/admin/includes/application_top.php on line 149

Fatal error: require() [function.require]: Failed opening required '/data/14/1/130/41/1293367/user/1384328/htdocs/testvm/store/includes/autoload_func.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/viamccom/public_html/testvm/store/admin/includes/application_top.php on line 149

It is still the same error but now I have the path of my test webstore right (/testvm/store) befire it was (/zen) which is my main webstore.

Here is my admin/icnludes/configure.php

define('HTTP_SERVER', 'http://.com');
define('HTTPS_SERVER', 'https://.com');
define('HTTP_CATALOG_SERVER', 'http://
.com');
define('HTTPS_CATALOG_SERVER', 'https://*****.com');
// Use secure webserver for catalog module and/or admin areas?
define('ENABLE_SSL_CATALOG', 'false');
define('ENABLE_SSL_ADMIN', 'false');
// NOTE: be sure to leave the trailing '/' at the end of these lines if you make changes!
// * DIR_WS_
= Webserver directories (virtual/URL)
// these paths are relative to top of your webspace ... (ie: under the public_html or httpdocs folder)
define('DIR_WS_ADMIN', '/testvm/store/admin/');
define('DIR_WS_CATALOG', '/testvm/store/');
define('DIR_WS_HTTPS_ADMIN', '/testvm/store/admin/');
define('DIR_WS_HTTPS_CATALOG', '/testvm/store/');
define('DIR_WS_IMAGES', 'images/');
define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
define('DIR_WS_CATALOG_IMAGES', HTTP_CATALOG_SERVER . DIR_WS_CATALOG . 'images/');
define('DIR_WS_CATALOG_TEMPLATE', HTTP_CATALOG_SERVER . DIR_WS_CATALOG . 'includes/templates/');
define('DIR_WS_INCLUDES', 'includes/');
define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');
define('DIR_WS_CATALOG_LANGUAGES', HTTP_CATALOG_SERVER . DIR_WS_CATALOG . 'includes/languages/');
// * DIR_FS_
= Filesystem directories (local/physical)
//the following path is a COMPLETE path to your Zen Cart files. eg: /var/www/vhost/accountname/public_html/store/
define('DIR_FS_ADMIN', '/data/14/1/130/41/1293367/user/1384328/htdocs/testvm/store/admin/');
define('DIR_FS_CATALOG', '/data/14/1/130/41/1293367/user/1384328/htdocs/testvm/store/');
define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');
define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');
define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');
define('DIR_FS_CATALOG_TEMPLATES', DIR_FS_CATALOG . 'includes/templates/');
define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');
define('DIR_FS_EMAIL_TEMPLATES', DIR_FS_CATALOG . 'email/');
define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');
// define our database connection
define('DB_TYPE', 'mysql');
define('DB_PREFIX', '');
define('DB_SERVER', 'localhost');
define('DB_SERVER_USERNAME', '
');
define('DB_SERVER_PASSWORD', '*****');
define('DB_DATABASE', '
*****');
define('USE_PCONNECT', 'false'); // use persistent connections?
define('STORE_SESSIONS', 'db'); // use 'db' for best support, or '' for file-based storage
// The next 2 "defines" are for SQL cache support.
// For SQL_CACHE_METHOD, you can select from: none, database, or file
// If you choose "file", then you need to set the DIR_FS_SQL_CACHE to a directory where your apache
// or webserver user has write privileges (chmod 666 or 777). We recommend using the "cache" folder inside the Zen Cart folder
// ie: /path/to/your/webspace/public_html/zen/cache -- leave no trailing slash
define('SQL_CACHE_METHOD', 'none');
define('DIR_FS_SQL_CACHE', '/data/14/1/130/41/1293367/user/1384328/htdocs/testvm/store/cache');

This file is actually my zen/admin/includes/configure.php where I changed the word "zen" but "testvm/store". I have edited my db info too.
Do I miss something here?

Thank again for all your help Doc, you r the best :)

F.

21 Jan 2008, 4:20 PM
#10
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: help please? - admin says failed to open /includes/autoload_func.php

Warning: require(/data/14/1/130/41/1293367/user/1384328/htdocs/testvm/store/includes/autoload_func.php) [function.require]: failed to open stream: No such file or directory in /home/viamccom/public_html/testvm/store/admin/includes/application_top.php

Your real DIR_FS_CATALOG setting should probably be more like: /home/viamccom/public_html/testvm/store/

But the error message is saying that it's being told to look at:
/data/14/1/130/41/1293367/user/1384328/htdocs/testvm/store/

"testvm" isn't the issue ... it's the rest of the path before it that's coming from settings for another server

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

21 Jan 2008, 4:24 PM
#11
merlinpa1969 avatar

merlinpa1969

Totally Zenned

Join Date:
Mar 2004
Posts:
13,031
Plugin Contributions:
4

Re: help please? - admin says failed to open /includes/autoload_func.php

you need to change these lines

define('DIR_FS_ADMIN', '/data/14/1/130/41/1293367/user/1384328/htdocs/testvm/store/admin/');
define('DIR_FS_CATALOG', '/data/14/1/130/41/1293367/user/1384328/htdocs/testvm/store/');

define('DIR_FS_SQL_CACHE', '/data/14/1/130/41/1293367/user/1384328/htdocs/testvm/store/cache');

to be

define('DIR_FS_ADMIN', '/home/viamccom/public_html/testvm/store/admin/');
define('DIR_FS_CATALOG', '/home/viamccom/public_html/testvm/store/');

define('DIR_FS_SQL_CACHE', '/home/viamccom/public_html/testvm/store/cache');

These are the same same edits I sent you last night,

Zen cart PCI compliant Hosting

21 Jan 2008, 7:15 PM
#12
fcegarra avatar

fcegarra

New Zenner

Join Date:
Jul 2007
Posts:
61
Plugin Contributions:
0

Re: help please? - admin says failed to open /includes/autoload_func.php

Thank you so much for your help,

I have solved this issue but I have another one now when I still want to connect to the admin section I got this :

Warning: require(includes/languages/english/email_extras.php) [function.require]: failed to open stream: No such file or directory in /home/viamccom/public_html/testvm/store/admin/includes/languages/english.php on line 669

Warning: require(includes/languages/english/email_extras.php) [function.require]: failed to open stream: No such file or directory in /home/viamccom/public_html/testvm/store/admin/includes/languages/english.php on line 669

Fatal error: require() [function.require]: Failed opening required 'includes/languages/english/email_extras.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/viamccom/public_html/testvm/store/admin/includes/languages/english.php on line 669

In the file "testvm/store/admin/includes/languages/english.php" on line 669 there is this :

// include additional files:
require(DIR_WS_LANGUAGES . $_SESSION['language'] . '/' . FILENAME_EMAIL_EXTRAS);
include(zen_get_file_directory(DIR_FS_CATALOG_LANGUAGES . $_SESSION['language'] . '/', FILENAME_OTHER_IMAGES_NAMES, 'false'));

But I don't know where I can look for it after...
Thanks to help me like you do and help the other zeners on the forum.

Thx,

F.

21 Jan 2008, 8:17 PM
#13
merlinpa1969 avatar

merlinpa1969

Totally Zenned

Join Date:
Mar 2004
Posts:
13,031
Plugin Contributions:
4

Re: help please? - admin says failed to open /includes/autoload_func.php

the problem here was that there were only 3 files in the admin/includes/languages/english folder,

there should have been 3 folders and 81 files,

Zen cart PCI compliant Hosting

22 Jan 2008, 12:30 PM
#14
lj111970 avatar

lj111970

New Zenner

Join Date:
Apr 2007
Location:
Ontario, Canada
Posts:
97
Plugin Contributions:
0

Re: help please? - admin says failed to open /includes/autoload_func.php

Thank you for trying to help me Dr Byte - I contacted my provider many times and they couldn't even give me the courtesy of a reply so I again switched to another host :( .... but hey! my site is up and I can actually access it now LOL
Thanks for the effort!

14 Feb 2008, 5:03 AM
#15
haleann avatar

haleann

New Zenner

Join Date:
Dec 2007
Posts:
3
Plugin Contributions:
0

Re: help please? - admin says failed to open /includes/autoload_func.php

hi,
i had this error, /includes/autoload_func.php

in my admin/includes

the problem was with my Dir_Fs in admin/includes.........

i fixed it by looking at my includes/configure.php

and pasting the define('DIR_FS_CATALOG', '/home/......./public_html/');
listed there to the admin/includes/configure.php

just paste whats there to the admin/includes config file

i hope it helps