Zen Cart Logo
Forums / Basic Configuration / Having a second ZC on the same server as a Backup.

Having a second ZC on the same server as a Backup.

Locked

Views: 1,282

Results 1 to 9 of 9
This thread is locked. New replies are disabled.
19 Jan 2008, 8:47 PM
#1
alhakeem2001 avatar

alhakeem2001

Zen Follower

Join Date:
Nov 2007
Posts:
434
Plugin Contributions:
1

Having a second ZC on the same server as a Backup.

I want to back up my website and have a second ZC running on the same sever with a deferent database, but I want to use the backed up SQL from my original ZC to upload to the new database! Is that Possible? And is there any configuration for the SQL before uploading it to the new database?

20 Jan 2008, 12:00 AM
#2
kuroi avatar

kuroi

Totally Zenned

Join Date:
Apr 2006
Location:
London, UK
Posts:
10,475
Plugin Contributions:
11

Re: Having a second ZC on the same server as a Backup.

As long as your SQL backup doesn't specify the database name, only the tables within it, that would be absolutely fine. I have over 100 running on my test server (note to self - must do some housekeeping!) over half of which were generated from just one backup.

20 Jan 2008, 1:13 AM
#3
alhakeem2001 avatar

alhakeem2001

Zen Follower

Join Date:
Nov 2007
Posts:
434
Plugin Contributions:
1

Re: Having a second ZC on the same server as a Backup.

OK, that's what I got after successfully installing my second ZC and replacing the SQL with the backed up SQL from my original ZC, at admin page I got this error :

Warning: require(includes/languages/arabic.php) [function.require]: failed to open stream: No such file or directory in /home/.whispa/alhakeem2001/arab-broker/orientalmeal2/admin/includes/init_includes/init_languages.php on line 31

Fatal error: require() [function.require]: Failed opening required 'includes/languages/arabic.php' (include_path='.:/usr/local/php5/lib/php:/usr/local/lib/php') in /home/.whispa/alhakeem2001/arab-broker/orientalmeal2/admin/includes/init_includes/init_languages.php on line 31
http://www.arab-broker.com/orientalmeal2/admin

and at main catalogue page I got just a blank page!
http://www.arab-broker.com/orientalmeal2/

There must be something wrong that I did? Any suggestions ?

20 Jan 2008, 1:19 AM
#4
kuroi avatar

kuroi

Totally Zenned

Join Date:
Apr 2006
Location:
London, UK
Posts:
10,475
Plugin Contributions:
11

Re: Having a second ZC on the same server as a Backup.

From which version of Zen Cart are the files for your new Cart? What is the version of the old database that you have imported? If the old database was older than the files, did you upgrade it to match them?

20 Jan 2008, 1:30 AM
#5
alhakeem2001 avatar

alhakeem2001

Zen Follower

Join Date:
Nov 2007
Posts:
434
Plugin Contributions:
1

Re: Having a second ZC on the same server as a Backup.

They are both from the same version, the 1.3.8a but in the old SQl I have my own products with all their details..

20 Jan 2008, 2:18 PM
#6
kuroi avatar

kuroi

Totally Zenned

Join Date:
Apr 2006
Location:
London, UK
Posts:
10,475
Plugin Contributions:
11

Re: Having a second ZC on the same server as a Backup.

It looks to me as though the catalog side is working. Although you have strict error reporting on and are getting a ton of notices, as I navigate around the site, I see no errors or even warnings.

The problem on the Admin site looks as though it is a mismatch between the database name/prefix and what is in your admin/inlcudes/configure.php file. Though since I can't see either from outside your server, it's not possible to be more specific.

20 Jan 2008, 6:22 PM
#7
alhakeem2001 avatar

alhakeem2001

Zen Follower

Join Date:
Nov 2007
Posts:
434
Plugin Contributions:
1

Re: Having a second ZC on the same server as a Backup.

OK, Now when I go to the front side I get this fatal error :

Fatal error: Class 'notifier' not found in /home/.whispa/alhakeem2001/arab-broker/orientalmeal2/includes/autoload_func.php on line 79

and on the admin side I get this error :

1146 Table 'orientalmeal2.zen_project_version' doesn't exist
in:
[select * from zen_project_version WHERE project_version_key = 'Zen-Cart Database' ]
If you were entering information, press the BACK button in your browser and re-check the information you had entered to be sure you left no blank fields.

I'm lost now !! I don't know what to do ! I was thinking of an option, Would that be possible just to copy the whole main ZC and upload it to the server and then upload the SQL of the main ZC to the database which has been set to the second ZC ?

20 Jan 2008, 8:37 PM
#8
kuroi avatar

kuroi

Totally Zenned

Join Date:
Apr 2006
Location:
London, UK
Posts:
10,475
Plugin Contributions:
11

Re: Having a second ZC on the same server as a Backup.

The Admin issue was addressed by my previous post. The catalog side problem has now changed into opne that is also commonly associated with inconsistencies between settings in the configure.php files and the actual local locations of files.

20 Jan 2008, 9:56 PM
#9
alhakeem2001 avatar

alhakeem2001

Zen Follower

Join Date:
Nov 2007
Posts:
434
Plugin Contributions:
1

Re: Having a second ZC on the same server as a Backup.

Now, if I want to build a new copy for my ZC based on the backup SQL from my main ZC! Is there a manual to fallow step by step to create a twin ZC to my original ZC.