Zen Cart Logo
Forums / Installing on a Linux/Unix Server / Configure.php error, even though the chmod is at 777

Configure.php error, even though the chmod is at 777

Locked

Views: 3,691

Results 1 to 7 of 7
This thread is locked. New replies are disabled.
24 Jan 2008, 9:28 AM
#1
ariejester avatar

ariejester

New Zenner

Join Date:
May 2007
Posts:
12
Plugin Contributions:
0

Configure.php error, even though the chmod is at 777

I have set the configure.php file in admin/includes and in the includes folder to 777 using SSH & Putty.
I have double checked this via my ftp program and all permissions has the tick box in them.
However I am installing zencart and it has come up with the error: "Error encountered while writing /includes/configure.php"
The permissions are at 777, I have checked the file size and its 3.1kb.
Can someone tell me why I have the error and what I am doing wrong?
The file is located at enchantedrealms.co.uk/htdocs/store/includes/configure.php
Thanks

24 Jan 2008, 10:04 AM
#2
ariejester avatar

ariejester

New Zenner

Join Date:
May 2007
Posts:
12
Plugin Contributions:
0

Re: Configure.php error, even though the chmod is at 777

Does anyone know what I've done wrong as I've been trying to install zencart for about a week now, due to permissions problems and all sorts, I finally got the permissions sorted and it still isn't working :(

24 Jan 2008, 10:11 AM
#3
yellow1912 avatar

yellow1912

Totally Zenned

Join Date:
Oct 2006
Posts:
5,422
Plugin Contributions:
0

Re: Configure.php error, even though the chmod is at 777

Shouldnt it be ```
http://enchantedrealms.co.uk/store/includes/configure.php


I suspect you are running PHP on CGI, Make sure you set the owner of the files correctly.
24 Jan 2008, 10:17 AM
#4
ariejester avatar

ariejester

New Zenner

Join Date:
May 2007
Posts:
12
Plugin Contributions:
0

Re: Configure.php error, even though the chmod is at 777

Yep I was just trying to show where the file was located in case anyone need to check it. When I look at the properties it says owner is: 201651.
Is that what it is meant to be? As I haven't changed anything there as far as I am aware.
How do I set the owner of the files properly and what should they be?
Thanks.

25 Jan 2008, 2:55 AM
#5
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: Configure.php error, even though the chmod is at 777

NOTE: during Installation or Upgrades you use 777 on the files:
/includes/configure.php
/admin/includes/configure.php

After the Installation or Upgrades you change to 644 or 444 as needed by your server to make the error go away that is warning you the file(s) are writable ...

On some servers this needs to be set via the Control Panel of your server to 444 and when updating in the future you will need to set to 644 to overwrite or 777 to Upgraded the configure.php files ...

26 Jan 2008, 5:04 PM
#6
sandykr09 avatar

sandykr09

New Zenner

Join Date:
Oct 2007
Posts:
38
Plugin Contributions:
0

Re: Configure.php error, even though the chmod is at 777

I am a serious new zenner. I basically have my website set up but when I try to change the configure.php and admin/configure.php to enable ssl, my website goes haywire. I am thinking that I need to do something with the permissions?? This is very intimidating for me. Is there a link that will walk me through this?
Please help
Sandy R

26 Jan 2008, 10:36 PM
#7
dbltoe avatar

dbltoe

Totally Zenned

Join Date:
Jan 2004
Location:
N of San Antonio TX
Posts:
9,799
Plugin Contributions:
15

Re: Configure.php error, even though the chmod is at 777

Has your host installed the certificate? If not, setting ssl to true will munge things up a bit.