Zen Cart Logo
Forums / General Questions / 404 Error - store down

404 Error - store down

Locked

Views: 985

Results 1 to 6 of 6
This thread is locked. New replies are disabled.
13 Feb 2008, 10:32 AM
#1
ignisserpentus avatar

ignisserpentus

New Zenner

Join Date:
Nov 2007
Posts:
11
Plugin Contributions:
0

404 Error - store down

Okies, so... I have a problem. Im getting 404 Page not found error when I try and click my store.

MY FIRST mistake is that my host is IPower :giggles: and they just moved me to vdeck 3.0. During that process, they left my zen database on the old platform, and then had to move it after I called them about it 3 times :groans: They finally did, and everything worked okay.... except my downloads. For some reason, I was getting page cannot be displayed, when clicking any download link in my acct (and the same when trying to check out anew to test it)

In the process of trying to resolve that, my friend (who also Zens) discovered that the home address for the files had changed from /home/myserver/catalog to something way longer. So I changed my configure file to match, to see if that would fix it. BAM, thats when the error occured and my store would no longer load. I changed it back to normal, reuploaded it, but it didnt fix it. Not even sure at this point if thats what did it. But I can tell you this much... my admin is working and phpbb works fine as well. It seems only to be my store not loading.

I havent changed any other files, and since it was working earlier, I dont really think that they copied all the files over incorrectly. Ive checked my permissions as well, they seem to be okay

My url is.... http://damageinc3d.net/catalog/index.php (not that you can see anything but an ugly 404 error)

At this point, Im out of ideas... any help would be so appreciated (and would save me money from having to buy wigs, coz Im gradually pulling all my hair out lol) Thanks!!!

13 Feb 2008, 11:00 AM
#2
website_rob avatar

website_rob

Inactive

Join Date:
Oct 2006
Location:
Alberta, Canada
Posts:
4,572
Plugin Contributions:
0

Re: 404 Error - store down

Best talk to your Hoster and find out what the correct path is.
Nothing else can be done till that is taken care of.

13 Feb 2008, 11:07 AM
#3
ignisserpentus avatar

ignisserpentus

New Zenner

Join Date:
Nov 2007
Posts:
11
Plugin Contributions:
0

Re: 404 Error - store down

Yeah kinna had a feeling that might be it - tho, that doesnt really explain why the admin still works, and the index doesnt (theyre both configured to the same directory) So it would logically follow... if one is broken, the other would be... but then, I dont really know. Maybe theres an explanation.

13 Feb 2008, 11:42 AM
#4
marcelo63 avatar

marcelo63

Zen Follower

Join Date:
Dec 2007
Posts:
125
Plugin Contributions:
0

Re: 404 Error - store down

IgnisSerpentus:

Yeah kinna had a feeling that might be it - tho, that doesnt really explain why the admin still works, and the index doesnt (theyre both configured to the same directory) So it would logically follow... if one is broken, the other would be... but then, I dont really know. Maybe theres an explanation.

seems like landing page is incorrect, but due your comments also zen is not finding the database either. consider migrating to a Zen certified hosting

13 Feb 2008, 11:46 AM
#5
ignisserpentus avatar

ignisserpentus

New Zenner

Join Date:
Nov 2007
Posts:
11
Plugin Contributions:
0

Re: 404 Error - store down

No, it sees the Database (unless some unknown table is missing - but if it was, it would have been all along, instead of working, then not working out of nowhere) All my customers are still in the backend... it (was) sending emails when it was working, I even put an order thru before it broke. It still sees all my files as well (like when I go to the define pages... it can locate and edit all those) So I dunno what the deal is.....

13 Feb 2008, 2:45 PM
#6
ann0314 avatar

ann0314

New Zenner

Join Date:
May 2006
Location:
Ohio
Posts:
51
Plugin Contributions:
0

Re: 404 Error - store down

I've been trying to help her with this as well. I know switching to a zen server seems like the easiest answer but as she has a huge site on there it would take days to move her whole site and then days more to get it all working again and that isnt a good answer for her at this point.

As for what's going on....her host chaged servers a day earlier and originally everything was working fine but the downloads for the store werent working. The table is there in the database...everything fine with it and the admin attrib controller shows all the downloads as green so they are there and zen sees them but it kept giving a 404 error but that was the only issue. Then we noticed it looked like her root may have chaged name (I used the Developers thingy to look up all files with the word download and the path to those files was diff then before) so we tried to mod her config file (backed up the old one first though) and it took the whole store down when all she chaged was the path to the DL folder..so then we replces that file with the original one but aen never came back up and still shows the 404 Error. When we replaced the file with the original it should have come back up..anyone know why it wouldnt?? THANKS for any and all help she really is pulling out her hair and bald isnt a good look on the poor girl O.o

HUGS!!!