Zen Cart Logo
Forums / General Questions / Email via fsockopen on 110mb.com

Email via fsockopen on 110mb.com

Locked

Views: 2,435

Results 1 to 4 of 4
This thread is locked. New replies are disabled.
25 Feb 2008, 8:04 AM
#1
windpower avatar

windpower

New Zenner

Join Date:
Feb 2008
Posts:
4
Plugin Contributions:
0

Email via fsockopen on 110mb.com

Hi, I have just installed zen-cart and it seems a great system. But one thing I can't get to work is sending emails. I don't have access to sendmail on the server, but I do have access to fsockopen. So I have set it to use smtpauth email, and set the smtp server stuff correctly. I keep getting the error:
Email Error: The following From address failed: [email protected] :lamo:
no matter what From adress etc. I try.
I have tried many combinations of Email settings without success. I have tried an smtp account at yahoo.com.au and also at gmail.com. I tried both yes and no for 'Emails must send from known domain?'. And also different 'Email Address (sent FROM)' addresses. And of course I carefully double checked all the 'SMTP Email' settings.

Has anyone got zen-cart working on 110mb.com? Can it work with fsockopen and not sendmail?

Please help!

Thanks in anticipation.

25 Feb 2008, 5:00 PM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Email via fsockopen on 110mb.com

Instead of trying to send through yahoo or gmail, why not use a normal traditional email account for sending?

25 Feb 2008, 8:44 PM
#3
windpower avatar

windpower

New Zenner

Join Date:
Feb 2008
Posts:
4
Plugin Contributions:
0

Re: Email via fsockopen on 110mb.com

Hi Doctor. Because the hosting site does not allow access to sendmail, only to fsockopen.

25 Feb 2008, 8:55 PM
#4
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Email via fsockopen on 110mb.com

yahoo and gmail usually don't let you send through their servers unless you have specific paid services established with them.
That is why you're getting rejections on your FROM email address ... because you're not authorized to send through their servers.

So, that's why I suggested that a better choice would be to test using SMTPAUTH and send mail through a normal email account with your hosting company.

The smtp/smtpauth methods use fsockopen.

Either that, or choose a more traditional hosting company to run your site from.