Zen Cart Logo
Forums / Installing on a Linux/Unix Server / How do you transfer from a dev WAMP server to a LAMP server?

How do you transfer from a dev WAMP server to a LAMP server?

Locked

Views: 6,481

Results 1 to 5 of 5
This thread is locked. New replies are disabled.
28 Feb 2008, 7:29 PM
#1
diannev avatar

diannev

New Zenner

Join Date:
Jul 2007
Location:
Johannesburg
Posts:
27
Plugin Contributions:
1

How do you transfer from a dev WAMP server to a LAMP server?

I have a perfectly running Zencart on my development server (which is WAMP). I now need to transfer the entire site to the real server which is LAMP. And I have a disaster on my hands... this is the whole story

First attempt:

First I tried to simply backup the database and import it into the new site, and then FTP the files across. (I've been moving the site to and from my laptop this way and it never had a problem). It was mostly fine but the product listing was showing in 1 column and not 3 and nothing I did would change it. I kept hitting new file permission problems so I decided I had been silly...

Site 2...

I asked the host to put the old site aside, and installed zencart exactly as it should be. I imported individual tables, and FTP'd my files. The site basically doesn't work. It connects to databases but there are continual errors and I can't get into admin at all.

Site 3...

Please tell me - is it possible to move a working site from a WAMP development server to a LAMP server. And is the 1column/3 column problem familiar to anyone.

I've been doing this for three days now and my deadline is Sunday. I have no idea what to try next. Please can anyone help. :cry:

I will reset the configure files on my own server so you can see both.

http://www.intercommunity.co.za/grandiflora - my server
http://www.grandifloradirect.co.za - their server

The world is divided into 10 kinds of people, those who understand binary and those who don't.

28 Feb 2008, 10:30 PM
#2
website_rob avatar

website_rob

Inactive

Join Date:
Oct 2006
Location:
Alberta, Canada
Posts:
4,572
Plugin Contributions:
0

Re: How do you transfer from a dev WAMP server to a LAMP server?

http://www.grandifloradirect.co.za/ - gives me an error msg. stating some files are missing.
In this case:
includes/templates/template_default/common/html_header.php

It's not uncommon that when uploading many files (over 1,000 for example) that for various reasons some uploads will fail. If your FTP program does not tell you about failures then best to upload one directory at a time.

i.e. first the 'admin' then the 'includes' as they are the two largest. All other directories can be uploaded at the same time.

The learning is in the doing.

Potent Products

28 Feb 2008, 11:47 PM
#3
kobra avatar

kobra

Black Belt

Join Date:
Aug 2005
Location:
Arizona
Posts:
31,500
Plugin Contributions:
4

Re: How do you transfer from a dev WAMP server to a LAMP server?

Looked at both and do not see your column issue??

I do see this

Warning: imagejpeg() [function.imagejpeg]: Unable to open '/home/grandifl/public_html/bmz_cache/1/189e1cf27d422bdd2f656d80783cda2b.image.120x120.jpg' for writing in /home/grandifl/public_html/includes/classes/bmz_image_handler.class.php on line 652

and this can be corrected in the admin ih2 config by removing the cache and rebuilding - watch permissions on the cache folder for ih2

Zen-Venom Get Bitten

29 Feb 2008, 6:21 AM
#4
diannev avatar

diannev

New Zenner

Join Date:
Jul 2007
Location:
Johannesburg
Posts:
27
Plugin Contributions:
1

Re: How do you transfer from a dev WAMP server to a LAMP server?

Thank you - I found a permissions problem on the cache folder. I will redo the cache. Thank you so much for your help.

The world is divided into 10 kinds of people, those who understand binary and those who don't.

29 Feb 2008, 8:02 AM
#5
diannev avatar

diannev

New Zenner

Join Date:
Jul 2007
Location:
Johannesburg
Posts:
27
Plugin Contributions:
1

Re: How do you transfer from a dev WAMP server to a LAMP server?

After a very long night, I think I have solved most of my problems - here are the solutions in case others have them.

  1. The 3 to 1 column issue - a capital letter in a templates folder name. The folder wasn't in the usual templates folders so I never even came across it. I could probably have kept my very first installation if I had noticed it earlier.

  2. Most of the error messages were folder permissions. I suspect as I do things I will find more.

  3. The images problems were being caused by .JPG files instead of .jpg.

  4. The biggest problem was being caused by the events calendar. The problem was actually fairly straightforward - the comments were being delineated with // instead of /** and */ . I changed each of the files and it now seems to be working. I will put this notice on the events calendar forum also because its actually a really nice module.

Three things that matter on Llinux and not windows servers:

  1. Capital letters
  2. Exact folder permissions - windows permissions are "fuzzier" and don't transfer
  3. // shouldn't be used to comment.

The world is divided into 10 kinds of people, those who understand binary and those who don't.