Zen Cart Logo
Forums / Upgrading from 1.3.x to 1.3.9 / Cannot connect to database in store after upgrade

Cannot connect to database in store after upgrade

Locked

Views: 3,508

Results 1 to 6 of 6
This thread is locked. New replies are disabled.
5 Mar 2008, 3:34 AM
#1
jcattanach avatar

jcattanach

New Zenner

Join Date:
Sep 2005
Posts:
17
Plugin Contributions:
0

Cannot connect to database in store after upgrade

I upgraded to Zencart 1.3.8a, which then wanted to upgrade my database, after which I get the following message on my website (store):

Sorry!
There seems to be a problem connecting to our database. Please give us a few minutes to remedy the problem. Thank you.

I can log into my admin pages fine and can see my database records, but just can't connect in my website store. Both my configure.php files are the same. I have played around with a few changes but none have worked. I have created another user and password and tried to use that but it never worked either. My brainstorming is not storming anymore. I'd appreciate any help.

5 Mar 2008, 4:11 AM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Cannot connect to database in store after upgrade

jcattanach:

Both my configure.php files are the same.Identical?
They shouldn't be.

5 Mar 2008, 4:21 AM
#3
jcattanach avatar

jcattanach

New Zenner

Join Date:
Sep 2005
Posts:
17
Plugin Contributions:
0

Re: Cannot connect to database in store after upgrade

No, sorry, I meant that they were the same with regards to the database name, username, password info (in define our database connection)

5 Mar 2008, 6:09 AM
#4
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Cannot connect to database in store after upgrade

What permission level is set on your /includes/configure.php file?

6 Mar 2008, 5:30 AM
#5
jcattanach avatar

jcattanach

New Zenner

Join Date:
Sep 2005
Posts:
17
Plugin Contributions:
0

Re: Cannot connect to database in store after upgrade

Permission level is 644

6 Mar 2008, 6:10 AM
#6
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Cannot connect to database in store after upgrade

jcattanach:

Sorry!
There seems to be a problem connecting to our database. Please give us a few minutes to remedy the problem. Thank you.This message only appears when Zen Cart cannot connect to your database successfully.

How it works:
a) the configure.php file is read, loading the database settings
b) a connection to the database is attempted
c) if a failure happens here, you'll get that message
d) if connection is successful, it attempts to access the specified database-name
e) if a failure happens here, you'll get that error message
f) if connection is successful, normal store operation proceeds.

So, if the configure.php file is incomplete, not readable by PHP, or has PHP syntax errors in it, you'll have a problem.
If the database settings cannot be used to successfully connect to the database and access the group of tables used for Zen Cart, you'll have a problem.