Zen Cart Logo
Forums / Upgrading from 1.3.x to 1.3.9 / 1.3.6 - 1.3.8a database upgrade GRRRRR!

1.3.6 - 1.3.8a database upgrade GRRRRR!

Locked

Views: 2,564

Results 1 to 7 of 7
This thread is locked. New replies are disabled.
18 Mar 2008, 7:59 PM
#1
pat_allosaurs avatar

pat_allosaurs

New Zenner

Join Date:
May 2006
Posts:
33
Plugin Contributions:
0

1.3.6 - 1.3.8a database upgrade GRRRRR!

I've followed the instructions carefully but I'm still not getting the database upgrade to work.

I've been careful to do the upgrades one at a time - ie from 1.3.5 to 1.3.7, and then from 1.3.7 to 1.3.8a on a fresh (not live) site, I'm not choosing the install option, I'm fairly sure I'm doing it by the book. But when I go from 1.3.5 to 1.3.7 I get this:-

16 segments processed 1 statement ignored

SKIPPED: cannot insert configuration key "DEFINE_PAGE_NOT_FOUND_STATUS" because it already exists

(that comes up four times in red at the bottom of the screen)

Because there is a message on the screen saying that this alert probably doesn't matter, I went ahead with the 1.3.7 to 1.3.8a upgrade. This time I got:-

7 statements processed note: 1 statement ignored

SKIPPED: cannot ALTER or INSERT/REPLACE into table linkpoint api because it does not exist. CHECK PREFIXES!

Anyone have the faintest idea what this means? I don't understand code at all but I'm good at following instructions :smile:

List of addons in case it's helpful:-

Image handler
Google analytics
Paypal verification seal
Column layout grid for product listing
I also used the uk template patch if I remember rightly

Any help MUCH appreciated, let me know if any more details are needed. My site's been down for two days now while I blunder about, time to ask for help!

Cheers,

Pat

18 Mar 2008, 8:34 PM
#2
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: 1.3.6 - 1.3.8a database upgrade GRRRRR!

One thing that helps is to check the first box suggested and uncheck the others ... then run that one only ...

Now, hit the RE-CHECK ... then set the next box to be run ...

Do you use Linkpoint?

18 Mar 2008, 9:00 PM
#3
pat_allosaurs avatar

pat_allosaurs

New Zenner

Join Date:
May 2006
Posts:
33
Plugin Contributions:
0

Re: 1.3.6 - 1.3.8a database upgrade GRRRRR!

Ajeh, I just figured out that I was being sloppy :blush:

I'd done everything right except for changing the database name and password in
admin/includes/configure.php

Now I have, and the upgrade ran smooth as silk :clap:

Just shows that if you are overtired and your eyes are going funny looking at the code you should take a break because you'll make mistakes and you need to come back fresh to check them out!

Thanks for getting back to me, I appreciate it

Cheers

Pat

19 Mar 2008, 5:53 PM
#4
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: 1.3.6 - 1.3.8a database upgrade GRRRRR!

I hate when it does what we say and not what we mean ... :blink:

Thanks for the update! :smile:

21 Mar 2008, 2:58 AM
#5
bxdavi2 avatar

bxdavi2

New Zenner

Join Date:
Mar 2008
Posts:
9
Plugin Contributions:
0

Re: 1.3.6 - 1.3.8a database upgrade GRRRRR!

Is there anyway to get rid of the upgrade error at the top if I don't want to upgrade at this time?

13 Jul 2009, 5:59 AM
#6
henryk avatar

henryk

New Zenner

Join Date:
Nov 2008
Posts:
6
Plugin Contributions:
0

Re: 1.3.6 - 1.3.8a database upgrade GRRRRR!

I had a similar error after the upgrade failed when I tried to do it via Fantastico (not so fantastic on that occassion).

After not getting anywhere after trying to run just the DB scripts again, I ran the option "Update Config" on that same DB update page and everything seems in sync now.

13 Jul 2009, 7:40 AM
#7
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: 1.3.6 - 1.3.8a database upgrade GRRRRR!

henryk:

I had a similar error after the upgrade failed when I tried to do it via Fantastico (not so fantastic on that occassion).
:eek: EEK! NEVER use Fantastico to do an upgrade. Always do it manually.

Their script doesn't actually do anything other than replace original files with newer versions. And that's not only dangerous, it's very incomplete. You will still need to manually compare all your customized files and templates and make all appropriate adjustments.