Zen Cart Logo
Forums / Installing on a Linux/Unix Server / Digital downloads issues (error 500)

Digital downloads issues (error 500)

Locked

Views: 1,437

Results 1 to 5 of 5
This thread is locked. New replies are disabled.
28 Mar 2008, 5:40 PM
#1
paullell avatar

paullell

New Zenner

Join Date:
Mar 2008
Posts:
3
Plugin Contributions:
0

Digital downloads issues (error 500)

Hey,

I couldn't find any reference to this specific issue through search or general browsing so if I missed something and this has already been addressed please let me know and I will go seek it out there.

Anyway, here we go...

I have installed ZC on my new host server, Linux based, and am getting it all set up very nicely. However, in testing things out I have encountered an issue with downloading digital product.

The entire shopping experience comes off without a hitch until I get to the download portion of the event. Once I click the Download button I get an Internal Server Error 500.

I have the cart configured stock except for its appearance which has been mostly modded via the admin control panel and some custom images, nothing major.

The DL manager has green lights on all the files I am testing with so I know it can see them alright. I have dialogued (if you can call it that) with my host's tech support and they suggest A) checking all .htaccess files for OPTION and ErrorDocuments and to remove those refs and B) to default back to the out of the box 'look' of the cart.

So I used the developer tools to search out the suggested lines and found nothing and I cannot fathom why the appearance of the cart while using the included modular controls to adjust it has anything at all to do with the issue at hand.

If it makes any difference at all, I have the files in a sub-directory within the downloads folder but as I said, the lights are all green so I didn't think that should be an issue either.

I had this working on my test host before I set this all up, using the exact same configuration/settings which leads me to believe that it is the host's issue, not mine, since that is the only real difference between the two situations.

At this point I just need some help troubleshooting this out so I can call my host and beat them senseless with facts and get them to take some responsibility for their issues. If it ISN'T their fault then I would like some assistance tweaking this situation to make it go.

Thanks in advance for any assistance and please let me know if any more/different info would be of assistance here.

28 Mar 2008, 5:56 PM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Digital downloads issues (error 500)

Your host was likely right about the .htaccess comment, because they've likely set up restrictions to prevent you from being able to control your own security.
Look in your /pub/.htaccess file. There is a reference to Options there. Try removing that. It may or may not help.

Alternatively, you could change your download method to streaming instead of redirect ... Admin->Configuration->Attribute Settings .... turn off redirect, and turn on streaming.

28 Mar 2008, 7:01 PM
#3
paullell avatar

paullell

New Zenner

Join Date:
Mar 2008
Posts:
3
Plugin Contributions:
0

Re: Digital downloads issues (error 500)

That seems to have done it actually. It is interesting how there are so many .htaccess files in this application and none of the help files are terribly specific on which ones need to be modified in order to affect certain changes.

Maybe I am just that much of a PHP novice...

Anyway, thank you for your assistance. Here's another question... If I put this block of code in the .htaccess file in my /download directory is the syntax correct for blocking visibility to the referenced file extensions?

<Files *.mov, *.flv, *.wma, *.avi, *.mp4, *.zip>
Order Deny,Allow
Deny from all
</Files>

28 Mar 2008, 11:04 PM
#4
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Digital downloads issues (error 500)

PaulLell:

That seems to have done it actually. It is interesting how there are so many .htaccess files in this application and none of the help files are terribly specific on which ones need to be modified in order to affect certain changes.

Maybe I am just that much of a PHP novice....htaccess has nothing to do with PHP.
It's an Apache Webserver thing.
There are lots of tutorials about it online. Just google: Apache htaccess

PaulLell:

If I put this block of code in the .htaccess file in my /download directory is the syntax correct for blocking visibility to the referenced file extensions?
No, if I'm not mistaken, you can't list multiple file extensions in one directive.

But, why are you doing that anyway?
The supplied .htaccess works around the security issue for the /downloads/ folder differently, by denying access to a directory listing, and also requiring authentication to browse files, with no accessible authentication, thus blocking everyone.

Or, if it's real security you're after, maybe you should just make the folder inaccessible to browsers:
https://www.zen-cart.com/tutorials/index.php?article=280

28 Mar 2008, 11:10 PM
#5
paullell avatar

paullell

New Zenner

Join Date:
Mar 2008
Posts:
3
Plugin Contributions:
0

Re: Digital downloads issues (error 500)

DrByte:

.htaccess has nothing to do with PHP.
It's an Apache Webserver thing.
There are lots of tutorials about it online. Just google: Apache htaccess

No, if I'm not mistaken, you can't list multiple file extensions in one directive.

But, why are you doing that anyway?
The supplied .htaccess works around the security issue for the /downloads/ folder differently, by denying access to a directory listing, and also requiring authentication to browse files, with no accessible authentication, thus blocking everyone.

Or, if it's real security you're after, maybe you should just make the folder inaccessible to browsers:
https://www.zen-cart.com/tutorials/index.php?article=280

See how much of a novice I am? laughs

As to the question of the download directory access, I just want to make it as impregnable as possible since that directory is going to be my bread and butter so to speak. I don't want any of that material getting wrenched out of there without payment.

I had it set up in a different directory before but the download problem came up and I moved it back to default positioning as a troubleshooting step. Maybe I'll move it back again and see if the Dl still works smoothly now (thanks again for the assistance by the way).