Zen Cart Logo
Forums / General Questions / 1030 Got error 134 from storage engine

1030 Got error 134 from storage engine

Locked

Views: 7,288

Results 1 to 8 of 8
This thread is locked. New replies are disabled.
4 Apr 2008, 3:31 AM
#1
susb8383 avatar

susb8383

Zen Follower

Join Date:
Feb 2008
Posts:
129
Plugin Contributions:
0

1030 Got error 134 from storage engine

Hi,

New to Zen Cart. I started getting this error for the db_cache table. The only thing I did was delete a product that was in multiple categories. Would that be the cause? After I deleted and refreshed the page, the product correctly disappeared. I don't know when this error started appearing.

Anyone know how to fix it?

TIA, Susie

5 Apr 2008, 3:01 PM
#2
susb8383 avatar

susb8383

Zen Follower

Join Date:
Feb 2008
Posts:
129
Plugin Contributions:
0

Re: 1030 Got error 134 from storage engine

Ok, fixed. I didn't realize it was a server (database) error and not a Zen Cart error. Got a tip from another forum that fixed it--I ran Repair on the database. Note for newbies like me: in cpanel you won't find this under PhpMyAdmin, you'll find it under MySql Databases. First I ran Check Databases to confirm the error on the table (the full error I got said the error was in db_cache) and then ran repair.

The database you need to repair will be username_zc1 (or 2 or 3, etc. if you have more than one instance of zen cart installed).

Most people would know this, but as I said, I'm a newbie.

18 Apr 2008, 1:58 PM
#3
trappersam avatar

trappersam

New Zenner

Join Date:
Jun 2007
Posts:
16
Plugin Contributions:
0

Re: 1030 Got error 134 from storage engine

Thanks susb8383 for answering you own question i am a newbie too and i was about to panic until i saw you fine words. I didnt know where to look either but i followed you example and phumph. it worked. Thanks again
Trappersam

When you think you have looked everywhere. You havnt cos if you had you would not be still looking?:clap:

13 Jan 2009, 6:47 AM
#4
babycharmer avatar

babycharmer

New Zenner

Join Date:
Dec 2007
Posts:
12
Plugin Contributions:
0

Re: 1030 Got error 134 from storage engine

THANK YOU THANK YOU THANK YOU!!!!!! I wouldn't have gotten it fixed without your wonderful post and directions on the my sql... a million thanks!

God Bless,
Holly

13 Jan 2009, 7:44 PM
#5
susb8383 avatar

susb8383

Zen Follower

Join Date:
Feb 2008
Posts:
129
Plugin Contributions:
0

Re: 1030 Got error 134 from storage engine

So glad I could help!

--Susie

24 Jun 2009, 9:38 AM
#6
sourcez avatar

sourcez

New Zenner

Join Date:
Oct 2008
Posts:
8
Plugin Contributions:
0

Re: 1030 Got error 134 from storage engine

Thanks for that, just helped me out :)

12 May 2010, 6:02 AM
#7
muteyaar avatar

muteyaar

Zen Follower

Join Date:
Oct 2007
Posts:
134
Plugin Contributions:
0

Re: 1030 Got error 134 from storage engine

Thanks for this wonderful post.

I had the same problem .

I did just described by you, and lo.....
it is fine again.

thanks again.

regards,

muteyaar


:clap::clap::clap:

28 Dec 2010, 9:54 PM
#8
black68gtx avatar

black68gtx

New Zenner

Join Date:
Dec 2010
Posts:
34
Plugin Contributions:
0

Re: 1030 Got error 134 from storage engine

I know that this was an old post but very helpful. I had two carts (one active, one testing) both had the problem "1030 Got error 134 from storage engine
in:
[select count(*) as count from banners_history where banners_id = '0' and date_format(banners_history_date, '%Y%m%d') = date_format(now(), '%Y%m%d')]

I'm not sure what caused it, my host serviced the server over the weekend?

Thanks for the helpful post.