Forums / Upgrading from 1.3.x to 1.3.9 / Error message when trying to run upgrade 1.3.7 to 1.3.8

Error message when trying to run upgrade 1.3.7 to 1.3.8

Locked

Views: 3,095

Results 1 to 6 of 6
This thread is locked. New replies are disabled.
9 Apr 2008, 9:00 PM
#1
huwmac avatar

huwmac

New Zenner

Join Date:
Jun 2007
Location:
UK
Posts:
21
Plugin Contributions:
0

Error message when trying to run upgrade 1.3.7 to 1.3.8

getting the following error when I choose upgrade cfg files, maybe some kind soul can interpret:

1062 Duplicate entry 'Customers who have never completed a purchase' for key 2
in:
[INSERT INTO query_builder (query_category, query_name, query_description , query_string) VALUES ('email,newsletters', 'Customers who have never completed a purchase', 'For sending newsletter to all customers who registered but have never completed a purchase', 'SELECT DISTINCT c.customers_email_address as customers_email_address, c.customers_lastname as customers_lastname, c.customers_firstname as customers_firstname FROM TABLE_CUSTOMERS c LEFT JOIN TABLE_ORDERS o ON c.customers_id=o.customers_id WHERE o.date_purchased IS NULL');]

The database files seem to be upgraded - version ifno is as follows:

Zen Cart 1.3.7

Database Patch Level: 1.3.8

TIA

9 Apr 2008, 9:11 PM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Error message when trying to run upgrade 1.3.7 to 1.3.8

That means you've run the upgrade process once already and now you're getting errors when you run it the second time.

The fastest way around the problem is to locate that particular statement in the /zc_install/sql/mysql_upgrade_137_to_138.sql file, and put a # in front of it, and run the 137-to-138 upgrade step again from your browser.

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

9 Apr 2008, 11:03 PM
#3
huwmac avatar

huwmac

New Zenner

Join Date:
Jun 2007
Location:
UK
Posts:
21
Plugin Contributions:
0

Re: Error message when trying to run upgrade 1.3.7 to 1.3.8

OK done that now I'm stuck with the following errors:
and the version remains at 13.7 / 1.3.8
:dontgetit

SKIPPED: Cannot insert configuration_key "SHOW_SHOPPING_CART_COMBINED" because it already exists
SKIPPED: Cannot insert configuration_key "ORDER_COMMENTS_INVOICE" because it already exists
SKIPPED: Cannot insert configuration_key "ORDER_COMMENTS_PACKING_SLIP" because it already exists
SKIPPED: Cannot ADD column module_name because it already exists.
SKIPPED: Cannot ADD column module_mode because it already exists.
SKIPPED: Cannot ADD column module_name because it already exists.
SKIPPED: Cannot ADD column module_mode because it already exists.
SKIPPED: Cannot create table nochex_apc_transactions because it already exists
SKIPPED: Cannot create table nochex_sessions because it already exists
SKIPPED: Cannot create table nochex_sessions because it already exists
SKIPPED: Cannot create table nochex_sessions because it already exists
SKIPPED: Cannot create table nochex_sessions because it already exists
SKIPPED: Cannot CHANGE column zen_order_id because it does not exist.
SKIPPED: Cannot CHANGE column zen_order_id because it does not exist.
SKIPPED: Cannot ALTER or INSERT/REPLACE into table linkpoint_api because it does not exist. CHECK PREFIXES!

9 Apr 2008, 11:45 PM
#4
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Error message when trying to run upgrade 1.3.7 to 1.3.8

Those informational messages are all very expected.

What version information is showing in your admin area, under Tools->Server Info?

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

10 Apr 2008, 7:23 AM
#5
huwmac avatar

huwmac

New Zenner

Join Date:
Jun 2007
Location:
UK
Posts:
21
Plugin Contributions:
0

Re: Error message when trying to run upgrade 1.3.7 to 1.3.8

Its says

Zen Cart 1.3.7

Database Patch Level: 1.3.8

v1.3.8 [2008-04-05 18:21:48] (Version Update 1.3.7->1.3.8)
v1.3.7 [2007-06-09 21:39:54] (Fresh Installation)

10 Apr 2008, 7:24 AM
#6
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Error message when trying to run upgrade 1.3.7 to 1.3.8

That means you've upgraded your database, but haven't upgraded your site's PHP files yet.

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.